指标汇总
神奇指标广告
通达信双色分水岭框架提示点
来源:通达信公式 5309次浏览 发布时间2022-11-29

通达信双色分水岭框架提示点

围绕市场的热点,涨停做文章,是我的交易系统的选股策略。不同的个性,理解会出现各自 不同的重点参与阶段。有的做拉升,有的做高位盘整,有的做第二波。还是细化到各个阶段的每个细节,这里绝对是有规律性的东西,变化很多,但是有共性的东西存在。

温故而知新,看过历史上几千张K线图的,经历过无数次同类型的战斗,就有明确的心得。至于盘中实施操作,的确更多时候靠即时盘感与条件反射。

掌握市场的根本,胜利接踵而至;如果被别人掌握了根,就会失败。买卖那一刻的冷静不仅是对股票走势的信心,更是自身境界的体现。小资金做大需要一些天赋和理解,不是每个人都能做到。短期内可以做到的核心是,首先,如果你的模式是正确的,你就不能没有模式,也不能走弯路。你需要不断地尝试和犯错误,比如经常看你的交割单,哪些赚了钱,哪些赔了钱,你需要不断地纠正和调节自己。

在这个指标中,红K波段持有上升趋势,绿顶冲高减仓,蓝k下跌卖出,上轨不减仓,下轨超卖反弹,中线分水岭,形态清晰,信号明显。



N:=17;
M:=18;
红K波段升势持股:0,COLORRED,NODRAW;
绿顶冲高减仓:0,COLOR00FF88,NODRAW;
蓝K波段跌势卖出:0,COLORFF6D00,NODRAW;
上轨不过减仓:0,COLOR00FF00,NODRAW;
下轨超跌反弹:0,COLORWHITE,NODRAW;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
BB:=ABS((CLOSE+2*HIGH+LOW)/4-MA(CLOSE,17))/MA(CLOSE,17);
DD:=DMA(CLOSE,CC);
EE:=DMA(CLOSE,BB);
低吸:=REF((1-3/100)*EE,2);
强弱分界线:=EMA(低吸,7),LINETHICK2,COLORFF6C00;
短支撑:=EMA((LLV((C+L)/2,6)+LLV((C+L)/2,5)+LLV((C+L)/2,4)+LLV((C+L)/2,3)+LLV((C+L)/2,2)+2*(C+L+H)/3)/7,3),COLORWHITE;
波段趋势:=EMA(短支撑,4);
涨幅:=(C-REF(C,1))/REF(C,1)*100;
走平支撑线:=LLV((HIGH+2*LOW+OPEN+CLOSE)/5*2.03-H,30)*1.006,COLORABFF40,LINETHICK2;
穿两线:=((CROSS(C,短支撑) AND CROSS(C,波段趋势)) OR (L<短支撑 AND C>波段趋势 AND 短支撑<波段趋势 ))AND 短支撑>REF(短支撑,1) AND C>REF(C,1)*1.02 AND (C-O>H-C) AND V>REF(V,1) AND (C>强弱分界线 OR C<强弱分界线 AND C>REF(C,1)*1.07);
DRAWTEXT(穿两线,L*0.985,'上攻'),COLORFF00FF;
STICKLINE(穿两线,H,L,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(穿两线,O,C,4.5,1),COLORYELLOW,LINETHICK2;
B1:=MA(CLOSE,N)+MA(CLOSE,N)-REF(MA(CLOSE,N),1);
分水岭:IF(MA(CLOSE,N)<B1,B1,MA(CLOSE,N)),COLORRED,LINETHICK2;
IF(分水岭<REF(分水岭,1),分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
IF(分水岭>REF(分水岭,1)*0.999,分水岭,DRAWNULL),COLORRED,LINETHICK3;
DRAWTEXT(ISLASTBAR,分水岭,'【分水岭】'),COLORRED;
DDD:=分水岭<REF(分水岭,1);
IF(DDD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
操作线:=分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;
IF((操作线<REF(操作线,1) AND C<操作线) OR (操作线>REF(操作线,1) AND C<操作线),操作线,DRAWNULL),COLORFF6C00,LINETHICK2;
B2:=MA(CLOSE,M)+MA(CLOSE,M)-REF(MA(CLOSE,M),1);
分水岭2:=IF(MA(CLOSE,M)<B2,B2,MA(CLOSE,M));
操作线2:=分水岭2-(EMA(C,3)-分水岭2);
短线:=MA(C,5),COLORWHITE,LINETHICK2;
IF(短线>=REF(短线,1),短线,DRAWNULL),COLORFF00FF,LINETHICK2;
IF(短线<REF(短线,1),短线,DRAWNULL),COLORFF9900,LINETHICK2;
CC0:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD0:=DMA(CLOSE,CC0);
上轨:(1+8/100)*DD0,POINTDOT,COLORYELLOW;
IF(H>上轨,上轨,DRAWNULL),POINTDOT,LINETHICK4,COLOR00FF00;
下轨:(1-8/100)*DD0,POINTDOT,COLORFF00FF;
S:=(短线>操作线);
IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
买入红箭头:=CROSS(分水岭,操作线) AND C-O>H-C AND 涨幅>1;
DRAWICON(买入红箭头,L*0.985,1);
白K转折点:=(CROSS(C,分水岭) AND CROSS(C,操作线)) OR (L<操作线 AND CROSS(C,分水岭) AND C>MA(C,6) AND C>操作线)
OR (L<操作线 AND C>操作线 AND C>分水岭 AND C>MA(C,6)) OR (分水岭>操作线 AND CROSS(C,分水岭) AND CROSS(C,MA(C,6) ));
STICKLINE(白K转折点,OPEN,CLOSE,3.5,0),COLOR0055FF;
STICKLINE(白K转折点,OPEN,CLOSE,3,0),COLOR0099FF;
STICKLINE(白K转折点,OPEN,CLOSE,2.2,0),COLOR00BBFF;
STICKLINE(白K转折点,OPEN,CLOSE,1.5,0),COLOR00DDFF;
STICKLINE(白K转折点,OPEN,CLOSE,0.4,0),COLOR00FFFF;
STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99 ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99,OPEN,CLOSE,3,1 ),COLOR0000CC;
STICKLINE(C>操作线 AND 操作线>REF(操作线,1),HIGH,LOW,0,0 ),COLORRED;
STICKLINE(C>操作线 AND 操作线>REF(操作线,1) ,OPEN,CLOSE,2.8,0 ),COLOR0000AA;
STICKLINE((C<操作线2) AND C<O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,0),COLORFF6C00;
STICKLINE((C<操作线2) AND C>O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,1),COLORFF6C00;
STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,C,H,0.1,0),COLORFF6C00;
STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,O,L,0.1,0),COLORFF6C00;
波段卖出:=短线>分水岭 AND CROSS(操作线2,C) OR (COUNT(白K转折点 OR 买入红箭头,3)>0 AND CROSS(操作线2,C)) OR (CROSS(分水岭,短线)AND REF(H,1)>分水岭 AND C<短线 AND REF(H,1)>分水岭) ;
卖出:=COUNT(CROSS(分水岭,短线),4)>=1 AND CROSS(短线,C) AND C<操作线2;
段头铡刀:= (CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭);
DRAWTEXT((白K转折点 OR 买入红箭头) AND 分水岭>REF(分水岭,1)*0.998 AND 涨幅>2.4 ,L*0.92,'买入'),COLORYELLOW;
DRAWTEXT(波段卖出 AND REF(波段卖出,1)=0 OR 卖出 ,H*1.02,'卖出'),COLOR00FF00;
DRAWTEXT(段头铡刀,H*1.035,'断头铡刀'),COLORF0F900;
洗盘回升:=(REF(段头铡刀,1)>0 AND 涨幅>9) OR (REF(段头铡刀,1)>0 AND C>REF(O,1) AND 涨幅>5);
DRAWTEXT(洗盘回升,L*0.98,'洗盘回升'),COLOR00FFFF;
STICKLINE(CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭 ,OPEN,CLOSE,3,0 ),COLOR00FF00;
A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
A3:=H>MA(C,5)*1.12;
AA:= A2 AND A3;
DRAWTEXT(AA,H*1.02,'高减'),COLORWHITE;
STICKLINE(AA,H,L,0.3,0),COLORFF0000;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
DRAWTEXT(CROSS(88,RSI) AND H>分水岭*1.2 AND H>MA(C,5)*1.09 ,(HIGH * 1.035),'高抛'),COLORYELLOW;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);




最新发布

相关文章

神奇指标广告