指标汇总
神奇指标广告
同花顺进攻撤退公式
来源:同花顺公式 9844次浏览 发布时间2022-09-05

以下是同花顺进攻撤退公式

同花顺进攻撤退公式

如果好用,就给个好评。共同学习,共同赚钱。

源码

量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),NODRAW;

AA10:MA(CLOSE,8),COLOR0000FF;

AA12:MA(CLOSE,12),COLOR0000FF;

BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);

BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);

MA13:=MA(CLOSE,13);

DRAWBAND(AA10,RGB(150,50,50),AA12,RGB(0,100,50));

X1:=(C+L+H)/3;

BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

EMA8:=EMA(C,8);

DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),

EMA8,'∠45上升'),colorwhite;

压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;

支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;

AA1:=AMOUNT/V;

BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L<MA(C,5)*0.921;

EE1:=V<MA(V,5)*1.5;

FF1:=BB1 AND CC1 AND DD1 AND EE1;

DRAWTEXT(FF1,(LOW* 0.99),'老鼠仓'),COLOR4080FF;

A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

黑马线:=EMA(A51,5);

A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));

DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,(HIGH* 0.97),'▲大黑马'),coloryellow;

LC:=REF(CLOSE,1);

RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

FF:=EMA(CLOSE,3);

MA15:=EMA(CLOSE,21);

DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLORA6E500;

DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶背离'),COLOR1880FF;

VAR2:=LLV(LOW,27);

VAR3:=HHV(HIGH,34);

VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;

注意买:=IF((VAR4<10),80,100);

RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

超跌:=IF(J<0,10,0);

BDDD:=LLV(J,2)=LLV(J,8);

买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);

DRAWTEXT(买入 AND 注意买=100 AND 超跌=0,LOW,'短线'),COLOR8000FF;

MTM:=C-REF(C,1);

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

DRAWTEXT(FILTER(买=1,5),LOW-0.03,'拉升'),COLORFFDE00;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0,0 ),COLOR0000FF;

STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0,0 ),COLOR0000FF;

STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0,0 ),COLOR00FF00;

STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0,0 ),COLOR00FF00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORFF8800;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORFFAA00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORFFCC00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLORFFEE00;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR000066;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR000088;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000AA;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLOR0000CC;

VAR9Q:=C=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV

(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);

STICKLINE(VAR9Q,C,(O+C)/2,3,0),COLOR000066;

STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR000088;

STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000AA;

STICKLINE(VAR9Q,C,(O+C)/2,0,0),COLOR0000CC;

VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);

STICKLINE(VARAQ,C,(O+C)/2,3,0),COLORFF22FF;

STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORFF44FF;

STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFF66FF;

STICKLINE(VARAQ,C,(O+C)/2,0,0),COLORFF88FF;

VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND

(REF(C,1)>HHV(C,4) OR REF(C,1)<HHV(C,4)) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);

STICKLINE(VARBQ,C,(O+C)/2,3,0),COLOR444444;

STICKLINE(VARBQ,C,(O+C)/2,2,0),COLOR666666;

STICKLINE(VARBQ,C,(O+C)/2,1,0),COLOR888888;

STICKLINE(VARBQ,C,(O+C)/2,0,0),COLORAAAAAA;

VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);

STICKLINE(VARCQ,O,(O+C)/2,3,0),COLOR004400;

STICKLINE(VARCQ,O,(O+C)/2,2,0),COLOR006600;

STICKLINE(VARCQ,O,(O+C)/2,1,0),COLOR008800;

STICKLINE(VARCQ,O,(O+C)/2,0,0),COLOR00AA00;

VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF

(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);

STICKLINE(VARDQ,O,(O+C)/2,3,0),COLORFF2200;

STICKLINE(VARDQ,O,(O+C)/2,2,0),COLORFF4400;

STICKLINE(VARDQ,O,(O+C)/2,1,0),COLORFF6600;

STICKLINE(VARDQ,O,(O+C)/2,0,0),COLORFF8800;

K_T1:=MA(H,5)*(1+5/100);

DRAWTEXT(CROSS(K_T1,C),H,'开盘就跑'),COLORFF8C00;

均价:=(3*C+H+L+O)/6;

VAR11:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;

TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR11;

立桩量:=FILTER(TJ1,5);

TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND

CLOSE>REF(HIGH,3),1,0)));

突破:=TJ2=1;

STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),colorcyan;

STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),coloryellow;

TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND

CLOSE>REF(LOW,3),1,0)));

三天法则:=TJ3=1;

成立:=三天法则 AND 突破;

条件成立:=FILTER(成立,3);

DRAWTEXT(条件成立,L*0.99,'成立'),coloryellow;

VAR21:=EMA(CLOSE,5);

VAR22:=EMA(CLOSE,5);

VAR23:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);

DRAWTEXT(CROSS(VAR22,VAR23),LOW*0.96,'B');

 

 

最新发布

相关文章

神奇指标广告