指标汇总
神奇指标广告
同花顺抄底逃顶 自动分析K线副图指标 源码
来源:同花顺公式 6758次浏览 发布时间2022-09-05

以下是同花顺抄底逃顶 自动分析K线副图指标 源码

工作线:EMA(CLOSE,50),colorred,LINETHICK1;
工作线2:EMA(CLOSE,13),LINETHICK1;
九号线:=EMA(CLOSE,99);
暴涨线:=MA(CLOSE,181);
牛:=EMA(CLOSE,144)>=REF(EMA(CLOSE,144),1);
 DRAWTEXT((工作线2>=REF(工作线2,1) AND
 L<工作线2 AND C>工作线2) ,L, '买'),coloryellow;
 DRAWTEXT((九号线>=REF(九号线,1) AND 牛 AND L<九号线 AND H>九号线)
AND ((CLOSE<REF(CLOSE,1) OR O>C)),L*0.98 , '●九号'),COLOR00FF00;
 DRAWTEXT((工作线>=REF(工作线,1) AND 牛 AND L<工作线 AND H>工作线)
AND ((CLOSE<REF(CLOSE,1) OR O>C)),L*0.94 , '★暴涨'),colormagenta;
黄昏之星:=((((((REF(CLOSE,2) / REF(OPEN,2)) > 1.03) AND (REF(OPEN,1) >
 REF(CLOSE,2))) AND ((ABS((REF(OPEN,1) - REF(CLOSE,1))) /
 REF(CLOSE,1)) < 0.02)) AND ((CLOSE / OPEN) < 0.97)) AND (CLOSE <REF(CLOSE,2)));
射击之星:=(((MIN(OPEN,CLOSE) = LOW) AND ((HIGH - LOW) > (3 *
 (MAX(OPEN,CLOSE) - LOW)))) AND (CLOSE > MA(CLOSE,5)));
锤头:=(((HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH -
 MIN(OPEN,CLOSE))))) AND (CLOSE < MA(CLOSE,5)));
吊颈:=(( (HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH -
 MIN(OPEN,CLOSE))))));
穿头破脚:=((((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN)
 < 0.96)) AND (CLOSE < REF(OPEN,1))) AND (OPEN > REF(CLOSE,1))) OR
 (((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) >
 1.04)) AND (CLOSE > REF(OPEN,1))) AND (OPEN < REF(CLOSE,1))));
身怀六甲:=(((((ABS((REF(CLOSE,1) - REF(OPEN,1))) / REF(CLOSE,1)) > 0.04)
 AND ((ABS((CLOSE - OPEN)) / CLOSE) < 0.005)) AND (MAX(CLOSE,OPEN) <
 MAX(REF(CLOSE,1),REF(OPEN,1)))) AND (MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1))));
乌云盖顶:=(((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN) <
 0.97)) AND (OPEN > REF(CLOSE,1))) AND (CLOSE < REF(CLOSE,1)));
曙光初现:=(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) >
 1.03)) AND (OPEN < REF(CLOSE,1))) AND (CLOSE > REF(CLOSE,1)));
倾盆雨:=(((((REF(CLOSE,1) / REF(OPEN,1)) >= 1.03) AND (OPEN <
 REF(CLOSE,1))) AND (OPEN > REF(OPEN,1))) AND (CLOSE < REF(OPEN,1)));
 DRAWTEXT(倾盆雨,H*1.03,'倾盆大雨'),colorcyan;
 DRAWTEXT(黄昏之星,H*1.02,'黄昏之星'),colorcyan;
 DRAWTEXT(射击之星,H*1.03,'射击之星可能见顶'),colorcyan;
 DRAWTEXT(锤头,L-L*0.02,'锤头可能见底'),colorgreen;
 DRAWTEXT(吊颈,H*1.03,'吊颈'),colorcyan;
 DRAWTEXT(穿头破脚,H*1.05,'穿头破脚'),colorcyan;
 DRAWTEXT(乌云盖顶,H*1.03,'乌云盖顶'),colorcyan;
 DRAWTEXT(曙光初现,L-L*0.02,'曙光初现(放量)'),colorgreen;
 DRAWTEXT(身怀六甲,L-L*0.02,'身怀六甲,底升顶落'),colorgreen;
 MA5:MA(CLOSE,5);
 MA20:MA(CLOSE,20);
 MA60:MA(CLOSE,60);
 DRAWTEXT(CROSS(ZIG(3,14),REF(ZIG(3,14),1)),LOW*1.001,'★底'),colorgreen;
 DRAWTEXT(CROSS(REF(ZIG(3,13),1),ZIG(3,13)),HIGH*1,'★逃顶'), colorred;
 PP:=ZIG(3, 19)>REF(ZIG(3,19),1) AND REF(ZIG(3,19), 1)<REF(ZIG(3,19), 2);
 VAR31:=BARSLAST(PP);
 STICKLINE(VAR31=2,L*0.95,L*0.98,1,0),COLOR0000FF;
 DRAWTEXT(VAR31=2,L*0.95,'3天'),coloryellow;
 STICKLINE(VAR31=4,H*1.05,H*1.02,1,0),COLOR9966FF;
 DRAWTEXT(VAR31=4,H*1.06,'5天'),coloryellow;
 STICKLINE(VAR31=7,L*0.95,L*0.98,1,0),COLOR00FFFF;
 DRAWTEXT(VAR31=7,L*0.95,'8天'),coloryellow;
 STICKLINE(VAR31=12,H*1.05,H*1.02,1,0),COLORFF33FF;
 DRAWTEXT(VAR31=12,H*1.06,'13天'),coloryellow;
 STICKLINE(VAR31=20,L*0.95,L*0.98,1,0),COLOR0066FF;
 DRAWTEXT(VAR31=20,L*0.95,'21天'),coloryellow;
 STICKLINE(VAR31=33,H*1.05,H*1.02,1,0),COLORFFFF00;
 DRAWTEXT(VAR31=33,H*1.06,'34天'),coloryellow;
 STICKLINE(VAR31=54,L*0.95,L*0.98,1,0),COLOR006600;
 DRAWTEXT(VAR31=54,L*0.95,'55天'),coloryellow;
 STICKLINE(VAR31=88,L*0.95,L*0.98,1,0),COLOR00FFFF;
 DRAWTEXT(VAR31=88,L*0.95,'89天'),coloryellow;
 STICKLINE(VAR31=143,H*1.05,H*1.02,1,0),COLORFF33FF;
 DRAWTEXT(VAR31=143,H*1.06,'144天'),coloryellow;
 STICKLINE(VAR31=232,L*0.95,L*0.98,1,0),COLOR0066FF;
 DRAWTEXT(VAR31=232,L*0.95,'233天'),coloryellow;
 STICKLINE(VAR31=376,H*1.05,H*1.02,1,0),COLORFFFF00;
 DRAWTEXT(VAR31=376,H*1.06,'377天'),coloryellow;
 STICKLINE(VAR31=609,L*0.95,L*0.98,1,0),COLOR006600;
 DRAWTEXT(VAR31=609,L*0.95,'610天'),coloryellow;

最新发布

相关文章

神奇指标广告