指标汇总
神奇指标广告
通达信彩色量能变化波动顶底macd
来源:副图指标公式 5416次浏览 发布时间2023-05-19

通达信彩色量能变化波动顶底MACD

换个思路,天地宽!

隔夜美股又是新高,且主要指数大涨。看着A股这走势,很多人都说赚钱不容易,尤其是最近反复震荡的走势,部分板块标的不要命的跌,推倒重建的呼声此起彼伏。

其实小蜂也有点沮丧。昨天晚上跟一位股市长青树老大哥聊了聊,启发很大。最近这两年,对他来说就是牛市。长线投资美股或指数基金。短线做A股趋势投资。不亦乐哉。其实他说的一些理念我都知道,但是有时执行的不是那么严格。今天就再跟大家谈一下。很多时候,必须要打开思路。主要是几点:

逆势抄底,没赚钱前不要重仓单一标的。

抬眼看世界。在国内,也有很多合法的手段投资投资全世界最好股市的机会。

拥抱趋势,拥抱新机会。不要封闭了眼界。

存在即合理。少一点抱怨,多点务实。我们的股市有自己的特点,去适应这个特点。

最悲观的时候,也是机会呈现的时候。

少看微博,多看新闻,独立思考。


P:=25;
S:=8;
M:=5;
M1:=14;
M2:=14;
M3:=9;
DRAWTEXT_FIX(1,0.01,0,0,'段底买进段顶抛,随波加减不可少;走势底部需确认,走势顶部尽早跑;心态平和看涨跌,股海淘金乐逍遥!'),COLORFF00FF;
TYP:= (HIGH + OPEN*2 +2*LOW + CLOSE)/6;
CCI:=(TYP-MA(TYP,M1))/(0.015*AVEDEV(TYP,M1));
WR:=(50-100*(HHV(HIGH,M2)-CLOSE)/(HHV(HIGH,M2)-LLV(LOW,M2)))*3;
RSV:=(CLOSE-LLV(LOW,M3))/(HHV(HIGH,M3)-LLV(LOW,M3))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=(3*K-2*D-50)*3;
PJZ:=(CCI+WR+J)/3;
DIFF1:=EMA(EMA(PJZ,S),3)*EMA(EMA(EMA(CLOSE,S),3),3)/100 - EMA(EMA(PJZ,P),5)*EMA(EMA(EMA(CLOSE,P),5),5)/100;
DEA1:=EMA(EMA(DIFF1,M),5);
CMACD:=2*(DIFF1-DEA1);
CCIL:=(TYP-MA(TYP,M1*25))/(0.015*AVEDEV(TYP,M1*25));
WRL:=(50-100*(HHV(HIGH,25*M2)-CLOSE)/(HHV(HIGH,25*M2)-LLV(LOW,25*M2)))*3;
RSVL:=(CLOSE-LLV(LOW,25*M3))/(HHV(HIGH,25*M3)-LLV(LOW,25*M3))*100;
KL:=SMA(RSV,25*3,1);
DL:=SMA(KL,3*25,1);
JL:=(3*KL-2*DL-50)*3;
PJZL:=CCIL+WRL+JL;
CDIFFL:=EMA(EMA(PJZL,S*25),3)*EMA(EMA(EMA(CLOSE,S*25),3),3)/100 - EMA(EMA(PJZL,P*25),5)*EMA(EMA(EMA(CLOSE,P*25),5),5)/100;
CDEAL:=EMA(EMA(CDIFFL,M*25),5);
CMACDL:=(CDIFFL-CDEAL);
STICKLINE(CMACDL>0,0,CMACDL,5,0),COLOR440044;
STICKLINE(CMACDL<0,0,CMACDL,5,0),COLOR440044;
CCIS:=(TYP-MA(TYP,M1*5))/(0.015*AVEDEV(TYP,M1*5));
WRS:=(50-100*(HHV(HIGH,5*M2)-CLOSE)/(HHV(HIGH,5*M2)-LLV(LOW,5*M2)))*3;
RSVS:=(CLOSE-LLV(LOW,5*M3))/(HHV(HIGH,5*M3)-LLV(LOW,5*M3))*100;
KSS:=SMA(RSVS,3*5,1);
DSS:=SMA(KSS,3*5,1);
JS:=(3*KSS-2*DSS-50)*3;
PJZS:=CCIS+WRS+JS;
CDIFFS:=EMA(EMA(PJZS,S*5),3)*EMA(EMA(EMA(CLOSE,S*5),3),3)/100 - EMA(EMA(PJZS,P*5),5)*EMA(EMA(EMA(CLOSE,P*5),5),5)/100;
CDEAS:=EMA(EMA(CDIFFS,M*5),5);
CMACDS:=(CDIFFS-CDEAS);
STICKLINE(CMACDS>0,0,CMACDS,0.1,0),COLOR444400;
STICKLINE(CMACDS<0,0,CMACDS,0.1,0),COLOR444400;
MACDHS:=IF(CMACD>0 AND CMACD>=REF(CMACD,1),CMACD,0);
MACDHX:=IF(CMACD>0 AND CMACD<=REF(CMACD,1),CMACD,0);
MACDLX:=IF(CMACD<0 AND CMACD<=REF(CMACD,1),CMACD,0);
MACDLS:=IF(CMACD<0 AND CMACD>=REF(CMACD,1),CMACD,0);
STICKLINE(MACDHS>0,0,CMACD,2.7,0),COLOR0000BB;
STICKLINE(MACDHS>0,0,CMACD,2.4,0),COLOR0000CC;
STICKLINE(MACDHS>0,0,CMACD,2.1,0),COLOR0011CC;
STICKLINE(MACDHS>0,0,CMACD,1.8,0),COLOR1122DD;
STICKLINE(MACDHS>0,0,CMACD,1.5,0),COLOR2233DD;
STICKLINE(MACDHS>0,0,CMACD,1.2,0),COLOR3344EE;
STICKLINE(MACDHS>0,0,CMACD,0.9,0),COLOR4455EE;
STICKLINE(MACDHS>0,0,CMACD,0.6,0),COLOR5566FF;
STICKLINE(MACDHS>0,0,CMACD,0.3,0),COLOR6677FF;
STICKLINE(MACDHX>0,0,CMACD,2.7,0),COLOR0077BB;
STICKLINE(MACDHX>0,0,CMACD,2.4,0),COLOR0088CC;
STICKLINE(MACDHX>0,0,CMACD,2.1,0),COLOR0099CC;
STICKLINE(MACDHX>0,0,CMACD,1.8,0),COLOR00AADD;
STICKLINE(MACDHX>0,0,CMACD,1.5,0),COLOR00BBDD;
STICKLINE(MACDHX>0,0,CMACD,1.2,0),COLOR00CCEE;
STICKLINE(MACDHX>0,0,CMACD,0.9,0),COLOR00DDEE;
STICKLINE(MACDHX>0,0,CMACD,0.6,0),COLOR00EEFF;
STICKLINE(MACDHX>0,0,CMACD,0.3,0),COLOR00FFFF;
STICKLINE(MACDLX<0,CMACD,0,2.7,0),COLOR770000;
STICKLINE(MACDLX<0,CMACD,0,2.4,0),COLOR881100;
STICKLINE(MACDLX<0,CMACD,0,2.1,0),COLOR992200;
STICKLINE(MACDLX<0,CMACD,0,1.8,0),COLORAA3300;
STICKLINE(MACDLX<0,CMACD,0,1.5,0),COLORBB4400;
STICKLINE(MACDLX<0,CMACD,0,1.2,0),COLORCC5500;
STICKLINE(MACDLX<0,CMACD,0,0.9,0),COLORDD6600;
STICKLINE(MACDLX<0,CMACD,0,0.6,0),COLOREE7700;
STICKLINE(MACDLX<0,CMACD,0,0.3,0),COLORFF8800;
STICKLINE(MACDLS<0,CMACD,0,2.7,0),COLOR005500;
STICKLINE(MACDLS<0,CMACD,0,2.4,0),COLOR007700;
STICKLINE(MACDLS<0,CMACD,0,2.1,0),COLOR009900;
STICKLINE(MACDLS<0,CMACD,0,1.8,0),COLOR00AA00;
STICKLINE(MACDLS<0,CMACD,0,1.5,0),COLOR00BB00;
STICKLINE(MACDLS<0,CMACD,0,1.2,0),COLOR00CC00;
STICKLINE(MACDLS<0,CMACD,0,0.9,0),COLOR00DD00;
STICKLINE(MACDLS<0,CMACD,0,0.6,0),COLOR00EE00;
STICKLINE(MACDLS<0,CMACD,0,0.3,0),COLOR00FF00;
波:CMACD,COLOR0000FF,NODRAW;
快速:DIFF1,COLORFFFFFF;
慢速:DEA1,COLOR00FFFF;
段:CMACDS,COLOR444400,NODRAW;
走势:CMACDL,COLOR440044,NODRAW;




最新发布

相关文章

神奇指标广告