指标汇总
神奇指标广告
通达信成交量组合公式
来源:通达信公式 3821次浏览 发布时间2022-09-05

以下是通达信成交量组合公式

通达信成交量组合公式

{成交量组合}
MV5:MA(VOL,5),COLORYELLOW;
MV20:MA(VOL,20),COLORMAGENTA;
MV60:MA(VOL,60),COLORGREEN;
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
AA:=VOL>=REF(V,1)*1.91 && C>REF(C,1);
AA1:=VOL<REF(LLV(VOL,21),1);
AA2:=VOL<REF(LLV(VOL,55),1);
AA3:=VOL<=REF(V,1)*0.59;

STICKLINE(AA,0,V,0.3,0),COLORYELLOW;
STICKLINE(AA1,0,V,0.5,0),COLORGREEN;
STICKLINE(AA2,0,V,0.5,0),COLORBLUE;
STICKLINE(AA3,0,V,0.5,0),COLORMAGENTA;

流通盘(亿手):CAPITAL/1000000,NODRAW,COLORRED;主营:FINANCE(20)/100000000,NODRAW;税后利润:FINANCE(29)/100000000,NODRAW;
每股净资:FINANCE(34),NODRAW,COLORGREEN;
投资收益:FINANCE(24)/10000,NODRAW,COLORWHITE;
年收益:FINANCE(33),NODRAW,COLORCYAN;
股东权益:FINANCE(36),NODRAW,COLORMAGENTA;
每股公积:FINANCE(18)/1,NODRAW,COLORGREEN;
{量(万):VOL/10000,NODRAW,VOLSTICK,COLORRED;}
额(亿):AMOUNT/100000000,NODRAW,COLORWHITE;
换手率:VOL/CAPITAL*100,NODRAW,COLORRED;
昨收:REF(CLOSE,1),NODRAW,COLORGREEN;
逐笔大单买:LARGEINTRDVOL/10000,COLORMAGENTA,NODRAW;
逐笔大单卖:LARGEOUTTRDVOL/10000,COLORCYAN,NODRAW;
逐笔买卖差:(LARGEINTRDVOL-LARGEOUTTRDVOL)/10000,COLORBROWN,NODRAW;
主动买量:ACTINVOL/10000,COLORMAGENTA,NODRAW;
主动卖量:ACTOUTVOL/10000,COLORCYAN,NODRAW;
主动买卖差:(ACTINVOL-ACTOUTVOL)/10000,COLORBROWN,NODRAW;

更多指标公式:www.shenqizhibiao.com

MM1:=5;
MM2:=10;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
{VVOL1:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;}

{MAVOL1:MA(VOLUME,MM1);
MAVOL2:MA(VOLUME,MM2);}

超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
净流入:(超B+大B+中B+小B)-(超S+大S+中S+小S),NODRAW;
超大单:(超B)-(超S),NODRAW;
大单:(大B)-(大S),NODRAW;
中单:(中B)-(中S),NODRAW;
小单:(小B)-(小S),NODRAW;
DAZHI:=CONST(MAX(ABS(净流入),MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单)))))),NODRAW;
DRAWRECTREL(0,0,182,999.2,IF(120,RGB(10,0,0),0));
DRAWRECTREL(0,CONST(830-(ABS(净流入)*500/DAZHI)),30,830,IF(CONST(净流入)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(38,CONST(830-(ABS(超大单)*500/DAZHI)),68,830,IF(CONST(超大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(76,CONST(830-(ABS(大单)*500/DAZHI)),106,830,IF(CONST(大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(114,CONST(830-(ABS(中单)*500/DAZHI)),144,830,IF(CONST(中单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(152,CONST(830-(ABS(小单)*500/DAZHI)),182,830,IF(CONST(小单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.001,1,0,'净流'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.037,1,0,'超大'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.073,1,0,'大单'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.109,1,0,'中单'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,1,0,'小单'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.001,0,'单位(万元)'),COLORYELLOW;
{M:=0.53;M1:=0.33;}M:=0.58;M1:=0.39;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.001,M-ABS(净流入)*M1/DAZHI,0,CEILING(净流入));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.037,M-ABS(超大单)*M1/DAZHI,0,CEILING(超大单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.073,M-ABS(大单)*M1/DAZHI,0,CEILING(大单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.111,M-ABS(中单)*M1/DAZHI,0,CEILING(中单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.147,M-ABS(小单)*M1/DAZHI,0,CEILING(小单));

最新发布

相关文章

神奇指标广告