指标汇总
神奇指标广告
通达信操盘宝塔主图指标源码
来源:通达信公式 10347次浏览 发布时间2022-11-04




以下是通达信操盘宝塔主图指标源码




通达信操盘宝塔主图指标源码



B1:=REF(C,1);

B2:=REF(C,2);

SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));

SM:=IF(REF(SS,1)!=0,REF(SS,1),IF(REF(SS,2)!=0,REF(SS,2),IF(REF(SS,3)!=0,REF(SS,3),IF(REF(SS,5)!=0,REF(SS,5),IF(REF(SS,6)!=0,REF(SS,6),IF(REF(SS,7)!=0,REF(SS,7),0))))));

STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,3,0),COLORRED;

STICKLINE(SS=2,B2,C,3,0),COLORRED;

STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,3,0),COLORRED;

AA:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(CLOSE,3) AND IF(REF(CLOSE,3)<REF(CLOSE,4),1,IF(REF(CLOSE,4)<REF(CLOSE,5),REF(CLOSE,1)<REF(CLOSE,4) OR (REF(CLOSE,2)<REF(CLOSE,4) AND REF(CLOSE,3)>=REF(CLOSE,5)),IF(REF(CLOSE,5)<REF(CLOSE,6),1,REF(CLOSE,6)<REF(CLOSE,7))));

BB:=CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,1)>REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)<=REF(CLOSE,5)),IF(REF(CLOSE,5)>REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));

DRAWICON(AA AND CLOSE>REF(OPEN,3),0.99*LOW,1);

DRAWICON(BB AND CLOSE<REF(CLOSE,3),HIGH*1.01,2);

DRAWTEXT(AA AND CLOSE>REF(OPEN,3),LOW*0.98,'三平底翻红'),COLORRED;

DRAWTEXT(BB AND CLOSE<REF(CLOSE,3),HIGH*1.02,'三平顶翻绿'),COLORGREEN;

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

STICKLINE(VAR19,L,L*0.98,3,0),COLORYELLOW;

VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

STICKLINE(VAR1A,H*1.01,H,3,0),COLOR00FF00{98FD};

XXMA:MA(C,5),COLORWHITE;

DD5:=XXMA<REF(XXMA,1);

IF(DD5,XXMA,DRAWNULL),COLOR00FF00;

X:=(3*C+L+O+H)/6;

多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+REF(X,20))/210,COLORFF00FF;

{用法:黄托底买进,绿压顶买出。}

DD:=多空线<REF(多空线,1);

IF(DD,多空线,DRAWNULL);

A:=(XXMA>多空线);

IF(A,多空线,DRAWNULL),POINTDOT;

A1:=(XXMA<多空线);

IF(A1,多空线,DRAWNULL);

V1:=CLOSE*VOL;

V2:=EMA(V1,13)/EMA(VOL,13);

CYS:=(EMA((CLOSE-V2)/V2,1)*100);

AAA:=CYS;

MIDD:=MA(CYS,21);

CC:=MIDD+0.85*STD(CYS,13);

TM6:=AAA>CC;

IF(TM6,XXMA,DRAWNULL);

STICKLINE(C>O,C,O,3,0),COLOR000077;

STICKLINE(C>O,C,O,2,0),COLOR000099;

STICKLINE(C>O,C,O,1,0),COLOR0000BB;

STICKLINE(C>O,H,L,0,0),COLOR0000FF;

{绿}

STICKLINE(C<O,C,O,3,0),COLOR007700;

STICKLINE(C<O,C,O,2,0),COLOR009900;

STICKLINE(C<O,C,O,1,0),COLOR00BB00;

STICKLINE(C<O,H,L,0,0),COLOR00FF00;



通达信操盘宝塔主图指标源码



最新发布

相关文章

神奇指标广告