指标汇总
神奇指标广告
通达信RSI微分副图、源码
来源:通达信公式 8598次浏览 发布时间2022-09-05

以下是通达信RSI微分副图、源码

通达信RSI微分副图、源码

{[RSI微分]加上80和20条线。分别代表顶部和底部。}

VAR1:=REF(OPEN,1);
VAR2:=SMA(MAX(OPEN-VAR1,0),6,1)/SMA(ABS(OPEN-VAR1),6,1)*100,NODRAW;
VAR3:=REF(CLOSE,1);
VAR4:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100,NODRAW;
VAR5:=REF(HIGH,1);
VAR6:=SMA(MAX(HIGH-VAR5,0),6,1)/SMA(ABS(HIGH-VAR5),6,1)*100,NODRAW;
VAR7:=REF(LOW,1);
VAR8:=SMA(MAX(LOW-VAR7,0),6,1)/SMA(ABS(LOW-VAR7),6,1)*100,NODRAW;
开盘值:VAR2,NODRAW;
收盘值:VAR4,NODRAW ;
最高值:VAR6,NODRAW ;
最低值:VAR8,NODRAW ;
{STICKLINE(VAR4<VAR2,VAR8,VAR6,3,0),COLORCYAN;
STICKLINE(VAR4>VAR2,VAR8,VAR6,3,0),COLORRED;}
STICKLINE(VAR4<VAR2,VAR2,VAR4,3,0),COLORCYAN;
STICKLINE(VAR4>VAR2,VAR2,VAR4,3,0),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR8>VAR4,VAR4,VAR6,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR8<VAR4,VAR4,VAR6,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR6>VAR4,VAR4,VAR8,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR6<VAR2,VAR2,VAR8,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR6>VAR2,VAR2,VAR8,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR8<VAR2,VAR2,VAR6,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR8>VAR2,VAR2,VAR6,0.8,1),COLORRED;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6<VAR4,VAR4,VAR8,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8<VAR4,VAR4,VAR6,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR6>VAR4,VAR4,VAR8,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6<VAR4,VAR2,VAR8,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6>VAR4,VAR2,VAR8,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8<VAR2,VAR2,VAR6,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8>VAR2,VAR2,VAR6,0.8,1),COLORCYAN;
DRAWBAND(20,RGB(400,400,0),20,DRAWNULL);
DRAWBAND(80,RGB(400,400,0),80,DRAWNULL);
趋势:(C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*80+10,COLORYELLOW;

 

最新发布

相关文章

神奇指标广告