指标汇总
神奇指标广告
通达信量化交易多空概率系统
来源:通达信公式 5906次浏览 发布时间2022-11-04




以下是通达信量化交易多空概率系统




通达信量化交易多空概率系统



博尔系统是以每周的数据运算得出做多做空位置 咱们就简单的模拟一下

加入背景是年线 k线决策加入宝塔 要的就是明确的东西 所谓的量化不过是按照系统给出的提示来操作而已 实际上均线也量化了 大智慧就有

本作做个股的多空位置基本上比较清晰 对大盘指数模拟不理想 也可能是指数波动幅度过小毕竟弱势

对自己手里被套的遇到做多位置出红k的时候做一下t+0 慢慢自救还是可以的

系统加入不定期函数 没有发现飘移显现 有问题大家多反馈在慢慢修改

因为是以周线数据来编辑 月线k线不会显示多空概率线 分时图正常



还有如果大家觉得决策k线天数太短 可以把n m的参数调整一下 或者都是9 或者12 也可以 4 12 怎么变化要看你自己的体会了



等待管理层来保护投资者 不如加强自身修炼 自己保护自己 不能恢复t+0谈不上什么保护中小投资者 怕过度投机 可以继续实行涨跌停板



老习 你怎么看



n 1 100 4 m 1 100 4



NK:=O#YEAR;NS:=C#YEAR;

STICKLINE(NS>=NK,NS,NK,8,0),COLOR000099;

STICKLINE(NS<NK,NS,NK,8,0),COLORLICYAN;

QQ1:=VOL/((DHIGH-DLOW)*2-ABS(DCLOSE-DOPEN));

主买:=IF(DCLOSE>DOPEN,QQ1*(DHIGH-DLOW),IF(DCLOSE<DOPEN,QQ1*((DHIGH-DOPEN)+(DCLOSE-DLOW)),VOL/2));

主卖:=IF(DCLOSE>DOPEN,0-QQ1*((DHIGH-DCLOSE)+(DOPEN-DLOW)),IF(DCLOSE<DOPEN,0-QQ1*(DHIGH-DLOW),0-VOL/2));

DD:=(主买+主卖)/10000;

DDX1:=EMA(DD,60)*60;

DDX2:=MA(DDX1,N);

DDX3:=MA(DDX1,M);

STICKLINE(DDX1<DDX3,H,L,0,0),COLORGREEN;

STICKLINE(DDX1<DDX3,C,O,4,0),COLOR00B500;

STICKLINE(DDX1<DDX3,C,O,3,0),COLOR00C600;

STICKLINE(DDX1<DDX3,C,O,2,0),COLOR00D500;

STICKLINE(DDX1<DDX3,C,O,1,0),COLOR00E600;

STICKLINE(DDX1>DDX3,H,L,0,0),COLOR106FFF;

STICKLINE(DDX1>DDX3,C,O,4,0),COLOR0000C8;

STICKLINE(DDX1>DDX3,C,O,3,0),COLOR0000D7;

STICKLINE(DDX1>DDX3,C,O,2,0),COLOR0000EA;

STICKLINE(DDX1>DDX3,C,O,1,0),COLOR0000FF;

STICKLINE(DDX1<DDX2 AND DDX1>DDX3,H,L,0,0),COLORFF5D10;

STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,4,0),COLORFF5D10;

STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,3,0),COLORFF7710;

STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2,0),COLORFF9910;

STICKLINE(DDX1>DDX2 AND DDX1<DDX3,H,L,0,0),COLORFF00FF;

STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,4,0),COLORD000D0;

STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,3,0),COLORE600E6;

STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2,0),COLORF900F9;

STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,1,0),COLORFF09FF;

JRH:=HHV(CLOSE,2);

JRL:=LLV(CLOSE,2);

MA3:=MA(CLOSE,3);

YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;

VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));

VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));

VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);

VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);

红色持股:=VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;

离场:=IF(红色持股,JRL,DRAWNULL);

明离场价:离场,COLORFF99FF,NODRAW;

今离场价:REF(离场,1)COLOR0000FF,NODRAW;

青色观望:=VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,NODRAW;

进:=IF(青色观望,JRH,DRAWNULL);

明进场价:进,COLOR33AACC,NODRAW;

今进场价:REF(明进场价,1),COLOR00FF00,NODRAW;

短买:=VAR19,COLOR33AACC,NODRAW;

品红离场:=VAR1A,COLORFF99FF,NODRAW;

急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;

STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;

STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;

CO:=(C-O);

STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555;

STICKLINE(短买,O,O+CO/3,2,0),COLOR338888;

STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA;

STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC;

STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE;

STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;

STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;

STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;

STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;

STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;

ZC:=DCLOSE#WEEK;

ZO:=DOPEN#WEEK;

ZH:=DHIGH#WEEK;

ZL:=DLOW#WEEK;

ZJ:=(ZC+ZO+ZH+ZL)/4;

做空68:ZJ*(1+0.068),COLORRED;

做空95:ZJ*(1+0.136),COLORBLUE;

做多68:ZJ*(1-0.068),COLORGREEN;

做多95:ZJ*(1-0.136),COLOR8409FF;



通达信量化交易多空概率系统



通达信量化交易多空概率系统



最新发布

相关文章

神奇指标广告