指标汇总
神奇指标广告
通达信中长趋势变色副图指标公式
来源:通达信公式 5248次浏览 发布时间2022-09-05

以下是通达信中长趋势变色副图指标公式

通达信中长趋势变色副图指标公式

{中长趋势变色【副图】}
中趋势线:3*SMA((C-LLV(C,27))/(HHV(C,27)-LLV(C,27))*100,5,1)-2*SMA(SMA((C-LLV(C,27))/(HHV(C,27)-LLV(C,27))*100,5,1),3,1),COLORMAGENTA;
长趋势线:3*SMA((C-LLV(C,55))/(HHV(C,55)-LLV(C,55))*100,5,1)-2*SMA(SMA((C-LLV(C,55))/(HHV(C,55)-LLV(C,55))*100,5,1),3,1),COLORRED;
IF(中趋势线<REF(中趋势线,1),中趋势线,DRAWNULL),COLORGREEN,,LINETHICK1;
IF(长趋势线<REF(长趋势线,1),长趋势线,DRAWNULL),COLORLICYAN,LINETHICK1;

STICKLINE(中趋势线>=90,10,0,5,0),COLOR00DB00;{绿色};
STICKLINE(中趋势线<=10,100,90,5,0),COLORFF5BFF;{浅红色};
STICKLINE(长趋势线>=90,10,0,5,0),COLORD5D500;{青色}
STICKLINE(长趋势线<=10,100,90,5,0),COLORRED;{红色}
STICKLINE(中趋势线>=99.5,10,0,5,0),COLORFF9428;{高点2--浅蓝色}
STICKLINE(长趋势线>=99.5,10,0,5,0),COLORFF6666;{高点--蓝色}
STICKLINE(长趋势线>=101,20,0,5,0),COLORFF1717;{深蓝色}
STICKLINE(长趋势线<0,100,80,5,0),COLOR00008A;{深红色}
STICKLINE(长趋势线<-5,110,90,5,0),COLOR000073;{紫红色}
STICKLINE(中趋势线<-5,100,80,5,0),COLOR00007B;{紫红色}
0,COLORBROWN;20,COLORBROWN;80,COLORLICYAN;100,COLORLICYAN;

{趋势短}
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K日:=SMA(RSV2,3,1);
D日:=SMA(K日,3,1);
J日:3*K日-2*D日,COLORGRAY,DOTLINE;

{KDJ同高同低}
KDJ同时高位:STICKLINE(CROSS(J日>100 AND K日>85 AND D日>80,0.5),80,60,3,0),COLORFF1A1A;{深蓝色方框}
KDJ同时低位:STICKLINE(CROSS(J日<0 AND K日<15 AND D日<20,0.5),80,60,3,1),COLOR115FFF;{棕黄色方框}
DRAWTEXT(CROSS(J日>100 AND K日>85 AND D日>80,0.5),75,'★'),COLORWHITE;
DRAWTEXT(CROSS(J日<0 AND K日<15 AND D日<20,0.5),75,'★'),COLORWHITE;

STICKLINE(J日<0,0,J日,0,-1),COLORWHITE;
STICKLINE(J日>100,100,J日,0,-1),COLORWHITE;

{【J】数值}
TT3:=(CURRBARSCOUNT=5-4);
DRAWNUMBER(TT3 AND J日,J日,J日),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,J日,' 【J】'),COLORMAGENTA;


 

 

最新发布

相关文章

神奇指标广告