指标汇总
神奇指标广告
通达信通达信拨雾寻底副图公式
来源:通达信公式 8067次浏览 发布时间2022-11-04




以下是通达信通达信拨雾寻底副图公式




通达信通达信拨雾寻底副图公式



VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;

持币区域:VAR1,COLORFEDCBA;

持股区域:IF(VAR1>0,VAR1,0),COLORRED;

短顶:STICKLINE(VAR1>9 AND FILTER(VAR1<ref(var1,1),5),var1+2,0,3,0),colorgreen;

大顶:STICKLINE(VAR1>20 AND FILTER(VAR1<ref(var1,1),5),var1+5,0,7,0),color00ff00;

VAR2:=HHV(VAR1>20,10);

危险: STICKLINE(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR1+10,0,4,0);

注意止损:STICKLINE(VAR2 AND FILTER(VAR1< REF(VAR1,1),6)

AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR1+6,0,3,0);

短底:STICKLINE(VAR1<-9 AND VAR1> REF(VAR1,1),VAR1-2,0,3,0),COLORRED;

大底:STICKLINE(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),VAR1-5,0,7,0),COLORYELLOW;

买入准备:VAR1<-9 AND VAR1>REF(VAR1,1),COLORWHITE;

DRAWTEXT(VAR1>9 AND FILTER(VAR1<ref(var1,1),5),var1+2,'短顶'),color00ff00;

DRAWTEXT(VAR1>20 AND FILTER(VAR1<ref(var1,1),5),var1+5,'大顶'),colorffff00;

DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR1+10,'危险'),COLOR00FFFF;

DRAWTEXT(VAR2 AND FILTER(VAR1< REF(VAR1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR1+6,'注意止损'),COLORFF00FF;

DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18),VAR1-2,'短底'),,COLOR0000FF;

DRAWTEXT(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),VAR1-5,'大底'),;

DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18),1,'买入准备');

LC:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);

PDI:=((DMP * 100) / TR1);

MDI:=((DMM * 100) / TR1);

ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

最佳买入:=(AV + NEWVOL);

最佳买入选股:IF(CROSS(最佳买入,0),1,0),STICK,COLORRED;

STICKLINE(最佳买入选股,0,5,7.5,0),COLOR102099;

STICKLINE(最佳买入选股,0,5,6,0),COLOR1020AA;

STICKLINE(最佳买入选股,0,5,5.5,0),COLOR1020BB;

STICKLINE(最佳买入选股,0,5,4,0),COLOR1020CC;

STICKLINE(最佳买入选股,0,1,3.5,0),COLOR1020DD;

STICKLINE(最佳买入选股,0,1,2,0),COLOR1020EE;

STICKLINE(最佳买入选股,0,1,1,0),COLOR1020FF;

RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 50);

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

X:=LLV(J,2)=LLV(J,8);

最佳买入时机: IF(CROSS(J,3),1,0),STICK,COLORFFFF00;

STICKLINE(最佳买入时机,0,1,3,0),COLOR999900;

{STICKLINE(最佳买入时机,0,5,3.5,0),COLORBBBB00;}

STICKLINE(最佳买入时机,0,1,2,0),COLORDDDD00;

STICKLINE(最佳买入时机,0,1,1,0),COLORFFFF00;

机构建仓: IF(最佳买入<5,-0.1,0),STICK,COLOR00FF00,LINETHICK1;

机构建仓日:STICKLINE(机构建仓,0,-0.1,3,0),COLOR00FF00,LINETHICK6;

</ref(var1,1),5),var1+5,'大顶'),colorffff00;

</ref(var1,1),5),var1+2,'短顶'),color00ff00;

</ref(var1,1),5),var1+5,0,7,0),color00ff00;

</ref(var1,1),5),var1+2,0,3,0),colorgreen;



通达信通达信拨雾寻底副图公式





最新发布

相关文章

神奇指标广告