指标汇总
神奇指标广告
通达信傻买傻卖公式-仿杨文峰老师成交量叠加主力买卖副图-让你如虎添翼!
来源:通达信公式 7788次浏览 发布时间2022-11-04




以下是通达信傻买傻卖公式-仿杨文峰老师成交量叠加主力买卖副图-让你如虎添翼!




通达信傻买傻卖公式-仿杨文峰老师成交量叠加主力买卖副图-让你如虎添翼!



许多坛友看了杨文峰老师的资金成交量叠加副图很是像望梅止渴的样子。今天俺做一回梅子,发仿杨文峰老师成交量叠加主力买卖副图(其实是多空量能+主力买卖),请大家鉴用。喜欢的给一分§79§§79§§79§§79§§79§§79§!!!!图形有压挤时可以调节N值参数.N(1.0 100.0 4.0).主图QSDD公式


{DRAWRECTREL(0,0,400,988,IF(120,RGB(10,0,0),0));N(1 100 4)}

超B:=L2_AMO(0,2)/10000.0;

大B:=L2_AMO(1,2)/10000.0;

中B:=L2_AMO(2,2)/10000.0;

小B:=L2_AMO(3,2)/10000.0;

超S:=L2_AMO(0,3)/10000.0;

大S:=L2_AMO(1,3)/10000.0;

中S:=L2_AMO(2,3)/10000.0;

小S:=L2_AMO(3,3)/10000.0;

主买A:=ACTINVOL,COLORRED,NODRAW;

主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;

主买:=主买A*100/(主买A+主卖A),NODRAW,COLORRED;

主卖:=主卖A*100/(主买A+主卖A),NODRAW,COLORGREEN;

SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));

【量能饱和】:IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;

主力净买量:=(LARGEINTRDVOL-LARGEOUTTRDVOL),COLORYELLOW,NODRAW;

大宗净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;

主动买卖差:=(ACTINVOL-ACTOUTVOL),COLORMAGENTA,NODRAW;

主力资金差:=((L2_AMO(0,0)+L2_AMO(1,0)-L2_AMO(0,1)-L2_AMO(1,1)))/10000,COLORCYAN,NODRAW;

DRAWRECTREL(100,0,90+CONST(主买*300/100),40,RGB(230,65,0));

DRAWRECTREL(100,60,90+CONST(主卖*300/100),100,RGB(0,104,0));

{DRAWRECTREL(100,120,390,160,RGB(0,0,100));}

DRAWRECTREL(100,120,90+CONST(【量能饱和】*300/100),160,RGB(250,104,0));

大单动向:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7),NODRAW;

T1:=IF (大单动向>0 AND REF(大单动向,1)<0,1,0);

T2:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)<0,2,T1);

T3:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)>0 AND REF(大单动向,3)<0,3,T2);

T4:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)>0 AND REF(大单动向,3)>0 AND REF(大单动向,4)<0,4,T3);

T5:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)>0 AND REF(大单动向,3)>0 AND REF(大单动向,4)>0 AND REF(大单动向,5)<0,5,T4);

T6:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)>0 AND REF(大单动向,3)>0 AND REF(大单动向,4)>0 AND REF(大单动向,5)>0 AND REF(大单动向,6)<0,6,T5);

T7:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)>0 AND REF(大单动向,3)>0 AND REF(大单动向,4)>0 AND REF(大单动向,5)>0 AND REF(大单动向,6)>0 AND REF(大单动向,7)<0,7,T6);

T8:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)>0 AND REF(大单动向,3)>0 AND REF(大单动向,4)>0 AND REF(大单动向,5)>0 AND REF(大单动向,6)>0 AND REF(大单动向,7)>0 AND REF(大单动向,8)<0,8,T7);

T9:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)>0 AND REF(大单动向,3)>0 AND REF(大单动向,4)>0 AND REF(大单动向,5)>0 AND REF(大单动向,6)>0 AND REF(大单动向,7)>0 AND REF(大单动向,8)>0 AND REF(大单动向,9)<0,9,T8);

T:=IF (大单动向>0 AND REF(大单动向,1)>0 AND REF(大单动向,2)>0 AND REF(大单动向,3)>0 AND REF(大单动向,4)>0 AND REF(大单动向,5)>0 AND REF(大单动向,6)>0 AND REF(大单动向,7)>0 AND REF(大单动向,8)>0 AND REF(大单动向,9)>0,10,T9);

D:=COUNT(大单动向>0,10),NODRAW;

DRAWTEXT_FIX(1,0.005,0.01,0,STRCAT(STRCAT('【主动买比】: ',CON2STR(主买,1)),' % ')),COLORYELLOW;

DRAWTEXT_FIX(1,0.005,0.07,0,STRCAT(STRCAT('【主动卖比】: ',CON2STR(主卖,1)),' % ')),COLORGREEN;

DRAWTEXT_FIX(1,0.005,0.13,0,STRCAT(STRCAT('【量能饱和】: ',CON2STR(【量能饱和】,1)),' % ')),COLORYELLOW;

DRAWTEXT_FIX(1,0.005,0.19,0,STRCAT(STRCAT('【主力资金差】: ',CON2STR(主力资金差,1)),' 万元 ')),COLORYELLOW;

DRAWTEXT_FIX(1,0.2,0.19,0,STRCAT(STRCAT('【大宗净流入】: ',CON2STR(大宗净流入,1)),' 万元 ')),COLORYELLOW;

DRAWTEXT_FIX(1,0.005,0.25,0,STRCAT(STRCAT('【主力净买量】: ',CON2STR(主力净买量,1)),' 手')),COLORYELLOW;

DRAWTEXT_FIX(1,0.2,0.25,0,STRCAT(STRCAT('【主动买卖差】: ',CON2STR(主动买卖差,1)),' 手')),COLORYELLOW;

DRAWTEXT_FIX(1,0.005,0.31,0,STRCAT(STRCAT('【DDX 连 红 天 数】: ',CON2STR(T,0)),' 天 ')),COLORYELLOW;

DRAWTEXT_FIX(1,0.2,0.31,0,STRCAT(STRCAT('【DDX两周红天数】: ',CON2STR(D,0)),' 天 ')),COLORYELLOW;


TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);

净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S);

超大单:=(超B)-(超S);

大单:=(大B)-(大S);

中单:=(中B)-(中S);

小单:=(小B)-(小S);

DAZHI:=CONST(MAX(ABS(净流入),MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单)))))),NODRAW;

DRAWRECTREL(250,CONST(960-(ABS(净流入)*200/DAZHI)),285,960,IF(CONST(净流入)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(290,CONST(960-(ABS(超大单)*200/DAZHI)),325,960,IF(CONST(超大单)>0,RGB(102,0,204),RGB(23,125,255)));

DRAWRECTREL(330,CONST(960-(ABS(大单)*200/DAZHI)),365,960,IF(CONST(大单)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(370,CONST(960-(ABS(中单)*200/DAZHI)),405,960,IF(CONST(中单)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(410,CONST(960-(ABS(小单)*200/DAZHI)),445,960,IF(CONST(小单)>0,RGB(255,0,0),RGB(0,128,0)));


DRAWTEXT_FIX(CURRBARSCOUNT=1,0.25,0.99,0,'净流入'),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.29,0.99,0,'超大单'),COLOR10DACB;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.33,0.99,0,'大单'),COLORFFFF00;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.37,0.99,0,'中单'),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.41,0.99,0,'小单'),COLORGREEN;

{DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.001,0,'单位(万元)'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,'资金博弈今日分类持仓单位(万元)'),COLORYELLOW;}

{M:=0.53;M1:=0.33;}M:=0.58;M1:=0.39;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.250,0.89,0,CEILING(净流入));

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.290,0.90,0,CEILING(超大单));

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.330,0.89,0,CEILING(大单));

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.370,0.90,0,CEILING(中单));

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.410,0.89,0,CEILING(小单));


总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

DRAWRECTREL(50,760,240,810,RGB(0,100,0));

DRAWRECTREL(50,760,150,810,RGB(0,250,50));

DRAWRECTREL(50,760,70+CONST(总流入比*160/100),810,RGB(175,50,250));

DRAWTEXT_FIX(1,0.00,0.78,0,STRCAT(STRCAT('资金流入比 ',CON2STR(总流入比,2)),' %')),COLORYELLOW;

大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;

大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);

DRAWRECTREL(50,820,240,870,RGB(0,100,0));

DRAWRECTREL(50,820,150,870,RGB(0,250,50));

DRAWRECTREL(50,820,75+CONST(大单流入限制*150/100),870,RGB(200,0,50));

DRAWTEXT_FIX(1,0.00,0.84,0,STRCAT(STRCAT('大单流入比 ',CON2STR(大单流入限制,2)),' %买')),COLORYELLOW;

成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;

机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;

DRAWRECTREL(50,880,240,930,RGB(0,100,0));

DRAWRECTREL(50,880,150,930,RGB(0,250,50));

DRAWRECTREL(50,880,60+CONST(机构参与度*160/100),930,RGB(200,0,50));

DRAWTEXT_FIX(1,0.00,0.90,0,STRCAT(STRCAT('机构参与度 ',CON2STR(机构参与度,2)),' %')),COLORYELLOW;

主力买力度:=LARGEINTRDVOL*100/VOL,NODRAW;

主力卖力度:=LARGEOUTTRDVOL*100/VOL,NODRAW;

DRAWRECTREL(50,940,240,990,RGB(0,75,200));

DRAWRECTREL(50,940,150,990,RGB(0,250,50));

DRAWRECTREL(50,940,50+CONST(主力买力度*160/100),990,RGB(175,50,250));

DRAWTEXT_FIX(1,0.00,0.96,0,STRCAT(STRCAT('主动买卖力 ',CON2STR(主力买力度,0)),'')),COLORYELLOW;


PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);

JJ:=REF(EMA(PJJ,3),1);

QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));

XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));

ZLL:=(VOL / CAPITAL);

HSL1:=IF((ZLL > 10),10,ZLL);

HSL:=((XVL / 20) / 1.15);

攻击流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));

GJJ:=EMA(攻击流量,8);

LLJX:=EMA(攻击流量,3);

STICKLINE(((HSL * 0.4) >= 0),((HSL * 0.4) +LLJX),0,3,0),COLOR00FFFF;

STICKLINE(((HSL * 0.4) < 0),((HSL * 0.4) +LLJX),0,3,0),COLOR00FF00;


资金流入:=IF((HSL*0.4+LLJX)>0,(HSL*0.4+LLJX),DRAWNULL),COLORRED;

资金流出:=IF((HSL*0.4+LLJX)<0,(HSL*0.4+LLJX),DRAWNULL),COLOR00FF00;


资金进出:=(HSL*0.4+LLJX),LINETHICK0;

万元:=AMOUNT/10000{0000},VOLSTICK,COLORFF00FF;

资金净进出:IF((HSL*0.4+LLJX)>0,资金流入,资金流出),COLORWHITE,POINTDOT;

进出比例%:IF((HSL*0.4+LLJX)>0,资金流入/万元*100,资金流出/万元*100),COLORYELLOW;


连红天1:=BARSLASTCOUNT(资金净进出>0),,COLORA20FFD,NODRAW;

连红天2:=IF(连红天1=0,REF(连红天1,1),连红天1),,COLORA20FFD,NODRAW;

连红天3:=IF(连红天2=0,REF(连红天1,2),连红天2),,COLORA20FFD,NODRAW;

连红天4:=IF(连红天3=0,REF(连红天1,3),连红天3),,COLORA20FFD,NODRAW;

近期连红天:IF(连红天4=0,REF(连红天1,4),连红天4),,COLORYELLOW,NODRAW;

最多连红天1:=MAX(REF(近期连红天,1),近期连红天),COLORYELLOW,NODRAW;

最多连红天2:=MAX(最多连红天1,REF(近期连红天,2)),COLORYELLOW,NODRAW;

最多连红天3:=MAX(最多连红天2,REF(近期连红天,3)),COLORYELLOW,NODRAW;

最多连红天4:=MAX(最多连红天3,REF(近期连红天,4)),COLORYELLOW,NODRAW;

最多连红天5:=MAX(最多连红天4,REF(近期连红天,5)),COLORYELLOW,NODRAW;

最多连红天:MAX(最多连红天5,REF(近期连红天,6)),COLORYELLOW,NODRAW;


三日资金:SUM(资金进出,3),COLORWHITE,NODRAW;

五日资金:SUM(资金进出,5),COLORFF00FF,NODRAW;

十日资金:SUM(资金进出,10),COLOR0000FF,NODRAW;


资金流量:=LLJX*50,LINETHICK0,COLOR0000FF;

STICKLINE((资金流量 > 0),资金流量,0,3,0),COLOR0000FF;

STICKLINE((资金流量 < 0),资金流量,0,3,0),COLORFF3300;


黄柱初出蓝:=REF(资金流出,1)<0 AND 资金流入>30 AND C>O AND C>REF(C,1) AND C>MA(C,3);


X:=(3*C+2*L+O+H)/7;

多空线:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)

+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)

+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+

REF(X,20))/210;

长黄柱:= 资金流入>300 AND CROSS(C,多空线);

DRAWTEXT(黄柱初出蓝,-30,'★'),COLORFF00FF;

DRAWTEXT(长黄柱 ,((HSL * 0.4) * 1.5)*1.4 ,'★'),COLORRED;


{DRAWGBK(C>0, RGB(0,0,0),RGB(0,10,10),0,'123',0);{渐变背景}}

AAA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

{MAV10:MA(V,10),COLORLIMAGENTA,LINETHICK2;}

主买1:IF(CLOSE>OPEN,AAA*(HIGH-LOW),IF(CLOSE<OPEN,AAA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),POINTDOT,COLORRED;

主卖1:=IF(CLOSE>OPEN,0-AAA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AAA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;

换手率%:VOL/CAPITAL*100,POINTDOT,COLORWHITE;

净流:主买1-主卖1,NODRAW;

LS_JW:=(CLOSE+2*LOW+HIGH)/4;

力道:=(LS_JW-MA(CLOSE,20)),LINETHICK2,COLORWHITE;

STICKLINE(力道>0,0+N*50000,VOL+N*50000,3,1),COLORRED;

STICKLINE(力道<0,0+N*50000,VOL+N*50000,3,1),COLORGREEN;

做多:STICKLINE(主买1>0,0+N*50000,主买1+N*50000,3,0),COLORRED;

{STICKLINE(主买1>0,0+N*50000,主买1+N*50000,2.5,0),COLOR000077;

STICKLINE(主买1>0,0+N*50000,主买1+N*50000,2,0),COLOR000099;

STICKLINE(主买1>0,0+N*50000,主买1+N*50000,1.5,0),COLOR0000BB;}

做空:STICKLINE(力道<0 AND 主买1>0,0+N*50000,主买1+N*50000,3,0),COLORGREEN;

STICKLINE(力道<0 AND 主买1>0,0+N*50000,主买1+N*50000,2.5,0),COLOR004400;

STICKLINE(力道<0 AND 主买1>0,0+N*50000,主买1+N*50000,2,0),COLOR007700;

STICKLINE(力道<0 AND 主买1>0,0+N*50000,主买1+N*50000,1.5,0),COLOR009900;

五日量:MA(V,5)+N*50000,COLORBLUE;

三五日:MA(VOL,35)+N*50000,COLORWHITE;

一三五日:MA(VOL,135)+N*50000,COLORYELLOW;


CK:=REF(MA(C,10),1);

{阶段高:=((HHV(C,10)-REF(CK,5))/LLV(C,10)*5)*VOL,COLORGREEN;

阶段低:=((REF(CK,5)-HHV(C,10))/LLV(C,10)*5)*VOL,COLORWHITE;

DRAWBAND(阶段高*1.15,RGB(150,120,50),阶段低*1.15,RGB(0,0,200));}

震荡:(C-REF(CK,5))/LLV(C,10)*100,COLORYELLOW,LINETHICK2;

天下无敌:LONGCROSS(震荡,0,30) ,COLORGREEN, LINETHICK2;

STICKLINE(天下无敌,N*50000,VOL*1.5+N*50000,6,0),COLORMAGENTA;

DRAWTEXT(天下无敌=1,VOL*1.5+N*50000,'【天下无敌】'),COLORGREEN;


TT:=240/FROMOPEN;

比:=TT;

AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);

AZ2:=EMA(AY2,9);

LT2:=(AY2-AZ2);

L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;

ZGD:=HHV(H,80)*0.99;

ZGD2:=CONST(ZGD);

ZDD:=LLV(L211,80);

ZDD2:=CONST(ZDD);

YYA4:=MA(CLOSE,20);

YYA5:=(CLOSE > MA(CLOSE,5));

YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));

YYA7:=(CLOSE > MA(CLOSE,10));

YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));

YYA9:=(CLOSE > MA(CLOSE,20));

YYA10:=REF(YYA4,1);

YYA11:=(YYA4 > YYA10);

YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));

DSLX:=(CLOSE / INDEXC);

DSLX1:=MA(DSLX,5);

DSLX2:=MA(DSLX,10);

YYV1:=MA(VOL,5);

YYV2:=MA(VOL,10);

J1:=CONST(IF( YYAVX > 0,200,100));

J2:=CONST(IF( YYAVX > 0,00,100));

J3:=CONST(IF( YYAVX > 0,100,100));

ZGD3:=ZGD2;

ZDD3:=ZDD2;

ZGD4:=ZGD2;

情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)),NODRAW;

情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));

情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));

情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));

情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));

情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));

情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));

情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));

情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));

情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));

情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;

情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));

情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));

情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));

情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));

情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));

大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));

大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));

大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));

大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));

大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));

大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));

大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));

大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));

MFI:=(HIGH-LOW)*1000000/(VOL*比);

绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);

MMM1:=CONST(绿灯);

衰退:=MFI<REF(MFI,1)AND VOL*比<REF(VOL,1);

MMM2:=CONST(衰退);

伪装:=MFI>=REF(MFI,1)AND VOL*比<REF(VOL,1);

MMM3:=CONST(伪装);

蛰伏:=MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1);

MMM4:=CONST(蛰伏);


WJ:=(H+L+C)/3;

V1:=IF(H=L,1,H-MAX(O,C));

V2:=IF(H=L,1,MAX(C,O)-WJ);

V3:=IF(H=L,1,MIN(O,C)-L);

V4:=IF(H=L,1,WJ-MIN(C,O));

V5:=VOL/IF(H=L,4,H-L);

V6:=(V1*V5);

V7:=(V2*V5);

V8:=(V3*V5);

V9:=(V4*V5);

买盘1:=DYNAINFO(23)*比;

卖盘1:=DYNAINFO(22)*比;

买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));

卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));

买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);

卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);

{买卖差:=买盘-卖盘;}


量大:=(卖盘+买盘)/REF(VOL,1)>2;

MMM5:=CONST(量大);

量缩:=REF(VOL,1)/(卖盘+买盘)>1.5;

MMM6:=CONST(量缩);

卖量大:=(卖盘-买盘)/买盘>0.4;

MMM7:=CONST(卖量大);

买量大:=(买盘-卖盘)/卖盘>0.4;

MMM8:=CONST(买量大);

TS1:=IF(情况1=1,0.06+0.06,0.06); TS2:=IF(情况2=1,TS1+0.06,TS1);

TS3:=IF(情况3=1,TS2+0.06,TS2); TS4:=IF(情况4=1,TS3+0.06,TS3);

TS5:=IF(情况5=1,TS4+0.06,TS4); TS6:=IF(情况6=1,TS5+0.06,TS5);

TS7:=IF(情况7=1,TS6+0.06,TS6); TS8:=IF(情况8=1,TS7+0.06,TS7);

TS9:=IF(情况9=1,TS8+0.06,TS8); TS10:=IF(情况10=1,TS9+0.06,TS9);

TS11:=IF(情况11=1,TS10+0.06,TS10); TS12:=IF(情况12=1,TS11+0.06,TS11);

TS13:=IF(情况13=1,TS12+0.06,TS12); TS14:=IF(情况14=1,TS13+0.06,TS13);

TS15:=IF(情况15=1,TS14+0.06,TS14); TS16:=IF(情况16=1,TS15+0.06,TS15);

TS17:=IF(大盘1=1,TS16+0.06,TS16); TS18:=IF(大盘2=1,TS17+0.06,TS17);

TS19:=IF(大盘3=1,TS18+0.06,TS18); TS20:=IF(大盘4=1,TS19+0.06,TS19);

TS21:=IF(大盘5=1,TS20+0.06,TS20); TS22:=IF(大盘6=1,TS21+0.06,TS21);

TS23:=IF(大盘7=1,TS22+0.06,TS22); TS24:=IF(大盘8=1,TS23+0.06,TS23);

TS25:=IF(MMM1=1,TS24+0.06,TS24);

TS26:=IF(MMM2=1,TS25+0.06,TS25);

TS27:=IF(MMM3=1,TS26+0.06,TS26);

TS28:=IF(MMM4=1,TS27+0.06,TS27);

TS29:=IF(MMM5=1,TS28+0.03,TS28);

TS30:=IF(MMM6=1,TS29+0.03,TS29);

TS31:=IF(MMM7=1,TS30+0.03,TS30);

TS32:=IF(MMM8=1,TS31+0.03,TS31);

DRAWTEXT_FIX(情况1=1 ,0.32,0,0,'量能理想,明显走强,中线参与,仓位控制在70%左右。'),COLORFF00FF;

DRAWTEXT_FIX(情况2=1 ,0.32,0,0,'走势趋强,量能不足,短线进场,仓位控制在50%左右。'),COLORFF00FF;

DRAWTEXT_FIX(情况3=1 ,0.32,0,0,'量价良好,并无明显走强,短线可进场,仓位50%左右。'),COLORFF00FF;

DRAWTEXT_FIX(情况4=1 ,0.32,0,0,'形态尚可,量能不足,未全走强,短入,仓位30%左右。'),COLORFF00FF;

DRAWTEXT_FIX(情况5=1 ,0.32,0,0,'形态已变坏,走势尚可,重仓者减大半,清仓者%观望。'),COLOR00FFFF;

DRAWTEXT_FIX(情况6=1 ,0.32,0,0,'随大盘下跌,明显缩量,考虑大盘风险,减持或清仓。'),COLOR00FFFF;

DRAWTEXT_FIX(情况7=1 ,0.32,0,0,'该股放量下跌,走势明显偏弱,不抢反弹,离场观望。'),COLORFFFFFF;

DRAWTEXT_FIX(情况8=1 ,0.32,0,0,'该股缩量下跌,走势偏弱无力,人气散失,离场观望。'),COLORFFFF00;

DRAWTEXT_FIX(情况9=1 ,0.32,0,0,'该股形态良好,强势明显,量能充足,可以继续持有。'),COLOR00FFFF;

DRAWTEXT_FIX(情况10=1,0.32,0,0,'上行趋势不变,强势依然,量能开始转弱,注意风险。'),COLOR00FFFF;

DRAWTEXT_FIX(情况11=1,0.32,0,0,'该股仍然具备上涨潜力,但股性偏弱,可以考虑减仓。'),COLORFFFFFF;

DRAWTEXT_FIX(情况12=1,0.32,0,0,'该股走势趋弱,量能明显不足,减大部分筹码或空仓。'),COLORFFFF00;

DRAWTEXT_FIX(情况13=1,0.32,0,0,'该股形态不佳,注意成交量变化,但目前不适合参与。'),COLORFFFF00;

DRAWTEXT_FIX(情况14=1,0.32,0,0,'该股趋势不明,股价偏弱,注意量能变化,暂不参与。'),COLORFFFF00;

DRAWTEXT_FIX(情况15=1,0.32,0,0,'有走强迹象,但量能不足,趋势不明朗,不适合操作。'),COLORFFFF00;

DRAWTEXT_FIX(情况16=1,0.32,0,0,'该股走势太弱,主动性买盘弱,没有太大的参与价值。'),COLORFFFFFF;

DRAWTEXT_FIX(大盘1,0.32,0.05,0,'总势量能理想,70%仓位, 若最佳买点,否则谨慎介入。'),COLOR00FF00;

DRAWTEXT_FIX(大盘2,0.32,0.05,0,'总势趋强,量不足,若前轮下跌,短进50%,量大加仓。'),COLORFF00FF;

DRAWTEXT_FIX(大盘3,0.32,0.05,0,'总势形态走坏,重仓者可减去大部分仓位或放空筹码。'),COLORAAAAAA;

DRAWTEXT_FIX(大盘4,0.32,0.05,0,'总势缩量调整,注意大盘系统风险,短线可清仓观望。'),COLORFFFFFF;

DRAWTEXT_FIX(大盘5,0.32,0.05,0,'总势走势良好,量能理想,可继续持有或加仓强势股。'),COLOR00FFFF;

DRAWTEXT_FIX(大盘6,0.32,0.05,0,'总势形态良好,但量能稍显不足,随时准备减仓调仓。'),COLOR00FF00;

DRAWTEXT_FIX(大盘7,0.32,0.05,0,'总势趋势不明,注意成交量变化,目前暂不适宜进场。'),COLORFFFFFF;

DRAWTEXT_FIX(大盘8,0.32,0.05,0,'总势趋势向下,量能萎缩,短线可杀跌,不适合进场。'),COLORFFFFFF;

DRAWTEXT_FIX(MMM1,0.32,0.10,0,'[绿灯]实计交易量增加。MFI促进指数增加。'),COLORFFFFFF;

{DRAWTEXT_FIX(MMM2,0.32,0.10,0,'[衰退]实计交易量减少。MFI促进指数减少。'),COLORGREEN;

DRAWTEXT_FIX(MMM3,0.32,0.10,0,'[伪装]实计交易量减少。MFI促进指数增加。'),COLORGREEN;

DRAWTEXT_FIX(MMM4,0.32,0.10,0,'[蛰伏]实计交易量增加。MFI促进指数减少。'),COLORYELLOW;

DRAWTEXT_FIX(MMM5,0.32,0.15,0,'★今天比昨天的成交量放大一倍以上。'),COLORGREEN;

DRAWTEXT_FIX(MMM6,0.32,0.15,0,'★今天比昨天的成交量缩量一半以上。'),COLORYELLOW;

DRAWTEXT_FIX(MMM7,0.32,0.20,0,'☆该股今天卖出量大于买入量40%以上。'),COLORGREEN;

DRAWTEXT_FIX(MMM8,0.32,0.20,0,'☆该股今天买入量大于卖出量40%以上。'),COLORYELLOW;};



通达信傻买傻卖公式-仿杨文峰老师成交量叠加主力买卖副图-让你如虎添翼!



最新发布

相关文章

神奇指标广告