指标汇总
神奇指标广告
通达信终极BOLL副图公式
来源:通达信公式 10020次浏览 发布时间2022-11-04




以下是通达信终极BOLL副图公式




通达信终极BOLL副图公式



源码---



SS:= MA(C,30)>REF(MA(C,30),1);

SS1:= MA(C,20)>REF(MA(C,20),1);

ADS:= MA(C,10)>REF(MA(C,10),1);

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

涨:STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR

VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,OPEN,5,1),COLORRED;

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

跌:STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,OPEN,5,1),COLORBLUE;

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

底:STICKLINE(VAR19,LOW,OPEN,6,0),COLORRED;

VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

顶:STICKLINE(VAR1A,OPEN,HIGH,5,0),COLORBLUE;

AAA:=(MA(CLOSE,13) MA(CLOSE,17))/2;

CCC:=(STD(CLOSE,13) STD(CLOSE,17))/2;

BBB:=AAA 2.1*CCC;

DDD:=AAA 0.72*CCC;

ZZZ:=IF(CCC>1.88,MA(DDD,3),DDD);

平衡:ZZZ,CIRCLEDOT,LINETHICK3;

止赢:=ZZZ*1.1;

了结:=ZZZ*1.05;

回档:=ZZZ*0.95;

反弹:=ZZZ*0.9;

DRAWTEXT(L<=反弹 AND C>O AND C>反弹,L*0.98,'买!'),COLORYELLOW;

DRAWTEXT(L<=止赢 AND H>=止赢 AND C<O AND (REF(C,1)-C)/C>0.02,H*1.02,'W&R'),COLORGREEN;

{STICKLINE(L<=反弹 AND C>O AND C>反弹,O,C,2,0),COLORYELLOW;}

{STICKLINE(L<=止赢 AND H>=止赢 AND C<O AND (REF(C,1)-C)/C>0.02,O,C,2,0),

BOLL:=MA(CLOSE,20);

上轨:BOLL 2*STD(CLOSE,20);

下轨:BOLL-2*STD(CLOSE,20);

红持:IF(平衡>REF(平衡,1),平衡,DRAWNULL),CIRCLEDOT,COLOR0085D1;

灰跌:IF(平衡<REF(平衡,1),平衡,DRAWNULL),CIRCLEDOT,COLORGREEN;

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));

B11:=REF(C,A11 1)>C AND REF(DIFF,A11 1)<DIFF AND CROSS(DIFF,DEA);

DRAWTEXT(B11>0,L*0.90,'M买'),COLORGREEN;

C11:=BARSLAST(REF(CROSS(DEA,DIFF),1));

D1:=REF(C,C11 1)<C AND REF(DIFF,C11 1)>DIFF AND CROSS(DEA,DIFF);

DRAWTEXT(VAR19 AND ADS AND SS AND SS1,L*0.98,'(买进)'),COLORYELLOW;

DRAWTEXT(D1>0,H*1.07,'M卖'),COLOR0066FF;

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10 1);

B1:=FILTER(A1,10);

C1:=BACKSET(B1,10 1);

HD:=FILTER(C1,20);

A2:=REF(TY,10)=LLV(TY,2*10 1);

B2:=FILTER(A2,10);

C2:=BACKSET(B2,10 1);

LD:=FILTER(C2,10);

A:=REF(C,BARSLAST(HD));

B:=REF(C,BARSLAST(LD));

T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;

T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);

波峰:IF(T1>=1,A,DRAWNULL), POINTDOT,COLOR33FF00,LINETHICK2;

波谷:IF(T2>=1,B,DRAWNULL), POINTDOT,COLOR00FFFF,LINETHICK1;



通达信终极BOLL副图公式



最新发布

相关文章

神奇指标广告