指标汇总
神奇指标广告
通达信实用汽枪主图指标公式
来源:通达信公式 6568次浏览 发布时间2022-11-03




以下是通达信实用汽枪主图指标公式




通达信实用汽枪主图——14年你必用的工具



指标不加密,源码公开,为人为到底,倾力奉献!!自己使用此主图多看看K线图的显示,你会掌握操盘要点。不喜欢的飘过,不要乱砸人。



N:=100;

KK:=BARSLAST(CURRBARSCOUNT=N);

GD:=CONST(IF(ISLASTBAR=1,HHV(H,KK),0));{高点}

DD:=CONST(IF(ISLASTBAR=1,LLV(L,KK),0));{低点}

KJ:=GD-DD;{高低点差值=分区高度}

GD4:=IF(CURRBARSCOUNT<=N,GD,DRAWNULL);

高区:=IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLORRED,LINETHICK2;

低区:=IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2;

平衡:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF;

低:=IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;

高:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;

支撑:=IF(CURRBARSCOUNT<=N/2,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;

强势:=IF(CURRBARSCOUNT<=N,DD+KJ*0.382,DRAWNULL),COLORFF00FF;

突破:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR0000FF;

警示:=IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;

压力:=IF(CURRBARSCOUNT<=N,DD+KJ*0.809,DRAWNULL),COLOR00FF00;

低涨:=IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,KK)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;

天数:BARSLAST(L=DD),COLORCYAN,NODRAW;

顶点:IF(CURRBARSCOUNT<=N, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT;

低点:IF(CURRBARSCOUNT<=N, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT;

STICKLINE(CCI>=200 AND H>=顶点,O,C,2,0),COLORBLUE;

STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;

DRAWBAND(高区,RGB(120,20,0),强势,RGB(0,0,0));

DRAWBAND(强势,RGB(80,0,100),低区,RGB(0,0,0));

DRAWBAND(高,RGB(100,100,0),压力,RGB(0,0,0));

STICKLINE(CURRBARSCOUNT=N,GD,DD,0,0),COLORGREEN;

STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080;

STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;

STICKLINE(CURRBARSCOUNT<=N,支撑,支撑,2,0),COLORFF00FF;

STICKLINE(CURRBARSCOUNT<=N,强势,强势,2,0),COLORFF00FF;

STICKLINE(CURRBARSCOUNT<=N,压力,压力,2,0),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=N/4+8,GD-KJ*0.09,'【风险区】--高抛避险'),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=N/4+10,GD-KJ*0.4,'【拉升区】--强势畜锐'),COLORFFFF80;

DRAWTEXT(CURRBARSCOUNT=N/4+15,DD+KJ/3,'【关注区】--逢低买入'),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=N/4+20,DD+KJ/10,'【低吸区】--大胆买入'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=N/2+10,GD-KJ*0.25,'【拉升区】'),COLORRED;

DRAWTEXT(CURRBARSCOUNT=N/2+10,DD+KJ*0.25,'【持股区】'),COLORYELLOW;

高1:=REF(HHV(H,120),3);

低1:=REF(LLV(L,120),3);

H1:=高1-(高1-低1)*0.191;

H2:=高1-(高1-低1)*0.382;

H3:=高1-(高1-低1)*0.5;

H4:=高1-(高1-低1)*0.618;

H5:=高1-(高1-低1)*0.809;

突破1:=REF(EMA(C,14),1);

A1XL:=(EMA(C,10)-突破1)/突破1*100;

基准:=IF(A1XL>=0,REF(EMA(C,10),BARSLAST(CROSS(A1XL,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1XL))+1));

STICKLINE(A1XL>=0,基准,突破1,0.5,0),COLOR408080;

第一防线:REFDATE(低,DATE),POINTDOT,COLORYELLOW,LINETHICK3;

第二防线:REFDATE(支撑,DATE),POINTDOT,COLORWHITE,LINETHICK3;

VAR11:=MA(C,9),COLORRED;

上升通道:IF(VAR11>REF(VAR11,1),VAR11,DRAWNULL),LINETHICK5,COLORRED;

下降通道:IF(VAR11<REF(VAR11,1),VAR11,DRAWNULL),LINETHICK4,COLORGREEN;


RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;

K24:=SMA(RSV24,3,1);

D24:=SMA(K24,3,1);

J24:=3*K24-2*D24;

压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLOR66CC66,LINETHICK3;

支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK3;

{支撑价:LLV(LOW,34),COLOR0088FF,DOTLINE,LINETHICK2;

阻力价:HHV(HIGH,34),COLORFF9900,DOTLINE,LINETHICK2;}


A0:=(L+H+C*2)/4;

AA:=EMA(A0,14)COLORYELLOW,LINETHICK1;

BB:=EMA(A0,25)COLORYELLOW,LINETHICK2;

A1X:=(AA-REF(AA,1))/REF(AA,1)*100;

A2X:=(BB-REF(BB,1))/REF(BB,1)*100;

G:=BARSLAST(CROSS(A1X,0));

CC:=IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLORBLUE;

必卖止损价位:REF(A0,G),COLORFFFFFF,LINETHICK3;


DRAWKLINE(H,O,L,C);

ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);

ZSP:=IF(C>REF(C,1),C,DRAWNULL);

DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL);

DSP:=IF(C<=REF(C,1),C,DRAWNULL);

DRAWKLINE(H,DKP,L,DSP);

STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE;

STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700;

STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900;

STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00;

DRAWKLINE(H,ZKP,L,ZSP);

STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099;

STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;

STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF;

STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;

STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW;


TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10+1);

B1:=FILTER(A1,10);

C1:=BACKSET(B1,10+1);

HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10+1);

B2:=FILTER(A2,10);

C2:=BACKSET(B2,10+1);

LD:=FILTER(C2,10);

前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT;

STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF;


JRH:=HHV(C,2);

JRL:=LLV(C,2);

VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));

VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));

VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);

VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);

红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;

离场:=IF(红色持股,JRL,DRAWNULL);

明离场价:=离场,COLORFF99FF,NODRAW;

青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW;

进:=IF(青色观望,JRH,DRAWNULL);

今离场价:REF(离场,1),COLOR0000FF,NODRAW;

明进场价:进,COLOR33AACC,NODRAW;

今进场价:REF(明进场价,1),COLORGREEN,NODRAW;


DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF;

DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF;

DRAWTEXT_FIX(1,0.00,0.10,0,'莸利比例:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.06,0.10,0,CONST(WINNER(C )*100)),COLOR0080FF;

DRAWTEXT_FIX(1,0.12,0.10,0,'动态PE:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.17,0.10,0,CONST(DYNAINFO(39))),COLOR0080FF;

DRAWTEXT_FIX(1,0.22,0.10,0,'市值:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.26,0.10,0,FINANCE(40)/100000000),COLOR0080FF;

DRAWTEXT_FIX (1,0.31,0.10,0,'公积金(股):'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.38,0.10,0,FINANCE(18)),COLOR0080FF;

DRAWTEXT_FIX (1,0.43,0.10,0,'收益:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.47,0.10,0,FINANCE(33)),COLOR0080FF;


主力买力度:=LARGEINTRDVOL*1000/VOL;

主力卖力度:=LARGEOUTTRDVOL*1000/VOL;


AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;

DRAWRECTREL(0,215,CONST(ABS(主力买力度)*560/AAD),268,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(0,270,CONST(ABS(主力卖力度)*560/AAD),323,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));

DRAWTEXT_FIX(1,0,0.224,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0,0.276,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;

超B:=L2_AMO(0,2)/10000.0;

大B:=L2_AMO(1,2)/10000.0;

中B:=L2_AMO(2,2)/10000.0;

小B:=L2_AMO(3,2)/10000.0;

超S:=L2_AMO(0,3)/10000.0;

大S:=L2_AMO(1,3)/10000.0;

中S:=L2_AMO(2,3)/10000.0;

小S:=L2_AMO(3,3)/10000.0;

净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;


{总额:=AMOUNT;

买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

买%:=买/AMOUNT*100;

流入:=AMOUNT*买%/10000000000;

流出:=AMOUNT/100000000-流入;

净流入:=(流入-流出);}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

VAR113:=HHV(HIGH,60);

VAR114:=LLV(LOW,30);

VAR115:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VAR116:=(VAR113+VAR114+VAR115)/3;

VAR117:=EMA(VAR116,5);

K01:=EMA(VAR117,5)*2, COLORFF00FF;

D01:=EMA(K01,5), COLORWHITE;

J01:=K01*3-D01*2, COLORYELLOW;

ENTERLONG:=CROSS(K01,D01);

EXITLONG:=CROSS(D01,K01);

B01:=(DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))

AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),L*0.98,1))*D01*2/3;

B02:=IF(TROUGHBARS(3,15,1)=1 AND HIGH>LOW+0.01,20,0);

必买:=(B01 AND B02) AND 净流入>0;

必卖:=IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN,LINETHICK1;

QQ:=必卖=80;

B03:=((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)));

V1:=EMA(CLOSE,60)-EMA(CLOSE,300);

V2:=EMA(V1,300);

V3:=(CLOSE-(LOW,8))/((HIGH,8)-LLV(LOW,8))*100;

V4:=SMA(V3,2,1),NODRAW;

V5:=SMA(V4,2,1),NODRAW;

V6:=CLOSE/REF(CLOSE,3)>=1.1;

V7:=BACKSET(V6,3);

大涨:=(V7 AND COUNT(V7,3)=1);

DRAWICON(必买,L-0.16,11);

DRAWICON(大涨 AND 必买,L-0.16,9);

DRAWICON(大涨,L-0.18,1);

DRAWICON(QQ,H+0.1,6);

M1:=30;

P2:=80;

VAR101:=(C+H+O+L)/4;

买入:=XMA(VAR101,M1)*(1-P2/1000),COLORFFFFFF,LINETHICK2;

反弹:=EMA(EMA(EMA(HIGH,5),5),5)*0.95,COLORRED,LINETHICK1;

暴:=CROSS(买入,反弹);

DRAWTEXT(暴>0,L*0.99,'↖起暴'),COLORYELLOW;

TYP:=(HIGH+LOW+CLOSE)/3;

CI15:=(TYP-MA(TYP,15))/(0.015*AVEDEV(TYP,15));

CI10:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));

CI5:=(TYP-MA(TYP,5))/(0.015*AVEDEV(TYP,5));

CI3:=(TYP-MA(TYP,3))/(0.015*AVEDEV(TYP,3));

EMAH3:=EMA(H,3);

EMAL3:=EMA(L,3);

EMAH5:=EMA(H,5);

EMAL5:=EMA(L,5);

EMAL10:=EMA(L,10);

EMAZ:=(EMAH3+EMAH5+EMAL3+EMAL5)/4;

EMA3:=(EMAH3-EMAL3)/8+EMAL3;

PBX1:=(EXPMA((C+H+L)/3,4)+MA((C+H+L)/3,4*2)+MA((C+H+L)/3,4*4))/3;

PBX2:=(EXPMA((C+H+L)/3,6)+MA((C+H+L)/3,6*2)+MA((C+H+L)/3,6*4))/3;

冠军1号短线王:=PBX1>PBX2 AND CI15>0 AND CI10>0 AND EMAH3>EMAH5 AND EMAL3>EMAL5 AND EMAL5>EMAL10 AND O<EMA3 AND L<EMAL3;

冠军1号:冠军1号短线王=1;

DRAWTEXT(冠军1号,L*0.99,'↖冠军1号'),COLORYELLOW;







最新发布

相关文章

神奇指标广告