指标汇总
神奇指标广告
擒牛绳代码源码
来源:通达信公式 473次浏览 发布时间2022-09-05

以下是擒牛绳代码源码

擒牛绳:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,DOTLINE,COLORRED;
 IF(擒牛绳>REF(擒牛绳,1),擒牛绳,DRAWNULL),LINETHICK2,COLORRED;
 {二五:MA(C,25),DOTLINE;}
低偏:(LOW-擒牛绳)/擒牛绳*100,NODRAW;
高偏:(H-擒牛绳)/擒牛绳*100,NODRAW;
收偏:((CLOSE-擒牛绳)/擒牛绳)*100,NODRAW;
板:COUNT(C/REF(CLOSE,1)>1.099,250),NODRAW,COLORRED;
涨5%:COUNT(CLOSE/REF(CLOSE,1)>1.05,250),NODRAW,COLORYELLOW;
板率:100*板/涨5%,NODRAW,COLORBLUE;
振5%:COUNT(H/L>1.05,25),NODRAW;
上影线:IF(C>O,100*(H-C)/C,100*(H-O)/O),NODRAW;
下影线:IF(C>O,100*(O-L)/O,100*(C-L)/C),NODRAW;
 C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
 {STICKLINE(涨停,OPEN,CLOSE,-1,0),COLORRED;
 STICKLINE(涨停,H,L,0,0),COLORRED;}
 DRAWICON(涨停 AND N=1,L-0.2,25);
跌停:=IF((C2-L)*100/C2>=(10-0.01*100/C2),1,0);
 {STICKLINE(跌停,OPEN,CLOSE,-1,0),COLORBLUE;
 STICKLINE(跌停,H,L,0,1),COLORBLUE;}
 DRAWICON(跌停 AND N=1,H+0.2,24);
开板:=IF(((H-C2)*100/C2>=(10-0.01*100/C2)) AND C<H AND N=1,1,0);
 DRAWICON(开板 AND N=1,L-0.2,26);

(参数1-4  N 0.00 1.00 1.00 最上面的一行)

 

 

最新发布

相关文章

神奇指标广告