指标汇总
神奇指标广告
通达信强势金牛副图 选股公式 抓获强势股的利器!
来源:通达信公式 7094次浏览 发布时间2022-09-05

以下是通达信强势金牛副图 选股公式 抓获强势股的利器!

通达信强势金牛副图 选股公式 抓获强势股的利器!

源码

N1:=3;N2:=5;N3:=9;N4:=13;N5:=21;N6:=34;
 DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
 DEA:=EMA(DIFF,N2);
 A1:=DIFF>DEA;
 RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
 K:=SMA(RSV1,N1,1);
 D:=SMA(K,N1,1);
 A2:=K>D;
 LC:=REF(CLOSE,1);
 RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
 RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
 A3:=RSI1>RSI2;
 RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
 LWR1:=SMA(RSV,N1,1);
 LWR2:=SMA(LWR1,N1,1);
 A4:=LWR1>LWR2;
 BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
 A5:=CLOSE>BBI;
 MTM:=CLOSE-REF(CLOSE,1);
 MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
 MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
 A6:=MMS>MMM;
 BIAS:=(C-MA(C,N2))/MA(C,N2);
 DIF:=(BIAS-REF(BIAS,16));
 DBCD:=SMA(DIF,76,1);
 MM:=MA(DBCD,5);
 A7:=DBCD>MM;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0,COLORRED;
下跌:=MA(持股,12),COLOR6B8E23,LINETHICK0;
 A8:=持股>下跌;
MT:=C-REF(C,1);
 ZLGJ:=100*EMA(EMA(MT,N3),N3)/EMA(EMA(ABS(MT),N3),N3);
 MAZL:=MA(ZLGJ,5);
 A9:=ZLGJ>MAZL;
 PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
 JJ:=REF(EMA(PJJ,3),1);
 QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
 XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));
 HSL:=(XVL/20)/1.15;
 GJLL:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
 GJJ:=EMA(GJLL,8);
 LLJX:=EMA(GJLL,3);
 ZJL:=LLJX,LINETHICK0,COLOR0000FF;
 A10:=ZJL>0;
 JCS:=(A1+A2+A3+A4+A5+A6+A7+A8+A9+A10);
 PP:=IF(JCS>5,1,0);
金牛:=IF((CROSS(PP,0.99)),13,0);
 IF(金牛,1,0);
 

 

最新发布

相关文章

神奇指标广告