指标汇总
神奇指标广告
通达信乾坤决策眼+分时九转 分时主图公式
来源:通达信公式 7381次浏览 发布时间2022-09-05

以下是通达信乾坤决策眼+分时九转 分时主图公式

通达信乾坤决策眼+分时九转 分时主图公式

{乾坤眼}
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00FFFF,DOTLINE;
支撑:L1+P1*0.5/8,COLORRED,DOTLINE;
中:(支撑+阻力)/2,COLORC0C0C0,DOTLINE;
现价:CLOSE,COLORWHITE,LINETHICK1;
MR:=C<支撑 AND CROSS(C,REF(C,2));
MC:=C>阻力 AND CROSS(REF(C,2),C);
均价:=SUM(V*C,0)/SUM(V,0),COLOR004080,DOTLINE;
DRAWTEXT(CURRBARSCOUNT=1,阻力,'--------阻力'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,支撑,'--------支撑'),COLORA2A2FF;
DRAWTEXT(ISLASTBAR,(支撑+阻力)/2,'--------中'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=4,均价,'--------均'),COLORFFFFFF,LINETHICK2;

{---------------------------------}
DRAWTEXT(CROSS(支撑,现价),(支撑-中)/5+支撑,'★底'),COLORYELLOW;
DRAWTEXT(CROSS(现价,阻力),阻力-(支撑-中)/5,'★顶'),COLORMAGENTA;

{---------------------------------}

QZS:=(EMA(CLOSE,10)+EMA(CLOSE,32))/2;
VAR1:=(EMA(CLOSE,30)+EMA(CLOSE,72))/2;
VAR2:=(EMA(VOL,10)+EMA(VOL,32))/2;
VAR3:=(VAR1+VAR2)/2;
VAR4:=EMA(VAR3,30);
VAR5:=EMA(VAR3,60);
VAR6:=EVERY(VAR1>REF(VAR1,1),5) AND EVERY(VAR4>REF(VAR4,1),5);

DRAWBAND(VAR1,RGB(150,30,30),EMA(VAR1,60),RGB(0,110,30));
牵引线:=VAR1,COLORYELLOW;
趋势关注:=IF(CROSS(VAR1,EMA(VAR1,60)) AND VAR6,1,0),NODRAW,COLORRED;
量价关注:=IF(CROSS(VAR3,VAR5) AND VAR6,1,0),NODRAW,COLORWHITE;
冲击量:=IF(VAR3>VAR5 AND VAR6,1,0),NODRAW,COLORYELLOW;
STICKLINE(QZS>VAR1,QZS,VAR1,1,0),COLORFF00FF;
STICKLINE(冲击量=1,QZS,VAR1,1,0),COLORYELLOW;
DRAWICON(趋势关注=1,EMA(VAR1,60),13);
DRAWTEXT(量价关注=1,EMA(VAR1,60),'L0V'),COLORWHITE;

{---------------------------------}
最新:=C,LINETHICK9,COLORFFFF00;
IF(C>=REF(C,1),C,DRAWNULL),LINETHICK9,COLORRED;
AA:=SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C));
BB:=BETWEEN(C/AA,C+H,C-H);
DRAWICON(ISLASTBAR AND C>REF(C,1),C,1);
DRAWICON(ISLASTBAR AND C<REF(C,1),C,2);

{乾坤眼划线}
STICKLINE(CROSS(阻力,现价),C,中,2,0),COLORFFFF00;
STICKLINE(MC=1,阻力,中,2,0),COLORFFFF00;
DRAWICON(MC=1 OR CROSS(阻力,现价),中,35);

STICKLINE(CROSS(现价,支撑),C,中,2,0),COLOR00F0F0;
DRAWICON(MR=1 OR CROSS(现价,支撑),中,34);


{---------分时均线-------------------}
W:=BARSLAST(DAY-REF(DAY,1))+1;
FSJX:=SUM(CLOSE*VOL,W)/SUM(VOL,W),LINETHICK2,COLORYELLOW;
IF(FSJX<REF(FSJX,1),FSJX,DRAWNULL),LINETHICK2,COLORGREEN;


{-----黄金线-------------}
X:=FROMOPEN+1;
HH:=HHV(H,X); 
LL:=LLV(L,X);  
HL:=HH-LL;
A76:=0.764*HL+LL;
A61:=0.618*HL+LL;
A38:=0.382*HL+LL;
A23:=0.236*HL+LL;  
A5:=0.5*HL+LL;
DRAWTEXT_FIX(1,0,0 ,0,'最高 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄' ),COLOR00FF00,LINETHICK2;
DRAWTEXT_FIX(1,0,1,0,'最低______________________________________________________________________________________________________________________________________________________________________'),COLOR00FF00,LINETHICK2;
DRAWTEXT_FIX(1,0,0.5,0,'中轴------------------------------------------------------------------------------'),COLOR00FFFF,LINETHICK2;
DRAWTEXT_FIX(1,0,0.616,0,'▼-------------------------------------------------------------------------------'),COLOR00FF00,LINETHICK2;
DRAWTEXT_FIX(1,0,0.382,0,'▲-------------------------------------------------------------------------------'),COLOR00FF00,LINETHICK2;
DRAWTEXT_FIX(1,0,0.128,0,'压力-------------------------------------------------------------------------------'),COLORFFFF00,LINETHICK2;
DRAWTEXT_FIX(1,0,0.880,0,'支撑-------------------------------------------------------------------------------'),COLORFFFF00,LINETHICK2;

{-------抓涨停-------}

获利盘:=100*WINNER(CLOSE)<0.15;
DRAWICON(获利盘,C,9);{钱袋}

{-------鬼鬼分时-------};
VARG1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VARG2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VARG3:=SMA(VARG2,2,1);
天:=100+(-ABS(VARG1));
下:=SMA(VARG3,2,1);
无:=ABS(VARG1);
买:=CROSS(下,无);
卖:=CROSS(下,天);
DRAWICON(买,C,25);
DRAWICON(卖,C,26);
{红球13}{蓝球14}{粉钻25}{黄钻26};

{标注};
DRAWTEXT_FIX(1,0.350,0.00,0,STRCAT('【阻力价格】',CON2STR(阻力,2))),COLORYELLOW;
DRAWTEXT_FIX(1,0.500,0.00,0,STRCAT('【支撑价格】',CON2STR(支撑,2))),COLORYELLOW;

{九转分时}
A:=DRAWTEXT(C>REF(L,4),LOW,'*');
LS0:=BARSLAST(A);
LS11:=IF(1,LS0=1,A);
LS21:=IF(1,LLV(L,1)<REF(L,1),1);
A1:=LS11 AND LS21;
LS12:=IF(2,LS0=2,A);
LS22:=IF(2,LLV(L,2)<REF(L,2),1);
A2:=LS12 AND LS22;
LS13:=IF(3,LS0=3,A);
LS23:=IF(3,LLV(L,3)<REF(L,3),1);
A3:=LS13 AND LS23;
LS14:=IF(4,LS0=4,A);
LS24:=IF(4,LLV(L,4)<REF(L,4),1);
A4:=LS14 AND LS24;
LS15:=IF(5,LS0=5,A);
LS25:=IF(5,LLV(L,5)<REF(L,5),1);
A005:=LS15 AND LS25;
LS16:=IF(6,LS0=6,A);
LS26:=IF(6,LLV(L,6)<REF(L,6),1);
A6:=LS16 AND LS26;
LS17:=IF(7,LS0=7,A);
LS27:=IF(7,LLV(L,7)<REF(L,7),1);
A7:=LS17 AND LS27;
LS18:=IF(8,LS0=8,A);
LS28:=IF(8,LLV(L,8)<REF(L,8),1);
A8:=LS18 AND LS28;
LS19:=IF(9,LS0=9,A);
LS29:=IF(9,LLV(L,9)<REF(L,9),1);
A9:=LS19 AND LS29;

{DRAWTEXT(REFX(A7,6),L,'1'),COLORGREEN;
DRAWTEXT(REFX(A7,5),L,'2'),COLORGREEN;
DRAWTEXT(REFX(A7,4),L,'3'),COLORGREEN;
DRAWTEXT(REFX(A7,3),L,'4'),COLORGREEN;
DRAWTEXT(REFX(A7,2),L,'5'),COLORGREEN;}
DRAWTEXT(REFX(A7,1),L,'6'),COLORGREEN;
DRAWTEXT(A7,L,'7'),COLORGREEN;
DRAWTEXT(A8,L,'8'),COLORGREEN;
DRAWTEXT(A9,L,'9'),COLORYELLOW;

B:=DRAWTEXT(C<REF(L,4),H,'*');
LB0:=BARSLAST(B);
LB11:=IF(1,LB0=1,B);
LB21:=IF(1,LLV(H,1)>REF(H,1),1);
B1:=LB11 AND LB21;
LB12:=IF(2,LB0=2,B);
LB22:=IF(2,LLV(H,2)>REF(H,2),1);
B2:=LB12 AND LB22;
LB13:=IF(3,LB0=3,B);
LB23:=IF(3,LLV(H,3)>REF(H,3),1);
B3:=LB13 AND LB23;
LB14:=IF(4,LB0=4,B);
LB24:=IF(4,LLV(H,4)>REF(H,4),1);
B4:=LB14 AND LB24;
LB15:=IF(5,LB0=5,A);
LB25:=IF(5,LLV(H,5)>REF(H,5),1);
B5:=LB15 AND LB25;
LB16:=IF(6,LB0=6,A);
LB26:=IF(6,LLV(H,6)>REF(H,6),1);
B6:=LB16 AND LB26;
LB17:=IF(7,LB0=7,A);
LB27:=IF(7,LLV(H,7)>REF(H,7),1);
B7:=LB17 AND LB27;
LB18:=IF(8,LB0=8,A);
LB28:=IF(8,LLV(H,8)>REF(H,8),1);
B8:=LB18 AND LB28;
LB19:=IF(9,LB0=9,A);
LB29:=IF(9,LLV(H,9)>REF(H,9),1);
B9:=LB19 AND LB29;

{DRAWTEXT(REFX(B7,6),H,'1'),COLORGREEN;
DRAWTEXT(REFX(B7,5),H,'2'),COLORGREEN;
DRAWTEXT(REFX(B7,4),H,'3'),COLORGREEN;
DRAWTEXT(REFX(B7,3),H,'4'),COLORGREEN;
DRAWTEXT(REFX(B7,2),H,'5'),COLORGREEN;}
DRAWTEXT(REFX(B7,1),H,'6'),COLORGREEN;
DRAWTEXT(B7,H,'7'),COLORGREEN;
DRAWTEXT(B8,H,'8'),COLORGREEN;
DRAWTEXT(B9,H,'9'),COLORYELLOW;

 

最新发布

相关文章

神奇指标广告