指标汇总
通达信乾坤决策眼分时副图公式
来源:通达信公式 8460次浏览 发布时间2022-09-05

以下是通达信乾坤决策眼分时副图公式

通达信乾坤决策眼分时副图公式

{乾坤眼}
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00FFFF,DOTLINE;
支撑:L1+P1*0.5/8,COLORRED,DOTLINE;
中:(支撑+阻力)/2,COLORC0C0C0,DOTLINE;
现价:CLOSE,COLORWHITE,LINETHICK1;
MR:=C<支撑 AND CROSS(C,REF(C,2));
MC:=C>阻力 AND CROSS(REF(C,2),C);
均价:=SUM(V*C,0)/SUM(V,0),COLOR004080,DOTLINE;
DRAWTEXT(CURRBARSCOUNT=1,阻力,'--------阻力'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,支撑,'--------支撑'),COLORA2A2FF;
DRAWTEXT(ISLASTBAR,(支撑+阻力)/2,'--------中'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=4,均价,'--------均'),COLORFFFFFF,LINETHICK2;

{---------------------------------}
DRAWTEXT(CROSS(支撑,现价),(支撑-中)/5+支撑,'★底'),COLORYELLOW;
DRAWTEXT(CROSS(现价,阻力),阻力-(支撑-中)/5,'★顶'),COLORMAGENTA;


{---------------------------------}
{新图}
Q:=250;
高点:=HHV(C,Q);
低点:=LLV(C,Q);
最高:=CONST(高点),NODRAW;
最低:=CONST(低点),NODRAW;
轴差:=最高-最低;
中价轴:=(最高+最低)/2;
HL3:=(100-0)/2*1.3;
HL4:=(100-0)/1*1.3;
{中间价轴:=(50-HL3)*轴差/HL4+中价轴;}
中间价轴:=中;
{平安轴:=(中价轴+中间价轴)/2;}
平安轴:=中;
BGTYU:=1;
GHYJKU:=BETWEEN((CLOSE*BGTYU)/(SUM(AMOUNT,BARSCOUNT((CLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((CLOSE*BGTYU)))),1.05,0.95);
VBNH:=IF(GHYJKU=0,MA((CLOSE*BGTYU),BARSCOUNT((CLOSE*BGTYU))),(SUM(AMOUNT,BARSCOUNT((CLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((CLOSE*BGTYU)))));
起动线:=EXPMA((CLOSE/VBNH),20)*1,COLORYELLOW,POINTDOT;
主力线:=EXPMA((CLOSE/VBNH),60)*1,COLORMAGENTA,LINETHICK2;
散户线:=EXPMA((CLOSE/VBNH),120)*1,COLORGREEN,LINETHICK2;
限制起动线:=起动线*中间价轴;
限制主力线:=主力线*中间价轴;
限制散户线:=散户线*中间价轴;
主散MIN:=MIN(限制主力线,限制散户线);
{分时转强:=主散MIN>金龙线 AND ((LONGCROSS(限制主力线,金龙线,2) OR CROSS(限制主力线,限制散户线)) OR (限制主力线>限制散户线 AND LONGCROSS(牵引线,金龙线,2)));}
DRAWBAND(限制主力线,RGB(250,125,0),限制散户线,RGB(0,100,250));
STICKLINE(起动线<主力线,限制起动线,限制主力线,1.0,0),COLOR00FF00;
STICKLINE(起动线>主力线,限制起动线,限制主力线,1.0,0),COLORFFFFFF;
STICKLINE(VOL>EMA(VOL,60) AND 起动线>主力线,限制起动线,限制主力线,1,0),COLORFF00FF;
STICKLINE(VOL>EMA(VOL,30) AND 起动线>主力线 AND 起动线>1.01 AND 起动线>REF(起动线,1),限制起动线,限制主力线,1,0),COLOR00FFFF;


{乾坤眼划线}
STICKLINE(CROSS(阻力,现价),C,中,2,0),COLORFFFF00;
STICKLINE(MC=1,阻力,中,2,0),COLORFFFF00;
DRAWICON(MC=1 OR CROSS(阻力,现价),中,35);

STICKLINE(CROSS(现价,支撑),C,中,2,0),COLOR00F0F0;
DRAWICON(MR=1 OR CROSS(现价,支撑),中,34);


{---------分时均线-------------------}
W:=BARSLAST(DAY-REF(DAY,1))+1;
FSJX:=SUM(CLOSE*VOL,W)/SUM(VOL,W),LINETHICK2,COLORYELLOW;
FSJX1:=IF(FSJX<REF(FSJX,1),FSJX,DRAWNULL),LINETHICK2,COLORGREEN;


{-------鬼鬼分时-------};
VARG1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VARG2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VARG3:=SMA(VARG2,2,1);
天:=100+(-ABS(VARG1));
下:=SMA(VARG3,2,1);
无:=ABS(VARG1);
买:=CROSS(下,无);
卖:=CROSS(下,天);
DRAWICON(买,C,25);
DRAWICON(卖,C,26);

{财神必买}
VAR01:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR01-REF(VAR01,1))/REF(VAR01,1)*1000;
JJ:=DYNAINFO(11);
P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
{必买}
DRAWICON(BTJ811 AND TIME>10,C,24);
{必卖}
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
STJ02:=控盘>0;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND  财>1.618;
STJ1:=(C-JJ)/JJ>0.005;
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
STJ83:=STJ81 AND STJ82;
DRAWICON(STJ83 AND TIME>10,C*1.01,27);

{分时心理}
PSY:=COUNT(CLOSE>REF(CLOSE,1),13)/13*100,COLOR00FFFF;
PA:=MA(PSY,3),COLOR0000FF;
TJ1:=FILTER((C-JJ)/JJ<-0.04 AND PA<16,13);
{红球---红买}
DRAWICON(TJ1,C,13);
TJ2:=FILTER((C-JJ)/JJ>0.05 AND PA>60,14);
{蓝球---绿卖}
DRAWICON(TJ2,C,14);


{-------抓涨停-------}

获利盘:=100*WINNER(CLOSE)<0.15;
DRAWICON(获利盘,C,9);{钱袋};


{南川2代分时}
AF1:=1;
TT:=BARSLAST(HOUR=9 AND MINUTE=(30+AF1))+1;
价位:C,COLORWHITE,LINETHICK4;
盘整:IF(HOUR>9 AND RANGE(HHV(C,60)/LLV(C,60),1,1.02),C,DRAWNULL),COLORRED,LINETHICK2;


V1:=V;
HH:=C>REF(C,1) AND C/均价>(1+0.03);
LL:=C<REF(C,1) AND C/均价<(1-0.03);
HH1:=CROSS(SUM(HH,0),0.5);
LL1:=CROSS(SUM(LL,0),0.5);
SS1:=SUM(HH1,0)*CROSS(COUNT(C<REF(C,1),BARSLAST(HH1)),0.5);
BB1:=SUM(LL1,0)*CROSS(COUNT(C>REF(C,1),BARSLAST(LL1)),0.5);
CS1:CONST(SUM(IF(SS1,REF(C,1),DRAWNULL),0)),COLORGREEN,LINETHICK2;
CB1:CONST(SUM(IF(BB1,REF(C,1),DRAWNULL),0)),COLORRED,LINETHICK2;

HH2:=CROSS(SUM(HH AND C>CS1*1.03,0),0.5);
LL2:=CROSS(SUM(LL AND C<CB1*0.97,0),0.5);
SS2:=SUM(HH2,0)*CROSS(COUNT(C<REF(C,1),BARSLAST(HH2)),0.5);
BB2:=SUM(LL2,0)*CROSS(COUNT(C>REF(C,1),BARSLAST(LL2)),0.5);
CS2:CONST(SUM(IF(SS2,REF(C,1),DRAWNULL),0)),COLORGREEN,LINETHICK1;
CB2:CONST(SUM(IF(BB2,REF(C,1),DRAWNULL),0)),COLORRED,LINETHICK1;

DRAWICON(HH1 OR HH2,C*1.01,39);
DRAWICON(LL1 OR LL2,C*0.99,38);
DRAWICON(BB1 OR BB2,REF(C,1)*0.99,7);
DRAWICON(SS1 OR SS2,REF(C,1)*1.01,8);

{强势涨停}
RC:=DYNAINFO(3);
地:=DYNAINFO(11)*1.02;
强势上涨:IF(DYNAINFO(7)>地,1,0),NODRAW;

{波段}
VAR7:=SMA(C,6.18,1);
VAR8:=SMA(VAR7,3.14,1);
DRAWBAND(VAR7,RGB(255,255,0),VAR8,RGB(0,255,255));

 

最新发布

相关文章