指标汇总
通达信★超跌一击★源码
来源:通达信公式 8684次浏览 发布时间2022-09-05

以下是通达信★超跌一击★源码

HJ_1:=REF(CLOSE,1);
 HJ_2:=SMA(MAX(CLOSE-HJ_1,0),6,1)/SMA(ABS(CLOSE-HJ_1),6,1)*100;
 HJ_3:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;
 HJ_4:=CROSS(85,HJ_2)*30;
 HJ_5:=SMA(MAX(CLOSE-HJ_1,0),7,1)/SMA(ABS(CLOSE-HJ_1),7,1)*100;
 HJ_6:=SMA(MAX(CLOSE-HJ_1,0),13,1)/SMA(ABS(CLOSE-HJ_1),13,1)*100;
 HJ_7:=BARSCOUNT(CLOSE);
 HJ_8:=CROSS(HJ_2,25);
 HJ_9:=EMA((CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5;
 HJ_10:=EMA((CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;
 HJ_11:=CROSS(HJ_9,HJ_10) AND HJ_9<(-100);
 HJ_12:=FILTER(COUNT(HJ_8 OR HJ_11,3)>=2,3);
超跌一击:(HJ_5<20 AND HJ_6<25 AND HJ_7>50 AND HJ_3<70 AND HJ_9<(-130))*300,COLOR37D42B;
 HJ_13:=KDJ.J#MONTH;
 HJ_14:=KDJ.J#WEEK;
 HJ_15:=KDJ.J;

 HJ_16:=IF(CROSS(HJ_15,0),300,0);
中线买点:IF(CROSS(HJ_14,0),200,0),COLORRED,LINETHICK2;
长线买点:IF(CROSS(HJ_13,0),300,0),COLORMAGENTA,LINETHICK2;
 DRAWICON(中线买点 AND HJ_16,5,15);
 DRAWICON(中线买点 AND 长线买点,8,11);
 DRAWICON(HJ_16 AND 长线买点,13,17);
 HJ_17:=(HIGH+LOW+CLOSE)/3;
 CCI:EMA((HJ_17-MA(HJ_17,36.027))/(0.015*AVEDEV(HJ_17,36.027)),2),COLORWHITE;
 STICKLINE(CCI<(-150),CCI,(-150),2.5,0),COLORRED;
 STICKLINE(CLOSE>0,(-150),(-151),2.5,0),COLORBLUE;
 STICKLINE(CLOSE>0,150,151,2.5,0),COLORBLUE;
 STICKLINE(CLOSE>0,100,100,2.5,0),COLORYELLOW;
 STICKLINE(CLOSE>0,(-100),(-100),2.5,0),COLORYELLOW;
 STICKLINE(CLOSE>0,0,0,2.5,0),COLORRED;
主力潜伏:COUNT(MACD.DIF<0,10)=10,NODRAW,COLORRED;
 STICKLINE(主力潜伏,0,MACD.DIF*200,10,0),COLORRED;
 STICKLINE(CCI<(-100),CCI,(-100),1,0),COLORMAGENTA;
 (-100);
 (-100),STICK,COLORYELLOW;
 DRAWTEXT_FIX(1,0.88,5,0,40),COLOR889999;

{-----------------------------------}

最新发布

相关文章