指标汇总
神奇指标广告
一组神獒技术指标源码(主图源码,收费、免费“大智慧”均可用)
来源:大智慧公式 4814次浏览 发布时间2022-10-21




以下是一组神獒技术指标源码(主图源码,收费、免费“大智慧”均可用)




《十二星座》轻松捕捉涨停股input:LONG(26,20,100),SHORT(12,5,40),M(9,2,60);a1:=1;a2:=DYNAINFO(14);a3:=(FINANCE2(37));a4:=(FINANCE2(3));a5:=DYNAINFO(17);a6:=(MA(CLOSE,0)) * a1;a7:=(MA(a6,0)) * a1;a8:=a6 - a7;STICKLINE((a6 > a7),a6,a7,0.8,501),linethick1,colorRed;STICKLINE((a7 > a6),a6,a7,0.8,1),linethick1;DRAWICON(((CROSS(a7,a6)) AND (TIME > 93200)),a6,8),colorGreen;DRAWICON(((CROSS(a6,a7)) AND (TIME > 93200)),a6,7),colorYellow;a9:=(CLOSE = ((HHV(CLOSE,0)) * a1)) AND (VOL >= 1000);a10:=VOL = (HHV(VOL,0));a11:=(STRFIND(STKNAME,'ST',1)) > 0;a12:=(STRFIND(STKNAME,'S',1)) > 0;a13:=NOT(a11) AND NOT(a12);a14:=SUM((((((a13 AND a9) AND a10) AND (CLOSE > (MA(CLOSE,0)))) AND (TIME > 93500)) AND (TIME < 145500)),0);a15:=((ALLBIDVOL / (ALLBIDVOL + ALLASKVOL)) * 100) * a1;a16:=(HIGH + LOW) / 2;a17:=(a14);a18:=(a15);a19:=(MA((MA(CLOSE,0)),0)) * a1;DRAWTEXT(((((a13 AND a9) AND a10) AND (TIME > 93500)) AND (TIME < 144500)),CLOSE,'黑马'),colorRed;DRAWTEXTABS(25,282,' '),colorCyan;DRAWTEXTABS(25,302,' '),colorCyan;DRAWTEXT((FILTER((((a5 > 1) AND (a14 >= 2)) AND (a8 > 0)),15)),a6,'㊣'),linethick3,coloryellow;a3:=(FINANCE2(37));DRAWTEXTABS(100,282,' 流通股 '+a3),colorGreen;a4:=(FINANCE2(3));DRAWTEXTABS(280,282,' 收益 '+a4),colorWhite;DRAWTEXTABS(290,282,' 量对比 '+a5),colorGreen;DRAWTEXTABS(25,262,'十二星座无视大盘战法:从涨幅排行中手动翻页筛选个股,发现㊣后分批买入'),colorCyan;DRAWTEXTABS(25,242,'最高宗旨:卖出股票参照◎点,买入股票参照★点,上下箭头代表趋势'),colorCyan;DRAWTEXTABS(25,222,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;a20:=(EMA(CLOSE,SHORT)) - (EMA(CLOSE,LONG));a21:=EMA(a20,M);a22:=2 * (a20 - a21);DRAWTEXT((FILTER(((a20 * a1) > 0.2),30)),CLOSE,'◎'),linethick2,colorGreen;DRAWTEXT((((FILTER(((a20 * a1) < -0.03),30)) AND (TIME > 113500)) AND (a2 > -0.02)),CLOSE,'★'),linethick3,colorRed;《神獒波段》波段高低起涨点input:N(5,1,111),N1(10,1,111),P(3,0.1,30),M(21,0,100);DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));a1:=(IF((DATE <= 1091025),1,0)) * (IF((CURRENTDATE <= 1091025),1,0));DRAWGBK((CLOSE > 0),'5');a2:=IF((CLOSE < 800),((AMOUNT / VOL) / 100),((((CLOSE * 2) + HIGH) + LOW) / 4));a3:=((HHV(HIGH,15)) + (LLV(LOW,30))) / 2;a4:=EMA((MA(a2,5)),10);a5:=EMA((MA(a2,15)),10);a6:=EMA((MA(a2,13)),21);a7:=((a4 + a5) + a6) / 3;a8:=(((REF(a7,1)) + a7) + (REF(a7,2))) / 3;决策线:EMA((MA(CLOSE,5)),3),colorGreen;PARTLINE(决策线,决策线 > (REF(决策线,3)),RGB(255,0,0)),linethick1,colorRed;UPR:决策线 + (3 * (STD(决策线,10))),Culor808000;DWN:决策线 - (3 * (STD(决策线,10))),CulorA10000;多空价:a8 * a1,linethick2,Culor008E00;半年线:MA(CLOSE,120),POINTDOT,linethick4,colorGray;年线:MA(CLOSE,250),CROSSDOT,Culor717143;STICKLINE((CLOSE > OPEN),HIGH,LOW,0.0001,1),colorRed;STICKLINE((CLOSE > OPEN),OPEN,CLOSE,8,1),Culor5050FF;STICKLINE((CLOSE < OPEN),OPEN,CLOSE,8,0),CulorFFFF85;STICKLINE((CLOSE < OPEN),HIGH,LOW,0.0001,0),colorCyan;a9:=((EMA((MA(a2,3)),3)) + (WMA(a2,5))) / 2;a10:=REF(a9,1);a11:=BARSCOUNT(CLOSE);a12:=IF((a11 = 1),0,(((a9 - a10) / a10) * 100));a13:=REF(CLOSE,1);a14:=IF((a11 = 1),0,(((CLOSE - a13) / a13) * 100));a15:=IF((a11 = 1),((CLOSE + OPEN) / 2),a10);a16:=REF(a9,2);a17:=((a9 + a10) + a16) / 3;a18:=((ABS((a9 - a17)) + ABS((a10 - a17))) + ABS((a16 - a17))) / 3;a19:=IF((a11 < 3),0,((a18 / a9) * 100));a20:=IF((((a12 > 0.5) AND ((a19 > 0.215) OR (LOW > a15))) AND (CLOSE >= OPEN)),1,0);a21:=IF((((a12 < (0 - 0.3)) AND ((a19 > 0.2) OR (HIGH < a15))) AND ((OPEN >= CLOSE) OR (a14 < -1))),1,0);B:((COUNT(a20,BARSLAST(a21))) = 1) AND a20,linethick0;D:((COUNT(a21,BARSLAST(a20))) = 1) AND a21,linethick0;a22:=BARSLAST(B);a23:=((SUM(D,a22)) = 0) * a22;a24:=a23 > 0;a25:=a23 = 0;STICKLINE(a24,CLOSE,OPEN,8,0),colorMagenta;STICKLINE(a24,CLOSE,OPEN,7,0),CulorFF28FF;STICKLINE(a24,CLOSE,OPEN,6,0),CulorFF3DFF;STICKLINE(a24,CLOSE,OPEN,5,0),CulorFF51FF;STICKLINE(a24,CLOSE,OPEN,4,0),CulorFF65FF;STICKLINE(a24,CLOSE,OPEN,3,0),CulorFF7AFF;STICKLINE(a24,CLOSE,OPEN,2,0),CulorFF8EFF;STICKLINE(a24,CLOSE,OPEN,1,0),CulorFFA2FF;STICKLINE(a25,CLOSE,OPEN,8,0),CulorFFFD02;STICKLINE(a25,CLOSE,OPEN,7,0),CulorF8FF24;STICKLINE(a25,CLOSE,OPEN,6,0),CulorFDFF4A;STICKLINE(a25,CLOSE,OPEN,5,0),CulorFCFF69;STICKLINE(a25,CLOSE,OPEN,4,0),CulorFDFD97;STICKLINE(a25,CLOSE,OPEN,3,0),CulorFFFFA2;STICKLINE(a25,CLOSE,OPEN,2,0),CulorFFFFB6;STICKLINE(a25,CLOSE,OPEN,1,0),CulorFFFFCC;STICKLINE(B,CLOSE,OPEN,8,0),colorYellow;STICKLINE(D,CLOSE,OPEN,8,0),Culor00BE00;DRAWTEXT(B,(LOW * 0.98),'㊣'),linethick2,ALIGN1,colorWhite;DRAWTEXT(D,(HIGH * 1.035),'S'),linethick2,ALIGN1,colorGreen;PARTLINE(决策线,决策线 > (REF(决策线,3)),RGB(255,0,0)),linethick1,colorRed;a26:=(((CLOSE / a13) - 1) * 100) >= (7 * a1);a27:=HIGH - ((HIGH - LOW) / 3);a28:=LOW + ((HIGH - LOW) / 3);PARTLINE(多空价,多空价 > (REF(多空价,3)),RGB(255,0,0)),linethick2,colorRed;DRAWTEXTREL(10,800,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;《神獒掌控》input:N(88,1,1111),N1(888,1,1111);DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));a1:=IF((CLOSE < 800),((AMOUNT / VOL) / 100),((((CLOSE * 2) + HIGH) + LOW) / 4));a2:=((HHV(HIGH,15)) + (LLV(LOW,30))) / 2;a3:=EMA((MA(a1,5)),10);a4:=EMA((MA(a1,15)),10);a5:=EMA((MA(a1,13)),21);a6:=((a3 + a4) + a5) / 3;决策线:EMA((MA(CLOSE,5)),3),colorGreen;PARTLINE(决策线,决策线 > (REF(决策线,3)),RGB(255,0,0)),linethick1,colorRed;多空带:((((REF(a6,1)) + a6) + (REF(a6,2))) / 3),linethick0;a7:=(((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 1.191;a8:=(((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 1.236;a9:=(((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 0.809;a10:=(((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 0.764;a11:=(((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 0.618;地线:(a9),linethick1,Culoryellow;天线:(a7),linethick1,CulorFF0000;支撑线:(a10),linethick2,Culor73740F;阻力线:(a8),linethick2,Culor509046;a12:=((EMA((MA(a1,3)),3)) + (WMA(a1,5))) / 2;a13:=REF(a12,1);a14:=BARSCOUNT(CLOSE);a15:=IF((a14 = 1),0,(((a12 - a13) / a13) * 100));a16:=REF(CLOSE,1);a17:=IF((a14 = 1),0,(((CLOSE - a16) / a16) * 100));a18:=IF((a14 = 1),((CLOSE + OPEN) / 2),a13);a19:=REF(a12,2);a20:=((a12 + a13) + a19) / 3;a21:=((ABS((a12 - a20)) + ABS((a13 - a20))) + ABS((a19 - a20))) / 3;a22:=IF((a14 < 3),0,((a21 / a12) * 100));a23:=IF((((a15 > 0.5) AND ((a22 > 0.215) OR (LOW > a18))) AND (CLOSE >= OPEN)),1,0);a24:=IF((((a15 < (0 - 0.3)) AND ((a22 > 0.2) OR (HIGH < a18))) AND ((OPEN >= CLOSE) OR (a17 < -1))),1,0);FILLRGN((((REF(a6,1)) + a6) + (REF(a6,2))) / 3,(((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 0.985,CLOSE > a2,RGB(250,0,0),CLOSE < a2,RGB(101,0,185));B:((COUNT(a23,BARSLAST(a24))) = 1) AND a23,linethick0;D:((COUNT(a24,BARSLAST(a23))) = 1) AND a24,linethick0;DRAWTEXT(B,(LOW * 0.98),'㊣'),linethick3,ALIGN1,colorWhite;DRAWTEXT(D,(HIGH * 1.035),'S'),linethick3,ALIGN1,colorGreen;STICKLINE(((B > 0) OR (D > 0)),a1,(a1 * 0.998),8,0),CulorFF0000;a25:=(EMA(CLOSE,12)) - (EMA(CLOSE,26));a26:=EMA(a25,9);a27:=2 * (a25 - a26);a28:=IF((((((((REF(a27,1)) < (REF(a27,2))) AND ((REF(a27,2)) < (REF(a27,3)))) AND (a27 > (REF(a27,1)))) AND (a27 >= 0)) AND ((LLV(a27,4)) > 0)) AND (COUNT((a27 < 0.18),5))),(a27 * 2),0);a29:=IF(((COUNT((CROSS(a26,a25)),8)) AND (CROSS(a25,a26))),(a27 * 4),0);a30:=(a28 > 0) AND (CLOSE >= (((REF(a6,1)) + a6) + (REF(a6,2))) / 3);DRAWICON(a30,LOW,12),ALIGN1;a31:=(((CLOSE / a16) - 1) * 100) >= 7;a32:=HIGH - ((HIGH - LOW) / 3);a33:=LOW + ((HIGH - LOW) / 3);a34:=(CLOSE > 0) AND a31;a35:=((HIGH - LOW) * 0.618) + LOW;a36:=((HIGH - LOW) * 0.382) + LOW;STICKLINE(a34,a32,a33,8,0),colorYellow;STICKLINE(a34,((HIGH + LOW) / 2),((HIGH + LOW) / 2),8,0);STICKLINE(a34,CLOSE,a35,8,0),colorRed;STICKLINE(a34,CLOSE,a35,7,0),Culor1414FF;STICKLINE(a34,CLOSE,a35,6,0),Culor2828FF;STICKLINE(a34,CLOSE,a35,5,0),Culor3D3DFF;STICKLINE(a34,CLOSE,a35,4,0),Culor5151FF;STICKLINE(a34,CLOSE,a35,3,0),Culor6565FF;STICKLINE(a34,CLOSE,a35,2,0),Culor7A7AFF;STICKLINE(a34,CLOSE,a35,1,0),Culor8E8EFF;STICKLINE(a34,a36,OPEN,8,0),colorGreen;STICKLINE(a34,a36,OPEN,7,0),Culor28FF28;STICKLINE(a34,a36,OPEN,6,0),Culor3DFF3D;STICKLINE(a34,a36,OPEN,5,0),Culor51FF51;STICKLINE(a34,a36,OPEN,4,0),Culor65FF65;STICKLINE(a34,a36,OPEN,3,0),Culor7AFF7A;STICKLINE(a34,a36,OPEN,2,0),Culor8EFF8E;STICKLINE(a34,a36,OPEN,1,0),CulorA2FFA2;a37:=((CLOSE - (EMA(a1,25))) / (EMA(a1,25))) * 100;DRAWTEXT(((a37 > 12) AND (CROSS(决策线,CLOSE))),HIGH,'卖出');a38:=BIGORDER(1,2);a39:=BIGORDER(2,2);a40:=(((a38 - a39) * VOL) / CAPITAL) * 500;DRAWTEXT(((a40 > 0.5) OR (LAST((a40 > 0)) > 1)),((((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 1.002),'● '),colorYellow;DRAWTEXT((a40 > 1),((((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 1.002),'★'),CulorFF0087;DRAWTEXT((a40 > 2),((((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 1.002),'★'),colorBlack;DRAWTEXT((((((REF(a40,1)) >= (HHV(a40,20))) AND (a40 >= (LLV(a40,20)))) AND ((REF(a40,1)) > 2.5)) AND (a40 < -2.5)),(HIGH * 1.02),'◤反转'),colorGreen;DRAWTEXT(((((OPEN / a16) > 1.03) AND (CLOSE < OPEN)) AND (a40 < 0)),HIGH,'出货'),colorMagenta;a41:=LOW < a11;DRAWICON(a41,LOW,1);DRAWICON((((CROSS(CLOSE,(REF(a9,1)))) AND (a15 < -3)) OR (((LOW < 支撑线) AND (CLOSE > 支撑线)) AND (a15 < -3.5))),LOW,7),ALIGN1;DRAWICON(((CROSS((REF(a7,1)),CLOSE)) AND (a40 < 0)),(HIGH * 1.015),8),ALIGN1;DRAWTEXT(((CROSS(CLOSE,(REF(a9,1)))) AND (a40 > 0)),LOW,'1/3仓'),colorMagenta;DRAWTEXT(((CROSS((REF(a7,1)),CLOSE)) AND (a40 < 0)),(HIGH * 1.05),'1/3仓出'),Culor00DB00;DRAWTEXT((CROSS(CLOSE,(REF(a10,1)))),(LOW * 0.96),'仓1/2'),colorYellow;DRAWTEXT((CROSS(CLOSE,(REF(((((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 0.681),1)))),(LOW * 0.98),'1/2仓'),Culor005EFF;STICKLINE(((CLOSE > 0) AND (DISPSTATUS = 2)),((((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 1.15),((((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 1.15),20,0),colorWhite;STICKLINE(((CLOSE > 0) AND (DISPSTATUS = 2)),((((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 0.85),((((REF(a6,1)) + a6) + (REF(a6,2))) / 3 * 0.85),20,0);DRAWTEXT(a41,HIGH,'满仓出击');a42:=(CYC(8) - (REF(CYC(8),1))) / (REF(CYC(8),1));a43:=((SMA((MAX((CLOSE - a16),0)),5,1)) / (SMA(ABS((CLOSE - a16)),5,1))) * 100;DRAWTEXT(((((CROSS(90,a43)) AND (a40 < 0)) AND ((CLOSE / OPEN) <= 0.985)) OR (((a43 > 90) AND (a40 < 0)) AND ((CLOSE / OPEN) <= 0.985))),(HIGH * 1.04),'▼'),ALIGN1,colorGreen;DRAWTEXT(((((CROSS(a43,10)) AND (a40 > 0)) OR ((a43 < 10) AND (a40 > 0))) OR (((LOW < 支撑线) AND (CLOSE > 支撑线)) AND (a40 > 0))),(LOW * 0.97),'▲'),ALIGN1,colorRed;DRAWTEXT(((CROSS(a43,10)) AND (a15 < -4)),(LOW * 0.92),'◢◣'),ALIGN1,colorRed;DRAWTEXT((((a15 < -5) AND (a37 < -24)) AND (a43 < 12)),(LOW * 0.95),'▲'),ALIGN1,colorMagenta;DRAWTEXT(((((a15 < -3) AND (a40 > 0)) AND (LOW <= 地线)) AND (CLOSE > 地线)),(LOW * 0.94),'◆'),ALIGN1,colorYellow;DRAWTEXT(((CLOSE > 0) AND (DISPSTATUS = 2)),(决策线 * 0.9),'多空价:'+REF(a6,1)),MOVE10,ALIGN2,colorYellow;DRAWTEXT(((CLOSE > 0) AND (DISPSTATUS = 2)),(a7 * 1.05),'天线:'+a7),MOVE10,ALIGN2,CulorFF8748;DRAWTEXT(((CLOSE > 0) AND (DISPSTATUS = 2)),(a9 * 0.96),'地线:'+a9),MOVE10,ALIGN2,Culor766A6C;DRAWTEXT(((CLOSE > 0) AND (DISPSTATUS = 2)),(决策线 * 0.95),'决策价:'+决策线),MOVE10,ALIGN2,colorRed;PARTLINE(支撑线,(MA(a1,10)) > (MA(a1,240)),RGB(255,0,255)),linethick2,colorMagenta;a44:=LOW > (REF(HIGH,1));a45:=HIGH < (REF(LOW,1));PARTLINE(地线,(MA(a1,10)) > (MA(a1,72)),RGB(255,255,0)),linethick1,colorYellow;DRAWTEXT(a44,((REF(HIGH,1)) * 1.003),'─'),ALIGN1,colorWhite;DRAWTEXT(a44,(LOW * 1.003),'─'),ALIGN1,colorWhite;DRAWTEXT(a45,((REF(LOW,1)) * 1.003),'─'),ALIGN1,colorGreen;DRAWTEXT(a45,(HIGH * 1.003),'─'),ALIGN1,colorGreen;DRAWTEXTREL(0,0,'评级:'+Extrastring('评级')),colorCyan;DRAWTEXTABS(1,15,'所属板块:'+BKNAME),CulorAFFF00;DRAWTEXTREL(0,130,'每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),2)+'元'+' 市净率:'+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+'元'+' 净资产:'+NUMTOSTRN(FINANCE2(4),2)+'元'),Culor00C0FF;DRAWTEXTREL(10,900,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;《神獒主升》input:N(2,1,100),N1(3,2,100),N3(10,5,100),N4(10,1,100),P(3,0.1,20);中轨:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,linethick2,COLOR800080;天线:中轨+P*STD(中轨,N4),linethick2,Culor00C0FF;地线:中轨-P*STD(中轨,N4),linethick2,colorCyan;MA1:sma(c,4,1),colorgreen,linethick1;MA2:ema(c,21),colorred,linethick1;神獒主升线:ma1,linethick2,coloryellow;星座持股线:ma2,linethick2,color0000ff;DRAWTEXT(cross(ma1,ma2),ma1,'㊣'),linethick2,color0000ff;DRAWTEXT(cross(ma2,ma1),ma1,'卖'),color00ff00;mm1:=sma(c,2,1);ma3:=ma(mm1,3);ss1:=cross(ma3,ma1) and ma1>ref(ma1,1) and ma1<ma2;DRAWTEXT(ss1,ma1*1.05,'盯'),colorff00ff;mm2:=sma(c,2,1);ma4:ma(mm1,3),color00ffff,linethick1;ss2:=cross(ma4,ma2) and ma2<ref(ma2,1) and ma2<ma1;DRAWTEXT(ss2,ma2*1.05,'★小心★'),colorff00ff;ah:hhvall(h); al:llvall(l); ahl:=ah-al;a23:al+ahl*0.236,COLORYELLOW,POINTDOT; a38:al+ahl*0.382,COLOREE00EE,POINTDOT; a50:al+ahl*0.50,COLORYELLOW,POINTDOT; a61:al+ahl*0.618,COLOREE00EE,POINTDOT; a76:al+ahl*0.764,COLORYELLOW,POINTDOT; {标注数字}y:=999;DRAWTEXTREL(500,0,'100% '+ah),COLOREE00EE;DRAWTEXTREL(500,y*0.236,'76.4% '+a76),COLORYELLOW;DRAWTEXTREL(500,y*0.382,'61.8% '+a61),COLOREE00EE;DRAWTEXTREL(500,y*0.50,'50% '+a50),COLORYELLOW;DRAWTEXTREL(500,y*0.618,'38.2% '+a38),COLOREE00EE;DRAWTEXTREL(500,y*0.764,'23.6% '+a23),COLORYELLOW;DRAWTEXTREL(500,y-30,'最低 '+al),COLOREE00EE;DRAWTEXTREL(1,795,'所属板块:'+BKNAME),CulorAFFF00;DRAWTEXTREL(0,850,'每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),2)+'元'+' 市净率:'+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+'元'+' 净资产:'+NUMTOSTRN(FINANCE2(4),2)+'元'),Culor00C0FF;DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));DRAWTEXTREL(10,900,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;Var1:=EMA(EMA(EMA((CLOSE*6+LOW*2+HIGH+OPEN)/10,N),N),N);短线:= Var1-REF(Var1,1)+Var1;中短:= MA(短线,N1);Var2:=EMA(EMA(EMA((CLOSE*6+LOW+HIGH*2+OPEN)/10,N),N),N);H短线:= Var2-REF(Var2,1)+Var2;H中短:= MA(H短线,N1);中线:= EMA(CLOSE,10);m中线:= EMA(中线,10);stickline(CROSS(短线,中短),c,o,7,0),colorred;stickline(CROSS(短线,中短),h,l,1,0),colorred;stickline(CROSS(H中短,H短线),c,o,7,0),colorgreen;stickline(CROSS(H中短,H短线),h,l,1,0),colorgreen;DRAWTEXT(CROSS(短线,中短),(LOW * 0.995),'★'),LINETHICK1,colorYELLOW;DRAWTEXT(CROSS(H中短,H短线),(HIGH * 1.02),'▼'),LINETHICK2,colorwhite;gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);明日阻力:=l+(gj-l)+(c-l);明日支撑:=l+(c-gj);今日阻力:=REF(明日阻力 , 1);今日支撑:=REF(明日支撑 , 1);STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,20,0),Culor0000FF;STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,20,0),Culor00FF00;STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,20,0),CulorFF00FF;STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,20,0),CulorFF9900;DRAWTEXTREL(830,5,'今日支撑:'+NUMTOSTRN(今日支撑 ,2 )),Culorred;DRAWTEXTREL(700,5,'今日阻力:'+NUMTOSTRN(今日阻力 ,2 )),CulorGREEN;《星座趋势》input:N(13,1,99),M(1,0,60),P(3,1,300),P2(5,1,300),P3(36,1,300),P4(13,1,300),P5(65,1,300);a1:=1;a2:=(EMA(CLOSE,3)) * a1;a3:=(EMA((((SLOPE(CLOSE,22)) * 20) + CLOSE),55)) * a1;a4:=MA(a3,1);a5:=a4 * 0.985;a6:=MA(CLOSE,5);a7:=MA(CLOSE,13);a8:=MA(CLOSE,21);a9:=IF((a2 > a4),a4,a5);STICKLINE((a2 > (a4 * a1)),(a4 * 1.001),(a4 + 0.018),6,501),linethick2,colorRed;STICKLINE((a2 < (a4 * a1)),(a4 * 1.001),(a4 + 0.018),6,501),linethick2,colorGreen;a10:=(CLOSE > (REF(CLOSE,1))) AND (CLOSE > (REF(CLOSE,2)));a11:=((REF(a10,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a12:=((REF(a11,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a13:=((REF(a12,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a14:=((REF(a13,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a15:=((REF(a14,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a16:=((REF(a15,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a17:=((REF(a16,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a18:=((REF(a17,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a19:=((REF(a18,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a20:=((REF(a19,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a21:=((REF(a20,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a22:=(CLOSE < (REF(CLOSE,1))) AND (CLOSE < (REF(CLOSE,2)));a23:=((REF(a22,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a24:=((REF(a23,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a25:=((REF(a24,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a26:=((REF(a25,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a27:=((REF(a26,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a28:=((REF(a27,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a29:=((REF(a28,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a30:=((REF(a29,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a31:=((REF(a30,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a32:=((REF(a31,1)) AND (CLOSE <= (REF(CLOSE,1)))) AND (CLOSE >= (REF(CLOSE,2)));a33:=((REF(a32,1)) AND (CLOSE >= (REF(CLOSE,1)))) AND (CLOSE <= (REF(CLOSE,2)));a34:=(REF((((((((((((a22 OR a23) OR a24) OR a25) OR a26) OR a27) OR a28) OR a29) OR a30) OR a31) OR a32) OR a33),1)) AND a10;STICKLINE((a34 * a1),LOW,(LOW + 0.1),12,1),linethick2,colorYellow;a35:=(REF((((((((((((a10 OR a11) OR a12) OR a13) OR a14) OR a15) OR a16) OR a17) OR a18) OR a19) OR a20) OR a21),1)) AND a22;STICKLINE((a35 * a1),HIGH,(HIGH - 0.1),12,1),linethick2,colorWhite;a36:=a6 * a1;a37:=(MA(CLOSE,10)) * a1;a38:=(MA(CLOSE,20)) * a1;a39:=(MA(CLOSE,30)) * a1;a40:=(MA(CLOSE,250)) * a1;a41:=BARSLAST((CROSS(a36,a37)));a42:=BARSLAST((CROSS(a37,a36)));a43:=IF((a41 < a42),(a41 + 1),0);a44:=IF((a42 < a41),(a42 + 1),0);a45:=(((a36 > a38) AND (a37 > a38)) AND (a38 > (REF(a38,1)))) AND (a39 > (REF(a39,1)));a46:=a43 * a45;a47:=a44 * a45;a48:=((((HHV(a43,5)) >= 2) AND a45) AND (a36 > (REF(a36,1)))) AND (a36 > a37);a49:=a48 * a43;a50:=BARSLAST(((a49 > 0) AND NOT((REF(a49,1))))) + 1;a51:=((CLOSE / (REF(CLOSE,a50))) - 1) * 100;a52:=(a46 > 0) AND (a49 = 0);a53:=BARSLAST(a52) + 1;a54:=(ATAN((((a36 / (REF(a36,1))) - 1) * 100)) * 180) / 3.14159;a55:=(a54 > (REF(a54,1))) AND ((REF(a54,1)) < (REF(a54,2)));a56:=(a36 > (REF(a36,1))) AND ((REF(a36,1)) < (REF(a36,2)));a57:=FILTER((((a55 OR a56) AND (CLOSE > a36)) AND a48),3);a58:=BARSLAST(a57);STICKLINE(a52,(((OPEN + CLOSE) / 2) - 0.01),(((OPEN + CLOSE) / 2) + 0.01),4,0),colorGreen;STICKLINE(a52,LOW,HIGH,1,1),colorGreen;STICKLINE(a57,(((OPEN + CLOSE) / 2) - 0.01),(((OPEN + CLOSE) / 2) + 0.01),4,0),colorYellow;STICKLINE(a57,LOW,HIGH,1,1),colorYellow;STICKLINE(((a58 > 0) AND (a58 <= 5)),(REF(OPEN,(a58 + 1))),(REF(OPEN,(a58 + 1))),4,1),colorWhite;DRAWTEXT(a57,LOW,'▲'),colorYellow;DRAWTEXT(a49,a9,'○'),colorWhite;DRAWTEXT(a52,a9,'□'),colorGreen;DRAWTEXT(((a2 > (a4 * a1)) AND (a34 * a1)),(LOW - 0.05),'㊣'),linethick3,colorRed;DRAWTEXT(((a2 < (a4 * a1)) AND (a35 * a1)),(HIGH + 0.05),'▼'),linethick3,Culor9000F5;a59:=EMA(CLOSE,5);a60:=IF((CLOSE = INDEXC),((((INDEXC + INDEXH) + INDEXL) + INDEXO) / 4),((AMOUNT / (VOL + 0.01)) / 100));a61:=(((LOW + (a60 - LOW)) + (CLOSE - LOW)));a62:=((LOW + (CLOSE - a60)));a61:=(((LOW + (a60 - LOW)) + (CLOSE - LOW)));a62:=((LOW + (CLOSE - a60)));a63:=(REF(a61,1)) * a1;a64:=(REF(a62,1)) * a1;STICKLINE(((DISPSTATUS = 2) AND (CLOSE >= a63)),a63,a63,30,0),colorRed;STICKLINE(((DISPSTATUS = 2) AND (CLOSE < a63)),a63,a63,30,0),colorGreen;STICKLINE(((DISPSTATUS = 2) AND (CLOSE >= a64)),a64,a64,30,0),colorMagenta;STICKLINE(((DISPSTATUS = 2) AND (CLOSE < a64)),a64,a64,30,0),CulorFF0000;主力线:MA(CLOSE,5);散户线:MA(CLOSE,6);趋势线:MA(CLOSE,13),linethick5,colorred;DRAWTEXTREL(1,760,'所属板块:'+BKNAME),CulorAFFF00;DRAWTEXTREL(1,830,'每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),2)+'元'+' 市净率:'+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+'元'+' 净资产:'+NUMTOSTRN(FINANCE2(4),2)+'元'),Culor00C0FF;DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));DRAWTEXTREL(10,900,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;《神獒霸气》{45度异动}x1:=(C+L+H)/3;bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;ema8:=ema(c,8);DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),ema8,'∠45上升'),coloryellow;ah:hhvall(h); al:llvall(l); ahl:=ah-al;a23:al+ahl*0.236,COLORYELLOW,POINTDOT; a38:al+ahl*0.382,COLOREE00EE,POINTDOT; a50:al+ahl*0.50,COLORYELLOW,POINTDOT; a61:al+ahl*0.618,COLOREE00EE,POINTDOT; a76:al+ahl*0.764,COLORYELLOW,POINTDOT; {标注数字}y:=999;DRAWTEXTREL(500,0,'100% '+ah),COLOREE00EE;DRAWTEXTREL(500,y*0.236,'76.4% '+a76),COLORYELLOW;DRAWTEXTREL(500,y*0.382,'61.8% '+a61),COLOREE00EE;DRAWTEXTREL(500,y*0.50,'50% '+a50),COLORYELLOW;DRAWTEXTREL(500,y*0.618,'38.2% '+a38),COLOREE00EE;DRAWTEXTREL(500,y*0.764,'23.6% '+a23),COLORYELLOW;DRAWTEXTREL(500,y-30,'最低 '+al),COLOREE00EE;DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));varl13:=("macd.diff#WEEK"(26,12,9));varl14:=("macd.dea#WEEK"(26,12,9));VL:=REF(LOW,1); VH:=REF(H,1);Var1:=SMA(ABS(H-Vh),13,1)/SMA(MAX(H-Vh,0),13,1)*100; Var2:=SMA(ABS(L-VL),13,1)/SMA(MAX(L-VL,0),13,1)*100;Var3:=MA(Var1,13); Var4:=MA(Var2,13);Var5:=LLV(L,34);Var6:=HHV(H,34);Var7:=EMA(IF(H>=Var6,Var3,0),3);Var8:=EMA(IF(L<=Var5,Var4,0),3);var9:=(SMA(SMA((((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54))) * 100),7,1),5,1));var10:=((SMA(((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54)) * 100),7,1)) * 16.18) - (var9* 10.9);Var11:=FILTER(IF(var10<=var9 AND Var8>REF(Var8,1),Var8*8,0),55);Var21:=LLV(LOW,60);Var31:=HHV(HIGH,60);Var41:=EMA((CLOSE-Var21)/(Var31-Var21)*100,13);Var51:=EMA(0.667*REF(Var41,1)+0.333*Var41,21);varl2:=FILTER(CROSS(Var51,Var41) AND Var41>84,13);持股线:MA(C,26),LINETHICK3,coloryellow;趋势线:MA(CLOSE,13),linethick5,colorred;qjj:FILTER((CROSS(varl13,varl14) and varl14<0 and CROSS(c,持股线)),90),LINETHICK0;DRAWTEXTREL(10,900,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;DD:=FINANCE2(35);SS:=FINANCE2(37);GG:=FINANCE2(3);TH:=DYNAINFO(39);DRAWTEXTREL(10,720,'总股本:'+NUMTOSTRn(DD,0)+'万股' +' 流通A股:'+NUMTOSTRn(SS,0)+'万股'+'市盈率:'+NUMTOSTRn(TH,2)+' 倍'+' 每股收益:'+NUMTOSTRn(GG,3)+' 元'),CulorFFFF00;DRAWTEXT(var11,C*0.98,'㊣'),linethick4,CulorFFFF00;DRAWICON(qjj,C*1.09,1);DRAWTEXT(qjj,l*0.78,'霸占大牛股'),COLOR00FFFF;DRAWTEXT(varl2,C*1.04,'逃跑'),Culorgreen;获利比例:=(WINNER(C)*1000)/10;平均成本:=(COST(50)*100)/100;穿透力:=(winner(C)-winner(ref(C,1)))/v*capital;90%成本:=FLOOR(COST(50-90/2)*100)/100;~:=CEILING(COST(50+90/2)*100)/100;90集中度:=INTPART((~-90%成本)/(~+90%成本)*1000)/10;70%成本:=FLOOR(COST(50-70/2)*100)/100;~~:=CEILING(COST(50+70/2)*100)/100;70集中度:=INTPART((~~-70%成本)/(~~+70%成本)*1000)/10;DRAWTEXTABS(0,12,' 获利比例:'+STR(获利比例)),COLOR44bbff;DRAWTEXTABS(0,24,' 平均成本:'+STR(平均成本)),COLOR44bbff;DRAWTEXTABS(0,36,' 穿透力:'+STR(穿透力)),COLOR44bbff;DRAWTEXTABS(0,48,'90%成本:'+STR(90%成本)+'-'+STR(~)),COLOR44bbff;DRAWTEXTABS(0,60,'90集中度:'+STR(90集中度)),COLOR44bbff;DRAWTEXTABS(0,72,'70%成本:'+STR(70%成本)+'-'+STR(~~)),COLOR44bbff;DRAWTEXTABS(0,84,'70集中度:'+STR(70集中度)),COLOR44bbff;gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);明日阻力:=l+(gj-l)+(c-l);明日支撑:=l+(c-gj);今日阻力:=REF(明日阻力 , 1);今日支撑:=REF(明日支撑 , 1);STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,20,0),Culor0000FF;STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,20,0),Culor00FF00;STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,20,0),CulorFF00FF;STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,20,0),CulorFF9900;DRAWTEXTREL(770,5,'今日支撑:'+NUMTOSTRN(今日支撑 ,2 )),Culorred;DRAWTEXTREL(630,5,'今日阻力:'+NUMTOSTRN(今日阻力 ,2 )),CulorGREEN;DRAWTEXTREL(1,800,'所属板块:'+BKNAME),CulorAFFF00;DRAWTEXTREL(1,850,'每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),2)+'元'+' 市净率:'+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+'元'+' 净资产:'+NUMTOSTRN(FINANCE2(4),2)+'元'),Culor00C0FF;《星座解析》input:N2(1,1,100),N1(8,2,100),N3(10,5,100),N(9,1,100),M1(3,1,100),M2(3,1,100);MA5:MA(C,5),PRECIS2;MA10:MA(C,10),PRECIS2;MA20:=MA(C,20);MA40:MA(C,40),PRECIS2;MA60:MA(C,60),PRECIS2;MA125:MA(C,125),PRECIS2;MA250:MA(C,250),PRECIS2;DRAWTEXTABS(40,30,'点击右边版面中的“评”字,将呈现十二星座特制全自动技术理论股评'),colorFF00FF,LINETHICK1;BIAS:=(C-MA20)/MA20*100;SHOPEN:=OPEN;SHHIGH:=HIGH;SHLOW:=LOW;SHCLOSE:=CLOSE;SHAMOUNT:=AMOUNT;SHVOL:=VOL;J12:=(HIGH - ((HIGH - LOW) / 3));J23:=(LOW + ((HIGH - LOW) / 3));t1:=(((IF((CLOSE = OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0)) > 1);t2:=((((CLOSE > J23) AND (CLOSE < J12)) AND (OPEN > J23)) AND (OPEN < J12));t3:=((CLOSE >= J12) AND (OPEN <= J23));t4:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE > J12));t5:=(((OPEN <= J23) AND (CLOSE <= J12)) AND (CLOSE >= J23));t6:=((CLOSE <= J23) AND (OPEN >= J12));t7:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE < J23));t8:=(((OPEN >= J12) AND (CLOSE <= J12)) AND (CLOSE >= J23));t9:=(((SHAMOUNT / SHVOL) / 100) > REF(HIGH,1));t10:=(((SHAMOUNT / SHVOL) / 100) < REF(LOW,1));if DISPSTATUS=2 then begin;var1000:='.';if t1>0 then var1000:=var1000+'☆极端行情,在未来的几日内有85%的机会变更方向。';if t2>0 then var1000:=var1000+'☆中性行情,多空双方都未能取得当日行情主动性的控制权';if t3>0 then var1000:=var1000+'☆爬升行情,整个交易期间都有买方主导。';if t4>0 then var1000:=var1000+'☆爬升行情,信息较少,但收盘期间是买方主导,其他未知。';if t5>0 then var1000:=var1000+'☆爬升行情,买方把收盘价拉升到开盘价之上,卖方却也主导一段行情,但不知道是谁主导最后的行情。';if t6>0 then var1000:=var1000+'☆漂流行情,整个交易期间都有卖方主导。';if t7>0 then var1000:=var1000+'☆漂流行情,信息最少,但收盘期间是卖方主导,其他未知。';if t8>0 then var1000:=var1000+'☆漂流行情,卖方把收盘价压至到开盘价之下,买方却也主导一段行情,但不知道是谁主导最后的行情。';if t9>0 then var1000:=var1000+'☆上涨趋势。';if t10>0 then var1000:=var1000+'☆下跌趋势。';if MA20>=MA60 AND CROSS(MA40,MA60) then var1000:=var1000+'☆形成季托,待股价回落到20天均线或40天均线时介入,20天均价为:'+MA20+' 。';if BIAS>9.5 AND (C-REF(C,1))/REF(C,1)*100<9.8 then var1000:=var1000+'☆短线涨幅过大,有整理要求。';if MA20>=MA60 AND H>=MA20 AND L<=MIN(MA40,MA60) AND C>O AND C>REF(C,1) then var1000:=var1000+'☆芙蓉出水,趋势向好。';if BIAS<-18 AND (C-REF(C,1))/REF(C,1)*100>-9.8 then var1000:=var1000+'☆股价严重超跌,有爆发要求。';if BIAS<-7 AND ALL(CLOSE<OPEN,5) then var1000:=var1000+'☆连收五阴,超跌有反弹要求。';if ABS(HIGH-REF(HIGH,1))/HIGH<0.001 then var1000:=var1000+'☆平顶,-该高点有一定阻力。';if ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.00 then var1000:=var1000+'☆平底,该低点有一定支撑。';if CLOSE=OPEN AND HIGH<>close and low<>close and HIGH/LOW > 1.03 then var1000:=var1000+'☆ 长十字,多空激争 前途未明。';if OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018 then var1000:=var1000+'☆ 大阴烛,今日空方有绝对优势。';if REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98 then var1000:=var1000+'☆双飞乌鸦,多头力竭,行情走软。';if (MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667 then var1000:=var1000+'☆长下影,下档支撑强或空方试探进攻。';if (HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667 then var1000:=var1000+'☆长上影,上档阻力大或多方试探进攻。';if CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH then var1000:=var1000+'☆垂死十字,在顶部时重要 表强力多头开始疲软。';if HIGH=CLOSE AND HIGH<>LOW then var1000:=var1000+'☆光头阳线,今日尾盘多方气盛,行情可能延续到明天。';if (HIGH<REF(LOW,1) OR LOW>REF(HIGH,1)) then var1000:=var1000+'☆跳空缺口,当日未补,有与跳空同向进行,上涨欲望强烈,三日内为回补观察期。';if LOW=CLOSE AND HIGH<>LOW then var1000:=var1000+'☆赤脚阴线,尾盘空方胜。 注意股价下跌延续至次日。';if CLOSE=OPEN AND HIGH<>close and low<>close and high <>close then var1000:=var1000+'☆十字星,警告信号。原趋势停顿或反转,依上下影线长度判后市。';if CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018 then var1000:=var1000+'☆大阳烛,上升行情中意味行情剧烈向上攀升;下跌行情中意味行情剧烈向上反弹。';IF REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1)AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2) THEN var1000:=var1000+'☆早晨十字,如同晨星。 从看空平衡到看涨转强;左右跳空曰弃婴 。';IF REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4) THEN var1000:=var1000+'☆上升三部曲,空方卖压被吸纳。 趋势易顺势走涨。';IF (ref(high,2) -ref(o,2))/ref(high,2)<=0.0003 AND (c-low)/o<=0.0003 AND ref(c,2)<ref(o,2) AND ref(c,2)>ref(o,1) AND ref(c,1)>o AND ref(c,1)<ref(o,1) AND ref(high,1)-ref(o,1)>0 AND ref(low,1)-ref(c,1)<0 AND high-o>0 AND ref(c,2)-ref(low,2)>0 THEN var1000:=var1000+'☆三胎乌鸦,多头走势被扭转。黑K价愈深量愈大,跳空愈大,反转信号愈强。';IF ((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)) THEN var1000:=var1000+'☆友好反攻,阴(阳)线结合,极线多方跳低(高)后反弹有企稳迹象 。';IF close<>open and MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5) THEN var1000:=var1000+'☆射击之星,如伴大量上遇阻力,有短期见顶可能,股价转疲。';IF REF(CLOSE,1)-REF(OPEN,1)<0 AND CLOSE-OPEN>0 AND OPEN-REF(CLOSE,1)<0 AND CLOSE<REF(OPEN,1) AND CLOSE>REF(CLOSE,1) AND CLOSE>(REF(CLOSE,1)+REF(OPEN,1))/2 THEN var1000:=var1000+'☆贯穿线,多头力道的反扑或是空单回补力道。长黑之后开低收在前天1/2之上,为多头反转信号。';IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1)) THEN var1000:=var1000+'☆身怀六甲,阴(阳)怀阳(阴),怪异的走势,显示该股行情可能转向。 若量由大转缩,下跌趋势更明确。';IF (ref(c,1)-ref(o,1)<0 AND c-o>0 AND c>ref(o,1) AND o<ref(c,1)) THEN var1000:=var1000+'☆多头阳线吞噬,红包黑。反转趋势需量能配合量。 ';IF ((ref(c,2)-ref(o,2)>0 AND (ABS(ref(c,2)-ref(o,2)))/(ABS(ref(c,3)-ref(o,3)))>2.4 AND ABS(c-o)>3 AND ABS(ref(c,2)-ref(o,2))>(ABS(ref(c,1)-ref(o,1))) AND ref(c,1)-ref(o,1)>0 AND c-o<0 AND ref(o,1) >ref(c,2) AND o<ref(o,1) AND c<ref(c,2) AND c>ref(o,2)) OR (ref(c,2)-ref(o,2)>0 AND (ABS(ref(c,2)-ref(o,2)))/(ABS(ref(c,3)-ref(o,3)))>2.4 AND ABS(c-o)>3 AND (ABS(ref(c,2)-ref(o,2)))>(ABS(ref(c,1)-ref(o,1))) AND ref(c,1)-ref(o,1)<0 AND c-o<0 AND ref(c,1) >ref(c,2) AND c<ref(c,2) AND c>ref(o,2) AND o<ref(c,1))) THEN var1000:=var1000+'☆夜星,从看多平衡到看空转弱,转空。 ';IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1)) THEN var1000:=var1000+'☆十字胎,似身怀六甲,转向可能性更大,量缩观望为宜 。'; IF ref(c,1)<ref(o,1) AND c-o>0 AND c>ref(H,1) AND o<ref(L,1) and ref(O,1)>ref(max(O,C),2) and ref(C,1)>ref(min(O,C),2) and ref(max(O,C),2)>ref(max(O,C),3) THEN var1000:=var1000+'☆ 双人殉情 ,在上升趋势中最后之空头吞噬,也就是所谓的不见长红不回头。 ';IF (ref(c,1)-ref(o,1)>0 AND c-o<0 AND c<ref(o,1) AND o>ref(c,1)) THEN var1000:=var1000+'☆阴线吞噬,黑包红,向空反转。 '; IF REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1) THEN var1000:=var1000+'☆曙光,与乌云盖顶相反,行情将演化为V型反转或止跌横盘趋势 。';IF (ref(c,1)-ref(o,1)<0 AND c-o>0 AND c<ref(o,1) AND o>ref(c,1)) THEN var1000:=var1000+'☆多头孕育线,阴育阳。多头反转可能。'; IF (ref(c,1)-ref(o,1)>0 AND (ABS(ref(c,1)-ref(o,1)))/(ABS(ref(c,2)-ref(o,2)))>2.4 AND c-o<0 AND c>ref(o,1) AND ref(c,1)-o>2) THEN var1000:=var1000+'☆空头孕育线,阳育阴。看空 。';IF (ref(c,1)-ref(o,1)<0 AND c-o<0 AND c>ref(c,1) AND o<ref(o,1) AND o-c <6) THEN var1000:=var1000+'☆空头孕育线,阴育阴。看空。';IF REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1) THEN var1000:=var1000+'☆三只乌鸦,强烈转空趋势。三黑K价越深量越大越易下跌。';IF REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4) THEN var1000:=var1000+'☆下跌三部曲,多方弱势不堪一击,趋势易顺势走跌。'; IF REF(CLOSE,4)/REF(OPEN,4)>1.02 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(close,4)<=REF(close,3) AND REF(high,2)<REF(high,3) AND REF(LOW,2)>=REF(open,4) AND REF(high,1)<REF(close,4) AND REF(low,1)>REF(open,4) AND CLOSE/OPEN>1.01 AND open>=REF(open,1) AND CLOSE>=REF(HIGH,3) THEN var1000:=var1000+'☆连续型态之执垫,比上升三法更具多头意义。';IF ref(O,1)/ref(C,1) > 1.05 AND ref(H,1)/ref(L,1) < ref(O,1)/ref(C,1)+0.018 and C>O and O<ref(L,1) and C=ref(L,1) THEN var1000:=var1000+'☆颈上线,下降趋势。若第二天大量,维持原趋势可能星大增。'; IF (ref(c,1)-ref(o,1)>0 AND (ABS(ref(c,1)-ref(o,1)))/(ABS(ref(c,2)-ref(o,2)))>2.5 AND c-o<0 AND c>ref(o,1) AND c<(REF(CLOSE,1)+REF(OPEN,1))/2 AND o>ref(c,1)) THEN var1000:=var1000+'☆乌云罩顶,上涨遇重大阻力。空头聚力。';IF (ref(c,1)-ref(o,1)>0 AND c-o<0 AND c<ref(o,1) AND o>ref(c,1)) THEN var1000:=var1000+'☆最后吞噬,在下降趋势中为一黑一红组合;多头吞噬,在上升趋势中为一红一黑组合,空头吞噬。';IF ref(open,1)<>ref(close,1) and REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2) THEN var1000:=var1000+'☆晨星,多方势盛 变盘信号';IF MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5) THEN var1000:=var1000+'☆ 倒转槌头 -高位抛压 低位多空争执';IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5) THEN var1000:=var1000+'☆槌头,下影线有多头意义。在下降趋势之后看涨。注意反弹卖压 。';IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE > MA(CLOSE,5) THEN var1000:=var1000+'☆吊颈线,高档看跌。';IF ((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1)) OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))) THEN var1000:=var1000+'☆ 穿头破脚 -若第一根K为阴(阳) 表强劲上涨(下跌)力量。';IF ref(open,1)<>ref(close,1) and REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2) THEN var1000:=var1000+'☆黄昏之星,空方势盛。反转信号,跳空成弃婴。';IF REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100 THEN var1000:=var1000+'☆二阳夹一阴,必须从后续的走势来研判。';IF OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0 THEN var1000:=var1000+'☆ 分离 -两日开盘相同 一阴一阳 变盘前彻底整理。';IF ((O>C and open>MA(C,5) and Open>MA(C,10) and O>MA(C,20) and Close<MA(C,5) and Close<MA(C,10) and Close<MA(C,20)) OR (O<C and open<MA(C,5) and Open<MA(C,10) and O<MA(C,20) and Close>MA(C,5) and Close>MA(C,10) and Close>MA(C,20))) THEN var1000:=var1000+'☆断头铡刀(出水芙蓉) -一根大阴(阳)线切断了三根均线 如果改变了其后均线的排列为空头(多头)排列 后势看空(多) 。'; end;TIPTEXT(DISPSTATUS=2,0,var1000);{可调节KDJ:压力支撑线参数 n=1 100 9,m1=1 100 3,m2=1 100 3}RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;K:=SMA(RSV,M1,1);D:=SMA(K,M2,1);J:=3*K-2*D;RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;K12:=SMA(RSV12,3,1); D12:=SMA(K12,3,1); J12:=3*K12-2*D12; RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100; K24:=SMA(RSV24,3,1); D24:=SMA(K24,3,1); J24:=3*K24-2*D24; 压力位:IF(CROSS(j24,j),H,REF(H,BARSLAST(CROSS(j24,j)))),PRECIS2,coloryellow,LINETHICK1,pointdot;支撑位:IF(CROSS(j,j24),L,REF(L,BARSLAST(CROSS(j,j24)))),PRECIS2,COLOR77AAFF,LINETHICK1,pointdot;DRAWTEXTREL(0,0,'评级:'+Extrastring('评级')),colorCyan;DRAWTEXTABS(1,15,'所属板块:'+BKNAME),CulorAFFF00;Var1:=EMA(EMA(EMA((CLOSE*6+LOW*2+HIGH+OPEN)/10,N2),N2),N2);短线:= Var1-REF(Var1,1)+Var1;中短:= MA(短线,N1);Var2:=EMA(EMA(EMA((CLOSE*6+LOW+HIGH*2+OPEN)/10,N2),N2),N2);H短线:= Var2-REF(Var2,1)+Var2;H中短:= MA(H短线,N1);中线:= EMA(CLOSE,10);m中线:= EMA(中线,10);stickline(CROSS(短线,中短),c,o,7,0),colorred;stickline(CROSS(短线,中短),h,l,1,0),colorred;stickline(CROSS(H中短,H短线),c,o,7,0),colorgreen;stickline(CROSS(H中短,H短线),h,l,1,0),colorgreen;DRAWTEXT(CROSS(短线,中短),(LOW * 0.995),'㊣'),LINETHICK1,colorYELLOW;DRAWTEXT(CROSS(H中短,H短线),(HIGH * 1.02),'S'),LINETHICK3,colorgreen;A74:=MA(CLOSE,20);A75:=(CLOSE > MA(CLOSE,5));A76:=(MA(CLOSE,5) > MA(CLOSE,10));A77:=(CLOSE > MA(CLOSE,10));A78:=(MA(CLOSE,5) > MA(CLOSE,20));A79:=(CLOSE > MA(CLOSE,20));A710:=REF(A74,1);A711:=(A74 > A710);AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10))) + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));DSLX:=(CLOSE / INDEXC);DSLX1:=MA(DSLX,5);DSLX2:=MA(DSLX,10);V1:=MA(VOL,5);V2:=MA(VOL,10);T := BARSLAST(DISPSTATUS=1)+1;T := BARSLAST(DISPSTATUS=1)+1;HHg := HHV(H, T);ddg := LLV(L, T);{Hk := LL-HH; G12 := LL-HK*1.55; }IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN DRAWTEXTABS(12,250,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),colorFF00FF,LINETHICK1; IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN DRAWTEXTABS(12,250,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN DRAWTEXTABS(12,250,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN DRAWTEXTABS(12,250,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN DRAWTEXTABS(12,250,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN DRAWTEXTABS(12,250,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN DRAWTEXTABS(12,250,'该股放量下跌,走势明显偏弱,离场观望。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN DRAWTEXTABS(12,250,'该股缩量下跌,走势偏弱,离场观望。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN DRAWTEXTABS(12,250,'该股形态良好,强势明显,量能充足,可以继续持有。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN DRAWTEXTABS(12,250,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN DRAWTEXTABS(12,250,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN DRAWTEXTABS(12,250,'该股走势趋弱,量能不足,减持大部分筹码。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN DRAWTEXTABS(12,250,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN DRAWTEXTABS(12,250,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN DRAWTEXTABS(12,250,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN DRAWTEXTABS(12,250,'该股走势太弱,没有参与价值。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN DRAWTEXTABS(12,250,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN DRAWTEXTABS(12,250,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN DRAWTEXTABS(12,250,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN DRAWTEXTABS(12,250,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2)) THEN DRAWTEXTABS(12,250,'大盘形态走坏,重仓者可以减去大部分仓位。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2)) THEN DRAWTEXTABS(12,250,'大盘缩量调整,注意风险,短线清仓观望。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) THEN DRAWTEXTABS(12,250,'大盘走势良好,量能理想,可以继续持有强势股。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) THEN DRAWTEXTABS(12,250,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) THEN DRAWTEXTABS(12,250,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),colorFF00FF,LINETHICK1;IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) THEN DRAWTEXTABS(12,250,'大盘趋势向下,量能萎缩,不适合进场。 '),colorFF00FF,LINETHICK1;{45度异动}x1:=(C+L+H)/3;bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;ema8:=ema(c,8);DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),ema8,'∠45上升'),colorwhite;{压力支撑}压力:MA(REF(HHV(C,30),1),2),LINETHICK2,Culor9DFFFF;支撑:MA(REF(LLV(C,30),1),2),LINETHICK2,CulorABFF46; {黑马线}A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);黑马线:=EMA(A51,5);A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,(HIGH* 0.97),'▲大黑马'),COLORYELLOW;DRAWTEXTREL(10,900,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));{神獒看盘}{副图}{大智慧L2新一代公式}a1:=BARSCOUNT(CLOSE);DRAWTEXTREL(50,10,'资金净流'),linethick2,colorYellow;DRAWTEXTREL(200,10,' 代码: '+STKLABEL+' '+STKNAME+' 日期: '+YEAR+'年'+MONTH+'月 '+DAY+'日 '),linethick2,CulorFFFF80;a2:=DATE;a3:=(WEEKDAY);if (((BARSTATUS = 2) AND (a3 = 5)) ) Then DRAWTEXTREL(800,10,'星期五'),linethick2,CulorFFEF40;if (((BARSTATUS = 2) AND (a3 = 4)) ) Then DRAWTEXTREL(800,10,'星期四'),linethick2,CulorFFEF40;if (((BARSTATUS = 2) AND (a3 = 3)) ) Then DRAWTEXTREL(800,10,'星期三'),linethick2,CulorFFEF40;if (((BARSTATUS = 2) AND (a3 = 2)) ) Then DRAWTEXTREL(800,10,'星期二'),linethick2,CulorFFEF40;if (((BARSTATUS = 2) AND (a3 = 1)) ) Then DRAWTEXTREL(800,10,'星期一'),linethick2,CulorFFEF40;if (((BARSTATUS = 2) AND (a3 = 6)) ) Then DRAWTEXTREL(800,10,'星期六'),linethick2,CulorFFEF40;if (((BARSTATUS = 2) AND (a3 = 0)) ) Then DRAWTEXTREL(800,10,'星期日'),linethick2,CulorFFEF40;a4:=(BUYVOL * CLOSE) / 100;a5:=SUM(a4,0);a6:=(CLOSE * SELLVOL) / 100;a7:=SUM(a6,0);a8:=a5 + a7;a9:=a5 - a7;a10:=IF(((a4 < 20) AND (a4 >= 5)),a4,0);a11:=SUM(a10,0);a12:=IF(((a6 < 20) AND (a6 >= 5)),a6,0);a13:=SUM(a12,0);a14:=IF(((a4 < 100) AND (a4 >= 20)),a4,0);a15:=SUM(a14,0);a16:=IF(((a6 < 100) AND (a6 >= 20)),a6,0);a17:=SUM(a16,0);a18:=IF((a4 >= 100),a4,0);a19:=SUM(a18,0);a20:=IF((a6 >= 100),a6,0);a21:=SUM(a20,0);a22:=IF((a4 >= 20),a4,0);a23:=SUM(a22,0);a24:=IF((a6 >= 20),a6,0);a25:=SUM(a24,0);a26:=a11 - a13;a27:=a15 - a17;a28:=a19 - a21;a29:=a23 - a25;a30:=(100 * ((SUM((IF((a4 >= 10),VOL,0)),0)) - (SUM((IF((a6 >= 10),VOL,0)),0)))) / CAPITAL;a31:=(100 * ((SUM((IF((a4 >= 20),VOL,0)),0)) - (SUM((IF((a6 >= 20),VOL,0)),0)))) / CAPITAL;a32:=(a26);a33:=(a27);a34:=(a28);a35:=(a29);a36:=350 / (MAX(ABS(a32),ABS(a33),ABS(a34),ABS(a35)));a37:=500 - (a32 * a36);a38:=500 - (a33 * a36);a39:=500 - (a34 * a36);a40:=500 - (a35 * a36);DRAWRECTREL(0,505,320,510,3289855),colorRed;DRAWRECTREL(50,a37,80,500,(IF((a32 >= 0),3289855,3342080))),colorYellow;DRAWRECTREL(130,a38,160,500,(IF((a33 >= 0),3289855,3342080))),colorYellow;DRAWRECTREL(210,a39,240,500,(IF((a34 >= 0),3289855,3342080))),colorYellow;DRAWRECTREL(290,a40,320,500,(IF((a35 >= 0),3289855,3342080))),colorYellow;DRAWTEXTREL(18,440,'中户'),CulorDDFFFF;DRAWTEXTREL(95,440,'大户'),CulorDDFFFF;DRAWTEXTREL(175,440,'机构'),CulorDDFFFF;DRAWTEXTREL(255,440,'主力'),CulorDDFFFF;a41:=(a11);a42:=(a13);a43:=(a15);a44:=(a17);a45:=(a19);a46:=(a21);a47:=(a23);a48:=(a25);a49:=700 / (MAX(a41,a42,a43,a44,a45,a46,a47,a48));a50:=940 - (a41 * a49);a51:=940 - (a42 * a49);a52:=940 - (a43 * a49);a53:=940 - (a44 * a49);a54:=940 - (a45 * a49);a55:=940 - (a46 * a49);a56:=940 - (a47 * a49);a57:=940 - (a48 * a49);DRAWRECTREL(700,a50,720,940,250),colorYellow;DRAWRECTREL(720,a51,740,940,6617600),colorYellow;DRAWRECTREL(780,a52,800,940,250),colorYellow;DRAWRECTREL(800,a53,820,940,6617600),colorYellow;DRAWRECTREL(860,a54,880,940,250),colorYellow;DRAWRECTREL(880,a55,900,940,6617600),colorYellow;DRAWRECTREL(940,a56,960,940,250),colorYellow;DRAWRECTREL(960,a57,980,940,6617600),colorYellow;DRAWTEXTREL(2,930,'主力净流:'+NUMTOSTR(a29)+'万'+' 机构净流:'+NUMTOSTR(a28)+'万'+' 大户净流:'+NUMTOSTR(a27)+'万'+' 中户净流:'+NUMTOSTR(a26)+'万'),colorWhite;DRAWTEXTREL(2,820,'控盘系数:'+NUMTOSTR(a30)+'%'+' 主力增仓:'+NUMTOSTR(a31)+'%'),linethick2,colorYellow;DRAWTEXTREL(940,965,'主力'),CulorDDFFFF;DRAWTEXTREL(865,965,'机构'),CulorDDFFFF;DRAWTEXTREL(785,965,'大户'),CulorDDFFFF;DRAWTEXTREL(705,965,'中户'),CulorDDFFFF;DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0)); 上面的指标用于分笔分析看盘!十二星座 ㊣十二星座*神獒赢富㊣input:LONG(26,20,100),SHORT(12,5,40),M(9,2,60);a1:=1;a2:=DYNAINFO(14);a3:=(FINANCE2(37));a4:=(FINANCE2(3));a5:=DYNAINFO(17);a6:=(MA(CLOSE,0)) * a1;a7:=(MA(a6,0)) * a1;a8:=a6 - a7;STICKLINE((a6 > a7),a6,a7,0.8,501),linethick1,colorRed;STICKLINE((a7 > a6),a6,a7,0.8,1),linethick1;DRAWICON(((CROSS(a7,a6)) AND (TIME > 93200)),a6,8),colorGreen;DRAWICON(((CROSS(a6,a7)) AND (TIME > 93200)),a6,7),colorYellow;a9:=(CLOSE = ((HHV(CLOSE,0)) * a1)) AND (VOL >= 1000);a10:=VOL = (HHV(VOL,0));a11:=(STRFIND(STKNAME,'ST',1)) > 0;a12:=(STRFIND(STKNAME,'S',1)) > 0;a13:=NOT(a11) AND NOT(a12);a14:=SUM((((((a13 AND a9) AND a10) AND (CLOSE > (MA(CLOSE,0)))) AND (TIME > 93500)) AND (TIME < 145500)),0);a15:=((ALLBIDVOL / (ALLBIDVOL + ALLASKVOL)) * 100) * a1;a16:=(HIGH + LOW) / 2;a17:=(a14);a18:=(a15);a19:=(MA((MA(CLOSE,0)),0)) * a1;DRAWTEXT(((((a13 AND a9) AND a10) AND (TIME > 93500)) AND (TIME < 144500)),CLOSE,'黑马'),colorRed;DRAWTEXTABS(25,282,' '),colorCyan;DRAWTEXTABS(25,302,' '),colorCyan;DRAWTEXT((FILTER((((a5 > 1) AND (a14 >= 2)) AND (a8 > 0)),15)),a6,'㊣'),linethick3,coloryellow;a3:=(FINANCE2(37));DRAWTEXTABS(100,282,' 流通股 '+a3),colorGreen;a4:=(FINANCE2(3));DRAWTEXTABS(280,282,' 收益 '+a4),colorWhite;DRAWTEXTABS(290,282,' 量对比 '+a5),colorGreen;DRAWTEXTABS(25,262,'十二星座无视大盘战法:从涨幅排行中手动翻页筛选个股,发现㊣后分批买入'),colorCyan;DRAWTEXTABS(25,242,'最高宗旨:卖出股票参照◎点,买入股票参照★点,上下箭头代表趋势'),colorCyan;DRAWTEXTABS(25,222,'㊣十二星座*神獒赢富㊣'),linethick1,COLOR00EEff;a20:=(EMA(CLOSE,SHORT)) - (EMA(CLOSE,LONG));a21:=EMA(a20,M);a22:=2 * (a20 - a21);DRAWTEXT((FILTER(((a20 * a1) > 0.2),30)),CLOSE,'◎'),linethick2,colorGreen;DRAWTEXT((((FILTER(((a20 * a1) < -0.03),30)) AND (TIME > 113500)) AND (a2 > -0.02)),CLOSE,'★'),linethick3,colorRed;

最新发布

相关文章

神奇指标广告