指标汇总
神奇指标广告
大智慧三线开花主图源码优化
来源:大智慧公式 7204次浏览 发布时间2022-09-05

以下是三线开花主图源码优化

这是大智慧主图原码。
“三线开花优化主图”
没有什么,这个公式主要是看趋势,做中长线。为了短线操作方便只是添加了几个比较准确的中短线信号。

A1:=SUM(AMOUNT,3)/SUM(VOL,3)/100;
 A2:=SUM(AMOUNT,8)/SUM(VOL,8)/100;
 A3:=SUM(AMOUNT,21)/SUM(VOL,21)/100;DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26),colorwhite;
 DEA:=EMA(DIFF,9),coloryellow;
 MACD:= 2*(DIFF-DEA), COLORSTICK ;
 V1:=C-(A1+MA(C,3))/2;
 V2:=C-(a2+MA(C,8))/2;
 V3:=C-(a3+MA(C,21))/2;Va1:=(C+v3-v1+MACD);Va4:=(C+v2-v1+MACD);
 x1:=(C+L+H)/3;
 x2:=EMA(x1,6);
 x3:=EMA(x2,5);
 gr1:=BARSLAST(BETWEEN("bias.bias2"(6,13,24),0,5));
 gr2:=EMA(x1,13)>EMA(x1,21) AND EMA(x1,21)>EMA(x1,34)
 AND EMA(x1,13)>REF(EMA(x1,13),1);
 gr3:=COUNT("bias.bias2"(6,13,24)>10 AND H=HHV(H,gr1),gr1);
 gr4:=H=HHV(H,gr1);
 gr5:="macd.macd"(12,26,9)<REF("macd.macd"(12,26,9),1);
 gr6:=gr2 AND gr3 AND gr4;
 gr7:=gr2 AND gr3 AND gr4 AND gr5;
 gr8:=gr6 AND gr7;
 LC := REF(CLOSE,1);
 RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
 BIAS5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
换手:=100*V/CAPITAL;
 bb13:=ATAN(EMA(x1,13)-REF(EMA(x1,13),1))*3.1416*10;
 ema8:=EMA(C,8);
 DRAWTEXT(FILTER(bb13>1 AND EMA(x1,13)>REF(EMA(x1,8),1),10),
 ema8,'∠45上升'),colorwhite;
 ma20:MA(C,20),coloryellow,linethick1;
 ma120:MA(C,120),colorgreen,linethick1;
 ma250:MA(C,250),colorffcc66,linethick1;
乖离线:=((C-REF(ma20,1))/20+ma20)*1.20;
 tt1:=CROSS(ma20,ma120)  AND CROSS(ma20,ma250) AND V>REF(V,1);
 tt2:=ma20>REF(ma20,2) AND V>REF(V,1) AND CROSS(C,ma20);
 STICKLINE(TT1,L,L-0.09,4,0),coloryellow;
 DRAWTEXT(TT1,L-0.13,'金叉'),coloryellow;
 STICKLINE(CROSS(C,ma120) AND CROSS(C,ma250) AND CROSS(C,ma20),L,L-0.09,4,0),coloryellow;
 DRAWTEXT(CROSS(C,ma120) AND CROSS(C,ma250) AND CROSS(C,ma20),L-0.13,'并线开花'),coloryellow;
 STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),color00ff00;
 DRAWTEXT(CROSS(C,乖离线) ,H+0.13,'卖点'),color00ff00;
 STICKLINE(ma250>=REF(ma250,1) AND ma20>=REF(ma20,1) AND CROSS(C,ma250),L,L-0.09,4,0),colorffcc66;
 DRAWTEXT(ma250>=REF(ma250,1) AND  ma20>=REF(ma20,1) AND CROSS(C,ma250),L-0.13,'牛象'),colorffcc66;
 STICKLINE(ma120>=REF(ma120,1) AND CROSS(C,ma20) AND CROSS(C,ma120) AND V>REF(V,1),L,L-0.09,4,0),colorff00ff;
 DRAWTEXT(ma120>=REF(ma120,1) AND CROSS(C,ma20) AND CROSS(C,ma120) AND V>REF(V,1),L-0.13,'买点2'),colorff00ff ;
 Var1:=(CLOSE*2+HIGH+LOW)/4;
 SK:= EMA(Var1,13)-EMA(Var1,73);
 SD:= EMA(SK,2);
 DRAWTEXT((CROSS(sk,sd) AND sk<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(sk,sd) AND sk<=-0.14 )
 OR (CROSS(sk,sd) AND sk<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'启动点'),coloryellow;
 STICKLINE((CROSS(sk,sd) AND sk<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(sk,sd) AND sk<=-0.14 )
 OR (CROSS(sk,sd) AND sk<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0.5,0),colorred;
 STICKLINE((CROSS(sk,sd) AND sk<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(sk,sd) AND sk<=-0.14 )
 OR (CROSS(sk,sd) AND sk<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,0.5,1),linethick2,colorred;
 STICKLINE(cross(ma(c,1),ma(c,9)),CLOSE,OPEN,5,0),colorred;
 STICKLINE(cross(ma(c,1),ma(c,9)),HIGH,LOW,0.35,0),COLORred;
 STICKLINE(cross(ma(c,1),ma(c,23.5)),CLOSE,OPEN,5,0),COLORyellow;
 STICKLINE(cross(ma(c,1),ma(c,23.5)),HIGH,LOW,0.35,0),COLORyellow;
 

最新发布

相关文章

神奇指标广告