指标汇总
神奇指标广告
大智慧茂荣副图指标
来源:大智慧公式 8442次浏览 发布时间2022-09-05

以下是大智慧茂荣副图指标

大智慧茂荣副图指标

源码

C01:=(h+l+c)/3;
C11:=HHV(C01,16*15);C21:=LLV(C01,16*15);C31:=C11-C21;
C41:=ema((C01-C21)/C31,11)*230+190;
茂荣趋势线:C41,COLORBLUE,linethick2;
C02:=(h+l+c)/3;
C12:=HHV(C02,16*15);C22:=LLV(C02,16*15);C32:=C12-C22;
C42:=ema((C02-C22)/C32,12)*200+200;
茂荣分界线:C42,COLORMAGENTA,LINETHICK2;
V3:=100-(100-3*SMA((C-LLV(L,5))/(HHV(H,5)-LLV(L,5))
*168,48,2)+3*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*168,48,2),15,1))+300;
茂荣操作线:=V3;
C04:=(INDEXH+INDEXL+INDEXC)/3;
C14:=HHV(C04,16*15);C24:=LLV(C04,16*15);C34:=C14-C24;
C44:=ema((C04-C24)/C34,11)*230+190;
大盘趋势线:C44,COLOR00FF00,linethick2;
C03:=(h+l+c)/3;
a13:=HHV(C03,5);a23:=LLV(C03,5);a33:=a13-a23;
a43:=ema((C03-a23)/a33,2)*200+200;
b13:=HHV(C03,4*10);b23:=LLV(C03,4*10);b33:=b13-b23;
b43:=ema((C03-b23)/b33,6)*200+200;
茂荣中期价位:b43,color6699ff;
短价:=a43;
Var1m:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*200;
Var2m:=SMA(Var1m,2,1);
Var3m:=SMA(Var2m,3,1);
Var4m:=SMA(Var3m,3,1);
波: Var3m+200,linethick2,COLORRED;
段: Var4m+200,linethick2,COLORYELLOW;
Var5m:=CROSS(Var2m,Var3m) AND Var3m<45;
STICKLINE(Var5m,200,Var3m+5+200,1,1),linethick2,COLORRED;
Var6m:=CROSS(Var3m,Var4m) AND Var3m<45;
Var7m:=Var6m AND VOL>REF(VOL,3)*2 AND VOL>REF(MA(VOL,12),1)*2;
STICKLINE(Var6m,200,Var3m+5+200,1,1),linethick2,COLORWHITE;
DRAWTEXT(Var6m AND COUNT(Var6m,10)=1,Var3m+15+200,'抄底'),linethick1,COLORWHITE;
STICKLINE(Var7m,200,Var3m+5+225,1,1),linethick4,COLORRED;
DRAWTEXT(Var7m AND COUNT(Var7m,10)=1,Var3m+5+230,'放量'),linethick1,COLORRED;
Var8m:=CROSS(Var2m,Var3m) AND Var3m>155 AND Var3m>Var4m AND 段>355;
STICKLINE(Var8m AND COUNT(Var8m,5)=1,Var3m-5+200,100+300,1,1),linethick2,COLORGREEN;
Var9m:=CROSS(Var4m,Var3m) AND Var3m>155;
STICKLINE(Var9m,Var3m-5+200,100+300,1,1),linethick2,COLORYELLOW;
DRAWTEXT(Var9m AND COUNT(Var9m,10)=1,Var3m-15+250,'逃顶'),linethick1,COLORYELLOW;
VarE:=MA(WINNER(CLOSE),36)*100;
STICKLINE(CROSS(VarE,2.5)*(60),60,0,24,0),coloryellow;
STICKLINE(CROSS(VarE,2.5)*(60),60,0,8,0),colorred;
中短期底部:=(CROSS(VarE,2.5)*(60));
drawtext(中短期底部 ,80,'★中短期底部庄家吸筹'),Culorred;
drawtext(中短期底部 ,65,'★越跌越买耐心持股'),Culorred;
VarEy:=MA(WINNER(CLOSE),144)*80;
买入飞弹:=CROSS(VarEy,2.5)*(60);
趋势线1:=(MA(CLOSE,36)-MA(CLOSE,480))/MA(CLOSE,480)*100;
DRAWGBK(((ref(VarEy,0.1)<ref(VarEy,14)) and 茂荣趋势线<250 and 趋势线1<-5 or 茂荣趋势线<220),STRIP(RGB(0,0,0),RGB(0,0,95),100));
获利筹码:EMA(WINNER(C)*70,5),Culorred;
动态底部:EMA(IF(L<= LLV(l,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(l,1),0),30,1),0),3)*10;
STICKLINE(动态底部>0,0,动态底部,7,0),coloryellow;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
STICKLINE(((CLOSE > 0) AND day=2),20,121,40,1),colorFFFFFF;
STICKLINE(((SAT <= 5) AND day=2),21,(20 + SAT),35,0),colorFFFFFF;
STICKLINE((((SAT > 5) AND (SAT <= 20)) AND day=2),21,(20 + SAT),35,0),colorCCFF88;
STICKLINE((((SAT > 20) AND (SAT <= 40)) AND day=2),21,(20 + SAT),35,0),colorFF00FF;
STICKLINE(((SAT > 40) AND day=2),21,(20 + SAT),35,0),color0000FF;
亏损筹码:EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5),Culorf0ff00;
STICKLINE(亏损筹码>0,0,亏损筹码,5,0),COLOR66FF00;
STICKLINE(亏损筹码>0,0,亏损筹码*0.9,5,0),COLOR66EE00;
STICKLINE(亏损筹码>0,0,亏损筹码*0.85,5,0),COLOR66DD00;
STICKLINE(亏损筹码>0,0,亏损筹码*0.8,5,0),COLOR66CC00;
STICKLINE(亏损筹码>0,0,亏损筹码*0.75,5,0),COLOR66BB00;
主力控筹:If(获利筹码>亏损筹码,获利筹码*2,获利筹码),colorred;
STICKLINE(主力控筹>0,0,主力控筹,5,0),COLORFFFFFF;
STICKLINE(获利筹码>0,0,获利筹码,5,0),COLORFFFFFF;
STICKLINE(获利筹码>0,0,获利筹码*0.9,5,0),COLOREEEEFF;
STICKLINE(获利筹码>0,0,获利筹码*0.85,5,0),COLORDDDDFF;
STICKLINE(获利筹码>0,0,获利筹码*0.8,5,0),COLORCCCCFF;
STICKLINE(获利筹码>0,0,获利筹码*0.75,5,0),COLORBBBBFF;
STICKLINE(获利筹码>0,0,获利筹码*0.7,5,0),COLORAAAAFF;
STICKLINE(获利筹码>0,0,获利筹码*0.65,5,0),COLOR9999FF;
STICKLINE(获利筹码>0,0,获利筹码*0.6,5,0),COLOR8888FF;
STICKLINE(获利筹码>0,0,获利筹码*0.55,5,0),COLOR7777FF;
STICKLINE(获利筹码>0,0,获利筹码*0.5,5,0),COLOR6666FF;
STICKLINE(获利筹码>0,0,获利筹码*0.45,5,0),COLOR5555FF;
STICKLINE(获利筹码>0,0,获利筹码*0.4,5,0),COLOR4444FF;
STICKLINE(获利筹码>0,0,获利筹码*0.35,5,0),COLOR3333FF;
STICKLINE(获利筹码>0,0,获利筹码*0.3,5,0),COLOR2222FF;
STICKLINE(获利筹码>0,0,获利筹码*0.25,5,0),COLOR1111FF;
VarzE:=REF(LOW,1)*0.9;
VarzF:=LOW*0.9;
Varz10:=(VarzF*VOL+VarzE*(CAPITAL-VOL))/CAPITAL;
Varz11:=EMA(Varz10,30);
Varz12:=CLOSE-REF(CLOSE,1);
Varz13:=MAX(Varz12,0);
Varz14:=ABS(Varz12);
Varz15:=SMA(Varz13,7,1)/SMA(Varz14,7,1)*100;
Varz16:=SMA(Varz13,13,1)/SMA(Varz14,13,1)*100;
Varz17:=BARSCOUNT(CLOSE);
Varz18:=SMA(MAX(Varz12,0),6,1)/SMA(ABS(Varz12),6,1)*100;
Varz19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Varz1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Varz1B:=SMA((SMA(Varz1A,4,1)-50)*2,3,1);
Varz1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Varz1D:=SMA(Varz1C,4,1);
Varz1E:=SMA(Varz1D,3,1);
Varz1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Varz20:=Varz18<=25 AND Varz19<-95 AND Varz1F>20 AND Varz1B<-30 AND Varz1E<30 AND Varz11-CLOSE>=-0.25 AND Varz15<22 AND
Varz16<28 AND Varz17>50;STICKLINE(Varz20,0,100,10,0),color436010,linethick2;
DRAWTEXT(Varz20 AND COUNT(Varz20,30)=1,85,'百万导弹!'),COLORFFFFFF;
Var1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
Var2:=2*ABS(Var1);
Var3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var5:=(HIGH+LOW+CLOSE)/3;
Var6:=(Var5-MA(Var5,14))/(0.015*AVEDEV(Var5,14));
Var7:=(Var5-MA(Var5,70))/(0.015*AVEDEV(Var5,70));
Var8:=IF(Var6>=150 AND Var6<200 AND Var7>=150 AND Var7<200,10,0);
Var9:=IF(Var6<=-150 AND Var6>-200 AND Var7<=-150 AND Var7>-200,-10,Var8);
VarA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VarB:=100-ABS(VarA);
预警系统: IF(Var7>=200 AND Var6>=150,15,IF(Var7<=-200 AND Var6<=-150,-15,Var9))+140,COLOR00FF00;
Var23:=IF(Var1>0,Var1,0)>50 AND 预警系统>150 AND IF(VarB<90,VarB,100)=100;
Var25:=IF(Var1<0,Var2,0)>38 AND 预警系统<130;
DRAWTEXT(Var23 AND COUNT(Var23,30)=1,160,'上涨过急 '),COLORFFFFFF;
DRAWTEXT(Var25 AND COUNT(Var25,30)=1,135,'不必杀跌!'),COLORFFFFFF;
Var100:=(短价<205 and 茂荣中期价位<210 and 茂荣操作线>茂荣分界线 and 茂荣分界线<茂荣趋势线 and 茂荣分界线<270 and 大盘趋势线<250);
筹码进场:IF(Var100>REF(Var100,1),10,0),COLORBLUE;
Var101:=(短价<205 and 茂荣中期价位<210 and 茂荣操作线>茂荣分界线 and 茂荣分界线<茂荣趋势线 and 茂荣分界线<230 and 茂荣趋势线<250 and 大盘趋势线<240);
筹码加仓:IF(Var101>REF(Var101,1),10,0),colorff00ff;
Var102:=(短价<205 and 茂荣中期价位<210 and 茂荣趋势线<215 and 大盘趋势线<230);
筹码抄底:IF(Var102>REF(Var102,1),10,0),COLORRED;
Var103:=(短价>395 and 茂荣中期价位>390 and 茂荣操作线<茂荣分界线 and 茂荣分界线>茂荣趋势线 and 茂荣操作线>300 and 茂荣分界线>370);
筹码出场:IF(Var103>REF(Var103,1),10,0),coloryellow;
Var104:=(短价>395 and 茂荣中期价位>390 and 茂荣趋势线>380);
筹码清仓:IF(Var104>REF(Var104,1),10,0),COLORCYAN;
Var105:=(短价>395 and 茂荣中期价位>390 and 茂荣趋势线>380 and 茂荣分界线>390);
筹码逃顶:IF(Var105>REF(Var105,1),10,0),COLOR00FF00;

DRAWTEXTREL(12,835,'  茂荣解盘:'),CulorFFFF00,LINETHICK2;
IF BARSTATUS=2 and  茂荣分界线<230 and  茂荣操作线>茂荣分界线 THEN
DRAWTEXTREL(150,840,'该股进入底部区域,注意成交量变化和各个指标信号买入。  '),coloryellow,LINETHICK1;         
IF BARSTATUS=2 and  茂荣分界线>370 and  茂荣操作线<茂荣分界线 THEN
DRAWTEXTREL(150,840,'该股进入顶部区域,注意成交量变化和各个指标信号卖出。  '),COLORRED,LINETHICK1; 
IF BARSTATUS=2 and  茂荣分界线<370 and  茂荣分界线>230 and  茂荣分界线<茂荣趋势线 THEN
DRAWTEXTREL(150,840,'该股进入下降区域,注意股价是否冲顶逃离。  '),COLOR00FF00,LINETHICK1;
IF BARSTATUS=2 and  茂荣分界线<370 and  茂荣分界线>230 and  茂荣分界线>茂荣趋势线 THEN
DRAWTEXTREL(150,840,'该股进入上升区域,注意股价是否回调买入。  '),colorff00ff,LINETHICK1;
Var200:=(CROSS(茂荣分界线,茂荣趋势线) AND 茂荣趋势线<250);
茂荣持股:IF(Var200 >REF(Var200 ,1),180,170),COLORRED;
STICKLINE(Var200 ,170,200,10,0),COLORRED;
DRAWTEXT(茂荣持股=180,190,'茂荣持股待涨'),COLORRED;
Var201:=(CROSS(茂荣趋势线,茂荣分界线) AND 茂荣趋势线>350);
茂荣持币:IF(Var201 >REF(Var201 ,1),410,438),COLOR00FF00;
STICKLINE(Var201 ,438,400,10,0),COLOR00FF00;
DRAWTEXT(茂荣持币=410,425,'茂荣持币观望'),COLOR00FF00;  
DRAWTEXTREL(2,905,'  《茂荣看价操作》'),CulorFFFF00;
DRAWTEXTREL(280,905,'  茂荣预测今日价位1'),CulorFFFFFF;
DRAWTEXTREL(660,905,'  价位2'),CulorFFFFFF;
DRAWTEXTREL(10,955,'所属板块:'+BKNAME),COLORBLUE;
分界线:300,pointdot,linethick2,COLORBLUE;
REFLINE:-100 ,0, 220,300,380, 438;-40,LINETHICK5,COLORBLUE;-3,LINETHICK3,colorff00ff;
200,LINETHICK2,color436010;400,LINETHICK2,color436010;
MA1:=MA(CLOSE,20);
MA2:=MA(CLOSE,120);
STICKLINE(MA1>MA2,435,438,10,0),COLORRED;
STICKLINE(MA1<MA2,435,438,10,0),COLOR00FF00;
STICKLINE(MA1>MA2,-100,-70,10,0),COLORRED;
STICKLINE(MA1<MA2,-100,-70,10,0),COLOR00FF00;
STICKLINE(茂荣趋势线>380,165,170,10,0),COLORRED;
STICKLINE(茂荣趋势线<220,165,170,10,0),COLOR00FF00;
STICKLINE(茂荣趋势线>220 AND 茂荣趋势线<380,165,170,10,0),coloryellow;
STICKLINE(茂荣趋势线>0,-100,-96,10,0),colorff00ff;

最新发布

相关文章

神奇指标广告