指标汇总
神奇指标广告
大智慧上下电梯副图指标
来源:大智慧公式 1560次浏览 发布时间2022-09-05

以下是大智慧上下电梯副图指标

大智慧上下电梯副图指标

源码

{上下电梯----创幻论坛一品茶缘编写副图指标,大智慧L-2版本}
{上下趋势指标使用说明:(该指标基础修改于软件自带心理线PSY)
短线上下坐电梯,最爱进场上楼区;
备钱低买关注底,风险见跑下楼去.}

快:COUNT(CLOSE>REF(CLOSE,2),4)/4*100,COLOR00FF00;
慢:COUNT(CLOSE>REF(CLOSE,2),6)/6*100,COLORFFFFFF;
备钱:IF(快=0 AND 慢>20,20,0),COLORFF00FF,LAYER0;
低买:IF(快=0 AND BETWEEN(慢,1,20),50,0),COLORRED,LAYER0;
关注:IF(快=0 AND 慢=0,10,0),COLORFF8800,LAYER0;
JC:=(CROSS(快,1) AND 慢<=40) OR (CROSS(慢,20) AND 快<=50);
进场:IF(FILTER(JC,3),20,0),COLOR00FFFF,LINETHICK0;
VERTLINE(进场,2),COLOR00FFFF;
QSXS:=快>=50 AND 快>=REF(快,1) AND 慢>=REF(慢,1);
上楼:IF(QSXS,1,0),COLOR0000FF,LINETHICK0;
风险:IF(快=100 AND 慢>=80,90,100),COLORFF00FF;
FXSJ:=BARSLAST(风险=90);
快跑:IF(FXSJ=1,1,0),COLORFFFF00,POINTDOT,LINETHICK0;
QSXX:=快<=REF(快,1) AND 慢<=REF(慢,1);
下楼:IF(FXSJ>=2 AND COUNT(QSXX,FXSJ)=FXSJ,1,0),COLOR00FFFF,LINETHICK0;
{以下设置副图显示方式}
FILLRGN(快,慢,上楼,RGB(255,0,0));
FILLRGN(快,慢,下楼,RGB(255,255,0));
DRAWTEXT(CROSS(备钱,1),30,'备钱'),COLORFF00FF;
DRAWTEXT(CROSS(低买,1),60,'低买'),COLORFFFFFF;
DRAWTEXT(CROSS(关注,1),20,'关注'),COLORFFFFFF;
DRAWTEXT(CROSS(COUNT(关注,6)=6,0.8),20,'地下室'),COLOR00FF00;
DRAWTEXT(FXSJ=1,100,'跑'),COLORFFFFFF,ALIGN1;
DRAWICON(风险=90,110,12),ALIGN1,LAYER0;
{以下设置副图显示方式----通用版本替换彩色带代码}
DRAWICON(风险=90,110,1);
STICKLINE(上楼,快,慢,4,0),COLOR0000FF;
STICKLINE(下楼,快,慢,4,0),COLOR00FFFF;

最新发布

相关文章

神奇指标广告