指标汇总
神奇指标广告
大智慧金钱吊吊主图指标
来源:大智慧公式 7477次浏览 发布时间2022-09-05

以下是大智慧金钱吊吊主图指标

大智慧金钱吊吊主图指标

源码

DRAWGBKLAST(DATE>900101,STRIP(RGB(5,125,5),RGB(5,25,5),0));
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1: (EMA(VAR1,3)+EMA(VAR1,6)+EMA(VAR1,12)+EMA(VAR1,24))/4,COLORff9900;
A2: EMA(A1,2),COLORff9900;
A3: EMA(A2,2),COLORff9900;
A4: EMA(A3,2),COLORff9900;
A5: EMA(A4,2),COLORff9900;
A6: EMA(A5,2),COLORff9900;
A7: EMA(A6,2),COLORff9900;
PARTLINE(A1,A1>REF(A1,1)),COLOR0ffff0;
PARTLINE(A2,A2>REF(A2,1)),COLOR0ffff0;
PARTLINE(A3,A3>REF(A3,1)),COLOR0ffff0;
PARTLINE(A4,A1>REF(A4,1)),COLOR0ffff0;
PARTLINE(A5,A1>REF(A5,1)),COLOR0ffff0;
PARTLINE(A6,A6>REF(A6,1)),COLOR0ffff0;
PARTLINE(A7,A7>REF(A7,1)),COLOR0ffff0;
安全线: EMA(CLOSE,55), CIRCLEDOT;
{买卖指标}
AA05:MA(C,5),linethick0;
MM5:=(c-AA05)/AA05*100;
BB05:=atan((aa05/ref(aa05,1)-1)*100)*180/3.1416;
NN5:=sma(ema((AA05-ref(AA05,1))/ref(AA05,1),3)*100,3,1);
NNNN5:ema((NN5-ref(NN5,1)),3),linethick0;
AA10:MA(C,10),linethick0;
AA20:=MA(c,20);
BB10:=atan((aa10/ref(aa10,1)-1)*100)*180/3.1416;
AA30:MA(C,30),linethick0;
MM30:(c-AA30)/AA30*100,linethick0;
Var1:=(AA20-AA30)>ref((AA20-AA30),1) and AA20>ref(aa20,1) and AA30>ref(AA30,1);
Var2:=(AA30-AA20)<ref((AA30-AA20),1) and AA20<ref(aa20,1) and AA30<ref(AA30,1);
BB30:=atan((aa30/ref(aa30,1)-1)*100)*180/3.1416;
强势:=filter(BB30>30 and BB10>45 and cross(BB05,60),10);
加仓:=filter(count(cross(BB05,30),5)>=1 and AA05>ref(aa05,1)  and MM30>ref(MM30,1) and AA10>ref(AA10,1)
and NNNN5>ref(NN5,1) and NN5>ref(NN5,1)  ,10) ;
清仓:=filter(count(cross(30,BB05),5)>=1 and (c>AA30 or O>AA30) and AA05<ref(aa05,1)  and MM30<ref(MM30,1) and AA10<ref(AA10,1),10);
JC:=cross(0,MM5) and MM30<ref(MM30,1) and AA10>ref(AA10,1) ;
减仓:=filter(JC,10);
MR:=count(cross(MM30,0),3)>=1 and MM30>ref(MM30,1) and AA05>ref(AA05,1) and (c/ref(c,1)-1)*100>5 and ref(c,1)<AA30;
买入:=filter(MR,10);
年1:=YEAR;
月1:=MONTH;
日1:=DAY;
星期:=WEEKDAY;
时:=HOUR;
分:=MINUTE;
秒:=TIME;
DRAWTEXTREL(5,10,NUMTOSTR(年1)+'年'+NUMTOSTR(月1)+'月'+NUMTOSTR(日1)+'日星期'+NUMTOSTR(星期)+
  北京时间 '+STRLEFT(NUMTOSTRN(IF(CURRENTTIME<10000,0,CURRENTTIME),0),IF(CURRENTTIME>=10000 AND
CURRENTTIME<100000,1,2))+'点  '+STRMID(NUMTOSTRN(CURRENTTIME,0),IF(CURRENTTIME<10000,1,IF(CURRENTTIME>=10000 AND
CURRENTTIME<100000,2,3)),2)+'分  '+STRRIGHT(NUMTOSTRN(CURRENTTIME,0),2)+'秒'),LINETHICK2,COLORyellow;
DRAWTEXT((买入),low*0.945,'⊙'),linethick2,ALIGN1,COLORYELLOW;
DRAWTEXT((买入),low*0.965,'⊙'),linethick2,ALIGN1,COLORYELLOW;
DRAWTEXT((买入),low*0.985,'⊙'),linethick2,ALIGN1,COLORYELLOW;
drawtext(减仓,high*1.06,'◇'),ALIGN2,linethick3,colorcyan;
drawtext(减仓,high*1.05,'◇'),ALIGN1,linethick3,colorcyan;
drawtext(减仓,high*1.059,'◇'),ALIGN0,linethick3,colorcyan;
DRAWTEXT((加仓),low*0.985,'⊙'),linethick2,ALIGN1,colorWhite;
DRAWTEXT((加仓),low*0.965,'⊙'),linethick2,ALIGN1,colorWhite;
DRAWTEXT((加仓),low*0.945,'⊙'),linethick2,ALIGN1,colorWhite;
DRAWTEXT((强势),low*0.985,'⊙'),linethick2,ALIGN1,COLORred;
DRAWTEXT((强势),low*0.965,'⊙'),linethick2,ALIGN1,COLORred;

{看色买卖}
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORFF7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORFF9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORFFBB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORFFCC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORFFDD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORFFEE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORFFFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF (C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2) =HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3) =HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
红持:var9Q,color0000ff,LINETHICK0;
STICKLINE(VAR9Q,C,(O+C)/2,7,0),COLOR000055;
STICKLINE(VAR9Q,C,(O+C)/2,6,0),COLOR000066;
STICKLINE(VAR9Q,C,(O+C)/2,5,0),COLOR000077;
STICKLINE(VAR9Q,C,(O+C)/2,4,0),COLOR000099;
STICKLINE(VAR9Q,C,(O+C)/2,3,0),COLOR0000BB;
STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR0000DD;
STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000FF;
VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
粉变:varaQ,colorff99ff,LINETHICK0;
STICKLINE(VARAQ,C,(O+C)/2,7,0),COLORFF11FF;
STICKLINE(VARAQ,C,(O+C)/2,6,0),COLORFF33FF;
STICKLINE(VARAQ,C,(O+C)/2,5,0),COLORFF55FF;
STICKLINE(VARAQ,C,(O+C)/2,4,0),COLORFF77FF;
STICKLINE(VARAQ,C,(O+C)/2,3,0),COLORFF99FF;
STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORFFBBFF;
STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFFDDFF;
VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3))  OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND  REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND  C<REF(C,1) AND C<REF(C,2);
灰跌:varbQ,color888888,LINETHICK0;
STICKLINE(VARBQ,C,(O+C)/2,7,0),COLOR333333;
STICKLINE(VARBQ,C,(O+C)/2,6,0),COLOR555555;
STICKLINE(VARBQ,C,(O+C)/2,5,0),COLOR777777;
STICKLINE(VARBQ,C,(O+C)/2,4,0),COLOR999999;
STICKLINE(VARBQ,C,(O+C)/2,3,0),COLORBBBBBB;
STICKLINE(VARBQ,C,(O+C)/2,2,0),COLORDDDDDD;
STICKLINE(VARBQ,C,(O+C)/2,1,0),COLORFFFFFF;
VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4)  AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
绿买:varcQ,color00ff00,LINETHICK0;
STICKLINE(VARCQ,O,(O+C)/2,7,0),COLOR003300;
STICKLINE(VARCQ,O,(O+C)/2,6,0),COLOR005500;
STICKLINE(VARCQ,O,(O+C)/2,5,0),COLOR007700;
STICKLINE(VARCQ,O,(O+C)/2,4,0),COLOR009900;
STICKLINE(VARCQ,O,(O+C)/2,3,0),COLOR00BB00;
STICKLINE(VARCQ,O,(O+C)/2,2,0),COLOR00DD00;
STICKLINE(VARCQ,O,(O+C)/2,1,0),COLOR00FF00;
VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4)  AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF (C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
蓝抛:vardQ,colorff9900,LINETHICK0;
STICKLINE(VARDQ,O,(O+C)/2,7,0),COLORFF1100;
STICKLINE(VARDQ,O,(O+C)/2,6,0),COLORFF3300;
STICKLINE(VARDQ,O,(O+C)/2,5,0),COLORFF5500;
STICKLINE(VARDQ,O,(O+C)/2,4,0),COLORFF7700;
STICKLINE(VARDQ,O,(O+C)/2,3,0),COLORFF9900;
STICKLINE(VARDQ,O,(O+C)/2,2,0),COLORFFBB00;
STICKLINE(VARDQ,O,(O+C)/2,1,0),COLORFFDD00;

最新发布

相关文章

神奇指标广告