指标资讯
神奇指标广告
大智慧顾比倒数副图指标-大智慧指标公式
来源:神奇指标 发布时间:2024-02-06

  

以下是大智慧顾比倒数副图指标源码和截图


大智慧顾比倒数副图指标源码:

   P1:=5;

   PH:=TROUGHBARS(2,P1,1);

   LL:=HHV(H,PH);

   TJ1:=LL=HIGHANDLL<REF(LL,1);

   TS:=SUMBARS(TJ1,2);

   TJ:=PEAKBARS(2,P1,1)=1ANDTS>=PH;

   警告灯:DRAWICON(TJ,HIGH*1.01+0.02,2);

   PL:=BArslAst(TJ);

   支撑:STICKLINE(BARSLAST(TJ1),REF(LOW,BARSLAST(TJ1)),REF(LOW,BARSLAST(TJ1)),4,0),POINTDOT,COLOREA91B5;

   压力:STICKLINE(BARSLAST(TJ),REF(HIGH,PL),REF(HIGH,PL),4,0),POINTDOT,COLORYELLOW;

   TJ_2:=LOW>REF(REF(LOW,TS),PL);

   DRAWTEXT(COUNT(TJ_2,PL+1)=1,HIGH*1.005,'↓'),COLORFF00FF;{//向下的箭头表示出局点}

   DRAWICON(BARSLAST(TJ1)=1,REF(LOW*0.995,BARSLAST(TJ1)),1);

   {顾比倒数线}

   l2:=IF(C<REF(C,1),

   IF(REF(L,1)>REF(L,2),REF(L,2),

   IF(REF(L,1)>REF(L,3),REF(L,3),

   IF(REF(L,1)>REF(L,4),REF(L,4),

   IF(REF(L,1)>REF(L,5),REF(L,5),

   IF(REF(L,1)>REF(L,6),REF(L,6),

   IF(REF(L,1)>REF(L,7),REF(L,7),

   IF(REF(L,1)>REF(L,8),REF(L,8),C))))))),C);

   l3:=IF(C<REF(C,1),

   IF(l2>REF(L,3),REF(L,3),

   IF(l2>REF(L,4),REF(L,4),

   IF(l2>REF(L,5),REF(L,5),

   IF(l2>REF(L,6),REF(L,6),

   IF(l2>REF(L,7),REF(L,7),

   IF(l2>REF(L,8),REF(L,8),

   IF(l2>REF(L,9),REF(L,9),C))))))),C);

   s:=BARSLAST(l3<L);

   sl3:=REF(l3,s);

   前低:sl3,color00ff00,CROSSDOT;

   h2:=IF(C>REF(C,1),

   IF(REF(H,1)<REF(H,2),REF(H,2),

   IF(REF(H,1)<REF(H,3),REF(H,3),

   IF(REF(H,1)<REF(H,4),REF(H,4),

   IF(REF(H,1)<REF(H,5),REF(H,5),

   IF(REF(H,1)<REF(H,6),REF(H,6),

   IF(REF(H,1)<REF(H,7),REF(H,7),

   IF(REF(H,1)<REF(H,8),REF(H,8),C))))))),C);

   h3:=IF(C>REF(C,1),

   IF(h2<REF(H,3),REF(H,3),

   IF(h2<REF(H,4),REF(H,4),

   IF(h2<REF(H,5),REF(H,5),

   IF(h2<REF(H,6),REF(H,6),

   IF(h2<REF(H,7),REF(H,7),

   IF(h2<REF(H,8),REF(H,8),

   IF(h2<REF(H,9),REF(H,9),C))))))),C);

   s1:=BARSLAST(h3>H);

   sh3:=REF(h3,s1);

   前高:sh3,colorred,CIRCLEDOT;

   {DRAWLINE(C>=sl3,sl3,C<sl3,sl3,0),color00ff00,linethick1;}

   DRAWTEXT(C<sl3ANDREF(C,1)>=sl3,L,'走'),colorgreen;

   {DRAWLINE(sh3>C,sh3,C>sh3,sh3,0),coloryellow,linethick2;}

   DRAWTEXT(C>sh3ANDsh3>REF(C,1),H*1.02,'进'),colorred;

   N:=60;P:=20;

   MA1:EMA(CLOSE,3),COLORYELLOW;

   MA2:EMA(CLOSE,5),COLORYELLOW;

   MA3:EMA(CLOSE,8),COLORYELLOW;

   MA4:EMA(CLOSE,10),COLORYELLOW;

   MA5:EMA(CLOSE,12),COLORYELLOW;

   MA6:EMA(CLOSE,15),COLORYELLOW;

   MA7:EMA(CLOSE,30),COLORRED;

   MA8:EMA(CLOSE,35),COLORRED;

   MA9:EMA(CLOSE,40),COLORRED;

   MA10:EMA(CLOSE,45),COLORRED;

   MA11:EMA(CLOSE,50),COLORRED;

   MA12:EMA(CLOSE,60),COLORRED;

   T1:=CONST(LLVBARS(LOW,N));

   T1HIGH:=CONST(REF(HIGH,T1));

   CC:=CONST(CURRBARSCOUNT);

   T2:=CONST(BARSLAST((CURRBARSCOUNT>(CC+T1))AND(HIGH>T1HIGH)));

   T2HIGH:=CONST(REF(HIGH,T2));

   T3:=CONST(BARSLAST((CURRBARSCOUNT>(CC+T2))AND(HIGH>T2HIGH)));

   T3HIGH:=CONST(REF(HIGH,T3));

   {猎击线:T3HIGH,LINETHICK2,COLOR0000FF;}

   猎击线:DRAWLINE(CURRBARSCOUNT=T3+1,T3HIGH,ISLASTBAR,T3HIGH,1),LINETHICK2,COLOR0000FF;

   DRAWTEXT(ISLASTBAR,T3HIGH,'猎击线')LINETHICK1,COLOR0000FF;

   TT1:=CONST(HHVBARS(HIGH,P));

   TT1LOW:=CONST(REF(LOW,TT1));

   CC1:=CONST(CURRBARSCOUNT);

   TT2:=CONST(BARSLAST((CURRBARSCOUNT>CC1+TT1)AND(LOW<TT1LOW)));

   TT2LOW:=CONST(REF(LOW,TT2));

   TT3:=CONST(BARSLAST((CURRBARSCOUNT>CC1+TT2)AND(LOW<TT2LOW)));

   TT3LOW:=CONST(REF(LOW,TT3));

   止损线:DRAWLINE(CURRBARSCOUNT=TT3+1,TT3LOW,ISLASTBAR,TT3LOW,1),LINETHICK2,COLORGREEN;

   DRAWTEXT(ISLASTBAR,TT3LOW,'止损线')LINETHICK1,COLORLIGREEN;




大智慧顾比倒数副图指标截图

最新发布

相关文章

神奇指标广告