指标资讯
神奇指标广告
通达信主力监控之王幅图指标源码-通达信指标公式
来源:神奇指标 发布时间:2024-02-06

  

以下是通达信主力监控之王幅图指标源码和截图


通达信主力监控之王幅图指标源码:


   高1:=REF(HHV(H,150),3);

   低1:=REF(LLV(L,150),3);

   H1:=高1-(高1-低1)*0.191;

   H2:=高1-(高1-低1)*0.382;

   H3:=高1-(高1-低1)*0.5;

   H4:=高1-(高1-低1)*0.618;

   H5:=高1-(高1-低1)*0.809;

   {顶:REFDATE(高1,DATE),POINTDOT,COLORWHITE;}

   %19:REFDATE(H1,DATE),POINTDOT,COLORYELLOW;

   %38:REFDATE(H2,DATE),POINTDOT,COLORYELLOW;

   %50:REFDATE(H3,DATE),POINTDOT,COLORWHITE;

   %61:REFDATE(H4,DATE),POINTDOT,COLORYELLOW;

   %80:REFDATE(H5,DATE),POINTDOT,COLORYELLOW;

   突破:REF(EMA(C,14),1)COLORMAGENTA,LINETHICK2;

   A1X:=(EMA(C,14)-突破)/突破*100,NODRAW;

   出击:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK2;

   休假:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK2;

   STICKLINE(A1X>=0,出击,突破,0,-1)COLORRED;

   STICKLINE(A1X<0,休假,突破,0,-1)COLORGREEN;

   STICKLINE(CROSS(A1X,0),C,O,2,0)COLORYELLOW;

   STICKLINE(CROSS(0,A1X),C,O,2,0)COLORGREEN;

   ※:IF(A1X<0,突破,DRAWNULL)COLORGREEN,LINETHICK2;

   DP:=REF(EMA(INDEXC,14),1);

   DPX:=(EMA(INDEXC,14)-DP)/DP*100;

   STICKLINE(DPX>=0ANDA1X>=0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORRED;

   STICKLINE(DPX<0ANDA1X<0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORGREEN;

   STICKLINE(NOT(DPX>=0ANDA1X>=0)ANDNOT(DPX<0ANDA1X<0),REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORYELLOW;

   {主力监控}

   N1:=9;N2:=5;

   MTM:=C-REF(C,1);

   主力轨迹:100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1),COLORWHITE;

   MAZL:MA(主力轨迹,N2),COLORYELLOW;

   VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

   VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);

   VAR3:=EMA(VAR2,10);

   VAR4:=LLV(LOW,33);

   VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);

   主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED,NODRAW;

   STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0),COLOR000055;

   STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.6,0),COLOR000077;

   STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0),COLOR000099;

   STICKLINE(VAR5>REF(VAR5,1),0,VAR5,1.5,0),COLOR0000BB;

   STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.9,0),COLOR0000DD;

   STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.3,0),COLOR0000FF;

   洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLOR000079,NODRAW;

   STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR000079;

   STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.6,0),COLOR000093;

   STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR0000C6;

   STICKLINE(VAR5<REF(VAR5,1),0,VAR5,1.5,0),COLOR4A4AFF;

   STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.9,0),COLOR7D7DFF;

   STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.3,0),COLORAAAAFF;

   VAR21:=SMA(ABS(HIGH-VAR1),13,1)/SMA(MIN(HIGH-VAR1,0),10,1);

   VAR31:=EMA(VAR21,10);

   VAR41:=HHV(HIGH,33);

   VAR51:=EMA(IF(HIGH>=VAR41,VAR31,0),3);

   主力拉高:IF(VAR51<REF(VAR51,1),VAR51,0),COLORYELLOW,NODRAW;

   STICKLINE(VAR51<REF(VAR51,1),0,VAR51,3,0),COLOR005555;

   STICKLINE(VAR51<REF(VAR51,1),0,VAR51,2.6,0),COLOR007777;

   STICKLINE(VAR51<REF(VAR51,1),0,VAR51,2.1,0),COLOR009999;

   STICKLINE(VAR51<REF(VAR51,1),0,VAR51,1.5,0),COLOR11BBBB;

   STICKLINE(VAR51<REF(VAR51,1),0,VAR51,0.9,0),COLOR33DDDD;

   STICKLINE(VAR51<REF(VAR51,1),0,VAR51,0.3,0),COLOR55FFFF;

   出货:IF(VAR51>REF(VAR51,1),VAR51,0),COLORCYAN,NODRAW;

   STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0),COLORCYAN;

   STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0),COLOR555555;

   STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.6,0),COLOR777777;

   STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.1,0),COLOR999999;

   STICKLINE(VAR51>REF(VAR51,1),0,VAR51,1.5,0),COLORBBBBBB;

   STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.9,0),COLORDDDDDD;

   STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.3,0),COLORFFFFFF;

   X_1:=AMOUNT/VOL/100;

   X_2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

   X_3:=SUM(AMOUNT,40)/X_1/100;

   GSZX:=SUM(AMOUNT,80)/X_1/100;

   X_5:=DMA(X_2,VOL/X_3);

   X_6:=DMA(X_2,VOL/GSZX);

   X_7:=(CLOSE-X_5)/X_5*100;

   X_8:=(CLOSE-X_6)/X_6*100;

   控盘:4,COLORYELLOW;

   河:(-5),COLORGREEN;

   湖:(-15),COLORCCFF33;

   STICKLINE(X_8>0,0,X_8,1,0),COLORYELLOW;

   STICKLINE(X_8<=0,0,X_8,1,0),COLORGREEN;

   STICKLINE(X_7>0,0,X_7,1,0),COLORRED;

   STICKLINE(X_7<=0,0,X_7,1,0),COLORFF9966;

   警戒:21,COLOR0099FF,LINETHICK5;



通达信主力监控之王幅图指标截图

最新发布

相关文章

神奇指标广告