指标资讯
神奇指标广告
通达信决策曲线简洁版副图指标公式源码-通达信指标公式
来源:神奇指标 发布时间:2024-02-06

  

以下是通达信决策曲线简洁版副图指标公式源码和截图


通达信决策曲线简洁版副图指标公式源码:

   回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);

   经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

   经典K:=SMA(经典RL,3,1);经典D:=SMA(经典K,3,1);经典J:=3*经典K-2*经典D;

   MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20)))/(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));

   MAHL2:=IF(EMA(C,2)>回归斜率线AANDMAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}

   MAHL3:=IF(EMA(C,2)>回归斜率线AANDMAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}

   回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));

   上线:=SMA(C,6.5,1);

   一号支撑线:SMA(C,14.5,1);

   上线1:=SMA(C,3,1);

   一号支撑线1:=SMA(C,8,1);

   上线2:=SMA(C,3.5,1);

   DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'洗盘'),COLOR00FF00;

   BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;

   UPR:=BBI+3*STD(BBI,13),LINETHICK2;

   DWN:=BBI-3*STD(BBI,13);

   安全:=MA(CLOSE,55),LINETHICK2;

   LC:=REF(CLOSE,1);

   RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

   DRAWTEXT(CROSS(82,RSI)ANDCLOSE<上线1,HIGH*1.04,'减仓'),COLORFF9966,LINETHICK2;

   A7:=(2*C+H+L)/4;

   操作:MA(A7,5),COLORBLUE,LINETHICK2;

   操作1:=MA(A7,5)*1.03,LINETHICK2;

   操作2:=MA(A7,5)*0.97,LINETHICK2;

   DRAWTEXT(CROSS(上线1,上线)AND上线1>操作,LOW*0.92,'买进'),COLORYELLOW;

   VAR1:LLV(A7,21);

   VAR2:HHV(A7,30);

   DRAWTEXT(CROSS(上线1,操作)AND上线1<一号支撑线AND上线1<一号支撑线1AND上线1<上线ANDCLOSE>VAR1,LOW*0.98,'见底'),COLORYELLOW;

   YCX:=操作>=REF(操作,1);

   H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);

   L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);

   DRAWTEXT(CROSS(上线1,一号支撑线1)AND上线1>操作,LOW*0.98,'全仓'),COLORYELLOW;

   SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);

   SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);

   M1:=1000*操作/一号支撑线<=1015AND1000*操作/一号支撑线>=975;

   M2:=1000*一号支撑线1/一号支撑线<=1020AND一号支撑线1/一号支撑线>=980;

   M3:=1000*上线/一号支撑线<=1015AND上线/一号支撑线>=985;

   DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10AND

   COUNT(SK>SD,6)ANDREF(LOW,5)=LLV(LOW,120)ANDREF(CLOSE>=OPEN,4)AND

   REF(CLOSE>OPEN,3)ANDREF(CLOSE>OPEN,2)ANDREF(OPEN>CLOSE,1)AND

   OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进'),COLORYELLOW;

   D:=MA(CLOSE,89)-MA(CLOSE,10)/3;

   DRAWTEXT(IF(CLOSE<DANDVOL/240>MA(VOL,5)/240ANDCLOSE>REF(CLOSE,1)*1.08

   ANDCLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;

   RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;

   K:=SMA(RSV,3,1);

   D1:=SMA(K,3,1);

   J:=3*K-2*D1;

   VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}

   VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}

   E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;

   F:=MA(E,3)+0.03;

   G:=MA(E,1);

   DRAWICON(CROSS(F,G)ANDJ>65,HIGH*1.02,15),COLORGREEN;

   DRAWICON(CROSS(G,F),LOW*0.9,9),COLORYELLOW;

   DRAWTEXT(CLOSE>OPENANDH1<CANDO<L1ANDYCXANDCROSS(上线1,操作)ANDLOW>VAR1AND上线1>一号支撑线ANDJ<90,LOW*0.9,'主升'),COLORRED;

   DRAWTEXT(CROSS(上线1,操作)ANDM1ANDM2ANDM3,LOW*0.94,'买进'),COLORYELLOW;

   DRAWTEXT(CLOSE>OPENAND上线>一号支撑线1AND一号支撑线1>一号支撑线ANDCLOSE>MA(CLOSE,一号支撑线)AND操作>=REF(CLOSE,操作)ANDCROSS(上线1,操作)ANDLOW>VAR1ANDJ<90,LOW*0.9,'主升'),COLORRED;

   DRAWTEXT(CLOSE>OPENAND操作>上线AND上线>一号支撑线1AND一号支撑线1>一号支撑线ANDCROSS(上线1,操作)ANDLOW>VAR1ANDJ<90,LOW*0.86,'回踩买进'),COLORRED;

   DRAWTEXT(CLOSE>OPENANDCROSS(上线,一号支撑线)ANDLOW>VAR1ANDJ<90,LOW*0.86,'回踩买进'),COLORRED;

   STICKLINE(CLOSE>REF(CLOSE,1),HIGH,LOW,0,0),COLORRED;

   STICKLINE(C<OANDC>REF(C,1),C,O,3,0),COLORFFCC00;

   STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,3,0),COLOR000055;{红K};

   STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,2.7,0),COLOR000077;{红K};

   STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,2.1,0),COLOR000099;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLOR0000BB;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLOR0000DD;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLOR0000FF;

   STICKLINE(CLOSE=REF(CLOSE,1),H,L,3,1),COLOR999999;

   STICKLINE(CLOSE=REF(CLOSE,1),HIGH,LOW,0,0),COLORWHITE;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,3,0),COLOR555555;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR777777;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR999999;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORBBBBBB;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORDDDDDD;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLORFFFFFF;

   STICKLINE(CLOSE<REF(CLOSE,1),HIGH,LOW,0,1),COLORCYAN;

   STICKLINE(C<REF(C,1)ANDC>O,C,O,3,0),COLORFFCC00;

   STICKLINE(C<REF(C,1)ANDC<O,OPEN,CLOSE,3,0),COLOR990000;

   STICKLINE(C<REF(C,1)ANDC<O,OPEN,CLOSE,2.7,0),COLORCC0000;

   STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,2.1,0),COLORFF4400;

   STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,1.5,0),COLORFF8800;

   STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,0.9,0),COLORFFCC00;

   STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,3.2,0),COLORBB00FF;

   STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,2.7,0),COLORFF33FF;

   STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,2.1,0),COLORFF66FF;

   STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,1.5,0),COLORFF99FF;

   STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;

   STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;

   MA1:=MA(CLOSE,5);

   MA2:=MA(CLOSE,10);

   P01:=IF(MA1>MA2,2,IF(MA2>MA1,(-2),0));

   MA3:=MA(CLOSE,3);

   MA4:=MA(CLOSE,5);

   P02:=IF(MA3>MA4,2,IF(MA4>MA3,(-2),0));

   MA5:=MA(CLOSE,12);

   MA6:=MA(CLOSE,50);

   P03:=IF(MA5>MA6,2,IF(MA6>MA5,(-2),0));

   RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;

   K:=EMA(RSV,3);

   D:=EMA(K,3);

   P04:=IF(K>D,2,IF(D>K,(-2),0));

   DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

   DEA:=EMA(DIF,9);

   MACD:=(DIF-DEA)*2;

   P05:=IF(DIF>DEA,2,IF(DEA>DIF,(-2),0));

   TR2:=EMA(EMA(EMA(CLOSE,12),12),12);

   TRIX:=(TR2-REF(TR2,1))/REF(TR2,1)*100;

   MATRIX:=MA(TRIX,9);

   P06:=IF(TRIX>MATRIX,2,IF(MATRIX>TRIX,(-2),0));

   TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),7);

   HD:=HIGH-REF(HIGH,1);

   LD:=REF(LOW,1)-LOW;

   DMP:=EMA(IF(HD>0ANDHD>LD,HD,0),7);

   DMM:=EMA(IF(LD>0ANDLD>HD,LD,0),7);

   PDI:=DMP*100/TR1;

   MDI:=DMM*100/TR1;

   ADX:=EMA(ABS(MDI-PDI)/(MDI+PDI)*100,7);

   ADXR:=EMA(ADX,7);

   P07:=IF(PDI>MDIANDADX>PDIANDADX>50,3,IF(PDI<MDIANDADX>MDIANDADX>50,(-3),0));

   LC:=REF(CLOSE,1);

   RSI1:=EMA(MAX(CLOSE-LC,0),5)/EMA(ABS(CLOSE-LC),5)*100;

   P08:=IF(RSI1>80,2,IF(RSI1<20,(-2),0));

   TYP:=(HIGH+LOW+CLOSE)/3;

   CCI:=(TYP-MA(TYP,8))/(0.015*AVEDEV(TYP,8));

   P09:=IF(CCI>180,2,IF(CCI<(-180),(-2),0));

   WR1:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;

   P10:=IF(WR1>80,2,IF(WR1<20,(-2),0));

   OSC:=100*(CLOSE-MA(CLOSE,20));

   P11:=IF(OSC>0,2,IF(OSC<0,(-2),0));

   MOM:=CLOSE-REF(CLOSE,7);

   P12:=IF(MOM>0,2,IF(MOM<0,(-2),0));

   DPO:=CLOSE-REF(MA(CLOSE,11),11/2+1);

   P13:=IF(DPO>0,1,IF(DPO<0,(-1),0));

   MB:=MA(CLOSE,12);

   R:=(CLOSE-MB)*(CLOSE-MB);

   X1:=MA(R,12);

   X2:=SQRT(X1);

   D1:=1;

   UPPERB:=MB+D1*X2;

   LOWERB:=MB-D1*X2;

   P14:=IF(CLOSE>UPPERB,2,IF(CLOSE<LOWERB,(-2),0));

   BR:=SUM(MAX(0,HIGH-REF(CLOSE,1)),14)/SUM(MAX(0,REF(CLOSE,1)-LOW),14)*100;

   AR:=SUM(HIGH-OPEN,14)/SUM(OPEN-LOW,14)*100;

   P15:=IF(BR>350ORAR>180,3,IF(BR<45ORAR<45,(-3),0));

   TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),14);

   TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),14);

   TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),14);

   VR:=100*(TH*2+TQ)/(TL*2+TQ);

   P16:=IF(VR>350,3,IF(VR<45,(-3),0));

   WVAD:=SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,6)/10000;

   P17:=IF(WVAD>0,1,IF(WVAD<0,(-1),0));

   VOLUME:=MA(VOL,4)/VOL;

   MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);

   EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,4),4);

   P18:=IF(EMV>0,1,IF(EMV<0,(-1),0));

   VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

   OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

   MAOBV:=EMA(OBV,24);

   P19:=IF(OBV>MAOBV,1,IF(OBV<MAOBV,(-1),0));

   PVI:=AMV.AMV1;

   MPVI:=EMA(PVI,24);

   P20:=IF(PVI>MPVI,1,IF(PVI<MPVI,(-1),0));

   NVI:=ZX.AV;

   MNVI:=EMA(NVI,24);

   P21:=IF(NVI>MNVI,2,IF(NVI<MNVI,(-2),0));

   MASS:=SUM(MA(HIGH-LOW,9)/MA(MA(HIGH-LOW,9),9),25);

   MA7:=MA(CLOSE,9);

   P22:=IF(MA7>REF(MA7,1)ANDMASS>26.5,2,IF(MA7<REF(MA7,1)ANDMASS<26.5,(-2),0));

   NUM:=ABS(HHV(HIGH,15)-LLV(LOW,15));

   DEN:=SUM(ABS(CLOSE-REF(CLOSE,1)),15);

   VHF:=IF(DEN=0,0,NUM/DEN);

   VHF1:=EMA(VHF,240);

   P23:=IF(VHF>VHF1,1,IF(VHF<VHF1,(-1),0));

   PU:=MA(CLOSE,13);

   CU:=MA(VOL,13);

   PU1:=(PU-REF(PU,1))/REF(PU,1)*100;

   CU1:=(CU-REF(CU,1))/REF(CU,1)*100;

   逆时针曲线:=PU1+CU1;

   P24:=IF(逆时针曲线>REF(逆时针曲线,1),1,IF(逆时针曲线<REF(逆时针曲线,1),(-1),0));

   LC2:=REF(CLOSE,1);

   AA:=ABS(HIGH-LC2);

   BB:=ABS(LOW-LC2);

   CC:=ABS(HIGH-REF(LOW,1));

   DD:=ABS(LC2-REF(OPEN,1));

   R2:=IF(AA>BBANDAA>CC,AA+BB/2+DD/4,IF(BB>CCANDBB>AA,BB+AA/2+DD/4,CC+DD/4));

   X01:=CLOSE-LC2+(CLOSE-OPEN)/2+LC2-REF(OPEN,1);

   SI:=16*X01/R2*MAX(AA,BB);

   ASI:=SUM(SI,0);

   MASI:=MA(ASI,6);

   P25:=IF(CLOSE<HHV(CLOSE,13)ANDASI=HHV(ASI,13),1,IF(CLOSE>LLV(CLOSE,13)ANDASI=LLV(ASI,13),(-1),0));

   BIAS1:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

   P26:=IF(BIAS1>10,1,IF(BIAS1<(-10),(-1),0));

   A:=VOL*CLOSE/10000;

   IUV:=EXPMEMA(A,30);

   MA6C:=EMA(IUV,6);

   P27:=IF(IUV>MA6C,1,IF(IUV<MA6C,(-1),0));

   N1:=30;

   N2:=30;

   MMM:=6;

   RES1:=MA(CLOSE,N1);

   RES2:=MA(AMOUNT,N2);

   SOURCE1:=(AMOUNT/RES2-1)*100-(CLOSE/RES1-1)*100;

   SOURCE2:=MA(SOURCE1,N2);

   REF1:=REF(SOURCE2,1);

   REF2:=REF(SOURCE1,N2);

   IUSV:=(REF1*N2-REF2+SOURCE1)/N2;

   EMA6B:=EMA(IUSV,MMM);

   P28:=IF(IUSV>EMA6B,1,IF(IUSV<EMA6B,(-1),0));

   决策曲线:=ROUND((P01+P02+P03+P04+P05+P06+P07+P08+P09+P10+P11+P12+P13+P14+P15+P16+P17+P18+P19+P20+P21+P22+P23+P24+P25+P26+P27+P28)/1.5+50);

   TDXSTEP286:STICKLINE(CLOSE>0,36,36,10,0),COLORLICYAN;

   TDXSTEP287:STICKLINE(CLOSE>0,44,44,10,0),COLORLICYAN;

   TDXSTEP288:STICKLINE(CLOSE>0,56,56,10,0),COLORLICYAN;

   TDXSTEP289:STICKLINE(CLOSE>0,71,71,10,0),COLORLICYAN;

   ER:=EXPMA(决策曲线,20);

   决策曲线JC:决策曲线,COLORWHITE;

   决策曲线JC强:IF(决策曲线>56,决策曲线,DRAWNULL),COLORRED;

   N1:=1;

   IF(n1<1)

   {

   IF(CLOSE>OPEN)

   RETURN"阳";

   ELSEIF(CLOSE<OPEN)

   RETURN"阴";

   ELSEIF(CLOSE==OPENANDOPEN>=CLOSE[1])

   RETURN"阳";

   ELSEIF(CLOSE==OPENANDOPEN<=CLOSE[1])

   RETURN"阴";

   MONEY;

   k线换手;

   }

   IF(n1>0)

   {

   Var1=MONEY/vol;

   A=SMA(Var1,5,1)-Sma(Var1,55,1);

   B=SMA((A-SMA(A,5,1)),5,1);

   风险系数:B;

   aa:=MA(CLOSE,5);

   前非红:=IF(REF(CLOSE,1)<REF(aa,1)ORREF(A,1)<REF(A,2)ORREF(B,1)<REF(B,2),1,2);

   当红:=IF(CLOSE>MA(CLOSE,5)ANDA>REF(A,1)ANDB>REF(B,1),1,2);

   LOWV1:=LLV(LOW,8);

   HIGHV1:=HHV(HIGH,8);

   RSV1:=EMA((CLOSE-LOWV1)/(HIGHV1-LOWV1)*100,3);

   K11:=EMA(RSV1,3);

   D11:=MA(K11,2);

   LOWV2:=LLV(LOW,21);

   HIGHV2:=HHV(HIGH,21);

   RSV2:=EMA((CLOSE-LOWV2)/(HIGHV2-LOWV2)*100,3);

   K22:=EMA(RSV2,3);

   D22:=MA(K22,2);

   V5:=MA(V,5);

   V18:=MA(V,18);

   IF(V>V5ANDV>V18)

   Ll:=6.5;

   ELSELl:=0;

   IF(D11>REF(D11,1))

   dx:=2.1;

   ELSEdx:=0;

   IF(D11<25)

   dz:=7.6;

   ELSEIF(D11<28)

   dz:=6.1;

   ELSEIF(D11<31)

   dz:=4.6;

   ELSEIF(D11<35)

   dz:=3.1;

   ELSEIF(D11<40)

   dz:=1.6;

   IF(D22<25)

   dz2:=7.6;

   ELSEIF(D22<28)

   dz2:=6.1;

   ELSEIF(D22<31)

   dz2:=4.6;

   ELSEIF(D22<35)

   dz2:=3.1;

   ELSEIF(D22<40)

   dz2:=1.6;

   zz:=Ll+dx+dz+dz2;

   MAVOL$0:MA(VOL,2);

   MAVOL$1:MA(VOL,5);

   MAVOL$2:MA(VOL,20);

   RSV1=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

   a1=SMA(RSV1,3,1);

   b1=SMA(a1,3,1);

   e1=3*a1-2*b1;

   IF(前非红=1AND当红=1ANDzz>16ANDC>O*0.985ANDC>REF(C,1)*0.98)//23

   RETURN("yang");

   IF(CLOSE>MA(CLOSE,5)ANDA>REF(A,1)ANDB>REF(B,1)ANDREF(MAVOL$1,1)<MAVOL$1ANDREF(MAVOL$2,1)<MAVOL$2AND前非红=1AND当红=1ANDb1<80)

   RETURN("buy");

   IF(CLOSE>MA(CLOSE,5)ANDA>REF(A,1)ANDB>REF(B,1))

   RETURN("colorred");

   IF(CLOSE<MA(CLOSE,5)ANDA>REF(A,1)ANDB>REF(B,1))

   RETURN("colorwhite");

   IF(A<REF(A,3)ANDB<REF(B,3))

   RETURN("colorgreen");

   IF(A>REF(A,1)ANDB<REF(B,1))

   RETURN("colorwhite");

   IF(A<REF(A,1)ANDB>REF(B,1))

   RETURN("colorwhite");

   }




通达信决策曲线简洁版副图指标公式截图

最新发布

相关文章

神奇指标广告