指标资讯
神奇指标广告
通达信涨停神器指标公式
来源:神奇指标 发布时间:2023-06-15

  

以下是通达信涨停神器指标公式源码和注释翻译结果


使用说明:

   指标解读:涨停神器指标的具体解读方法通常由软件提供。在通达信软件中,该指标可能会以柱状图或其他形式呈现。一般来说,该指标会根据一定的算法和规则识别潜在的涨停股票,并在图表上标示出来。用户可以根据指标的数值或图表的变化来判断股票是否具有涨停潜力。

   设置参数:在使用涨停神器指标之前,通常需要设置一些参数,以便根据个人需求进行筛选。这些参数可能包括市场类型、股票范围、过滤条件等。具体的设置方法通常会在软件的用户手册或在线教程中有所说明。

通达信涨停神器指标公式源码:


    XG:HHV(H,480),DOTLINE,COLORCYAN;
    RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
    JY:=BArslAst((RQ-REF(RQ,1))!=WEEkdAY-REF(WEEKDAY,1)ORTOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
    ma1:=REF(C,JY);
    MA2:=REF(MA1,JY);
    MA3:=REF(MA2,JY);
    MA4:=REF(MA3,JY);
    MA5:=REF(MA4,JY);
    MA6:=REF(MA5,JY);
    MA7:=REF(MA6,JY);
    MA8:=REF(MA7,JY);
    MA9:=REF(MA8,JY);
    H1:=MAX(DYNAINFO(3),DYNAINFO(5));
    L1:=MIN(DYNAINFO(3),DYNAINFO(6));
    P1:=H1-L1;
    阻力:L1+P1*8/9,COLORLIRED,DOTLINE;
    支撑:L1+P1*0.5/9,COLORGREEN,DOTLINE;
    均线:IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(vol*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW,DOTLINE;
    DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);
    DEA:=EMA(DIF,9);
    macd1:=10*(DIF-DEA);
    MacD2:=EMA(MACD1,2);
    STICKLINE(MACD1>=MACD2ANDMACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGRAY;
    STICKLINE(MACD1<MACD2ANDMACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLICYAN;
    STICKLINE(MACD1>=MACD2ANDMACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGRAY;
    STICKLINE(MACD1<MACD2ANDMACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGREEN;
    XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
    主力:=expma(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
    底:=1;1.022,NODRAW;高:=1.033;
    DRAWTEXT(crOSS(主力,1.02),C*0.999,'拉'),COLORMAGENTA;
    DRAWICON(CROSS(主力,1.04),C,45);
    DRAWTEXT(CROSS(主力,1.04),C*0.999,'冲'),COLORRED;
    A1:=(VOL/CLOSE)/3;
    A2:=SUM((IF(((A1>40)AND(CLOSE>(REF(CLOSE,1)))),A1,0)),0);
    A3:=SUM((IF(((A1>40)AND(CLOSE<(REF(CLOSE,1)))),A1,0)),0);
    A4:=SUM((IF(((A1<40)AND(CLOSE>(REF(CLOSE,1)))),A1,0)),0);
    A5:=SUM((IF(((A1<40)AND(CLOSE<(REF(CLOSE,1)))),A1,0)),0);
    A6:=((A2+A3)+A4)+A5;
    A7:=IF((BARSTATUS=2),((100*A2)/A6),0);
    A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));
    A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));
    A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));
    DRAWTEXT(LONGCROSS(支撑,C,2),C-0.01,'买入'),COLOR0000FF;
    DRAWICON(LONGCROSS(支撑,C,2),C-0.01,1);
    STICKLINE(LONGCROSS(支撑,C,2),C,阻力,0,-1),COLORCYAN;
    DRAWTEXT(LONGCROSS(C,阻力,2),C+0.01,'卖出'),COLORGREEN;
    DRAWICON(LONGCROSS(C,阻力,2),C+0.01,45);
    STICKLINE(LONGCROSS(C,阻力,2),C,支撑,0,-1),COLORRED;
    量价:=(VOL/CLOSE)/3;
    B2:=SUM((IF(((量价>0.20)AND(CLOSE>(REF(CLOSE,1)))),量价,0)),0);
    B3:=SUM((IF(((量价>0.20)AND(CLOSE<(REF(CLOSE,1)))),量价,0)),0);
    B6:=B2+B3;DD1:=1;比:=B2/B3;
    D1:=YEARANDMONTHANDDAY;
    BA1:=STRCAT(CON2STR(YEAR,0),'年');
    BA2:=STRCAT(CON2STR(MONTH,0),'月');
    BA3:=STRCAT(CON2STR(DAY,0),'日');
    BA4:=STRCAT('星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));
    AA:=STRCAT(STRCAT(STRCAT(BA1,BA2),STRCAT(BA3,BA4)),'');
    DRAWTEXT_FIX(D1,0.905,0,0,AA),COLORGRAY;
    WA1:=V*C/100;
    WA2:=SUM((IF(((WA1/8>20)AND(CLOSE>(REF(CLOSE,1)))),WA1,0)),0);
    WA3:=SUM((IF(((WA1/8>20)AND(CLOSE<(REF(CLOSE,1)))),WA1,0)),0);
    WA4:=SUM((IF(((WA1/8<20)AND(CLOSE>(REF(CLOSE,1)))),WA1,0)),0);
    WA5:=SUM((IF(((WA1/8<20)AND(CLOSE<(REF(CLOSE,1)))),WA1,0)),0);
    WA6:=((A2+A3)+A4)+A5;
    WA7:=IF((ISLASTBAR),((100*WA2)/WA6),0);
    WA8:=IF((ISLASTBAR),((100*WA3)/WA6),0);
    WA9:=IF((ISLASTBAR),((100*WA4)/WA6),0);
    WA10:=IF((ISLASTBAR),((100*WA5)/WA6),0);
    机构买盘:=(WA2);
    机构卖盘:=(WA3);
    散户买盘:=(WA4);
    散户卖盘:=(WA5);
    DRAWTEXT_FIX(1,0.752,1-0.088,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),'万')),COLORRED;
    DRAWTEXT_FIX(1,0.752,1-0.001,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),'万')),COLORGREEN;
    DRAWTEXT_FIX(1,0.883,1-0.088,0,STRCAT(STRCAT('【散户买盘】',CON2STR(散户买盘,2)),'万')),COLORMAGENTA;
    DRAWTEXT_FIX(1,0.883,1-0.001,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),'万')),COLORCYAN;
    涨停就发:REF(C,1)/REF(C,2)<=0.93AND
    BETWEEN(C/REF(C,1),1.03,0.97)and
    close/ref(close,8)<=0.8and
    between(ref(c,2)/ref(c,3),1.04,0.96)and
    between(ref(c,3)/ref(c,4),1.04,0.96),linethick0,coloryellow;
    stickline(涨停就发,0,2,8,1),colorred;
    drawtext(涨停就发,3,'今\n买\n明\n涨\n停'),COLORred;
    选股:涨停就发,colorwhite;






通达信涨停神器指标公式源码注释翻译结果


    输出XG:480日内最高价的最高值,DOTLINE,画青色
    RQ赋值:日期对应的转换天数-总的周期数-到最后交易的周期日前的日期对应的转换天数+1
    JY赋值:上次(RQ-1日前的RQ)不等于星期-1日前的星期ORTOTALBARSCOUNT-到最后交易的周期=0距今天数+1
    MA1赋值:JY日前的收盘价
    MA2赋值:JY日前的MA1
    MA3赋值:JY日前的MA2
    MA4赋值:JY日前的MA3
    MA5赋值:JY日前的MA4
    MA6赋值:JY日前的MA5
    MA7赋值:JY日前的MA6
    MA8赋值:JY日前的MA7
    MA9赋值:JY日前的MA8
    H1赋值:昨收盘价和最高价的较大值
    L1赋值:昨收盘价和最低价的较小值
    P1赋值:H1-L1
    输出阻力:L1+P1*8/9,画淡红色,DOTLINE
    输出支撑:L1+P1*0.5/9,画绿色,DOTLINE
    输出均线:如果收盘价/(成交额(元)的历史累和/成交量(手)*100的历史累和)位于1.05和0.95之间=0,返回收盘价的历史简单移动平均,否则返回(成交额(元)的历史累和/成交量(手)*100的历史累和),画黄色,DOTLINE
    DIF赋值:(收盘价的12日指数移动平均-收盘价的26日指数移动平均)+昨收盘价
    DEA赋值:DIF的9日指数移动平均
    MACD1赋值:10*(DIF-DEA)
    MACD2赋值:MACD1的2日指数移动平均
    当满足条件MACD1>=MACD2ANDMACD1>=0时,在昨收盘价和MACD1+昨收盘价位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画淡灰色
    当满足条件MACD1<MACD2ANDMACD1>0时,在昨收盘价和MACD1+昨收盘价位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画淡青色
    当满足条件MACD1>=MACD2ANDMACD1<0时,在昨收盘价和MACD1+昨收盘价位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画淡灰色
    当满足条件MACD1<MACD2ANDMACD1<0时,在昨收盘价和MACD1+昨收盘价位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画淡绿色
    XX赋值:成交额(元)的收盘价的有效数据周期数日累和/成交量(手)*100的收盘价的有效数据周期数日累和
    主力赋值:收盘价/XX的20日指数移动平均
    大户赋值:收盘价/XX的60日指数移动平均
    散户赋值:收盘价/XX的120日指数移动平均
    底赋值:1
    1.022,NODRAW
    高赋值:1.033
    当满足条件主力上穿1.02时,在收盘价*0.999位置书写文字,画洋红色
    当满足条件主力上穿1.04时,在收盘价位置画45号图标
    当满足条件主力上穿1.04时,在收盘价*0.999位置书写文字,画红色
    A1赋值:(成交量(手)/收盘价)/3
    A2赋值:(如果((A1>40)AND(收盘价>(1日前的收盘价))),返回A1,否则返回0)的历史累和
    A3赋值:(如果((A1>40)AND(收盘价<(1日前的收盘价))),返回A1,否则返回0)的历史累和
    A4赋值:(如果((A1<40)AND(收盘价>(1日前的收盘价))),返回A1,否则返回0)的历史累和
    A5赋值:(如果((A1<40)AND(收盘价<(1日前的收盘价))),返回A1,否则返回0)的历史累和
    A6赋值:((A2+A3)+A4)+A5
    A7赋值:如果(数据位置状态=2),返回((100*A2)/A6),否则返回0
    A8赋值:((如果(数据位置状态=2),返回((100*A3)/A6),否则返回0))
    A9赋值:((如果(数据位置状态=2),返回((100*A4)/A6),否则返回0))
    A10赋值:((如果(数据位置状态=2),返回((100*A5)/A6),否则返回0))
    当满足条件支撑小于收盘价保持2个交易日后交叉上穿时,在收盘价-0.01位置书写文字,COLOR0000FF
    当满足条件支撑小于收盘价保持2个交易日后交叉上穿时,在收盘价-0.01位置画1号图标
    当满足条件支撑小于收盘价保持2个交易日后交叉上穿时,在收盘价和阻力位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画青色
    当满足条件收盘价小于阻力保持2个交易日后交叉上穿时,在收盘价+0.01位置书写文字,画绿色
    当满足条件收盘价小于阻力保持2个交易日后交叉上穿时,在收盘价+0.01位置画45号图标
    当满足条件收盘价小于阻力保持2个交易日后交叉上穿时,在收盘价和支撑位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画红色
    量价赋值:(成交量(手)/收盘价)/3
    B2赋值:(如果((量价>0.20)AND(收盘价>(1日前的收盘价))),返回量价,否则返回0)的历史累和
    B3赋值:(如果((量价>0.20)AND(收盘价<(1日前的收盘价))),返回量价,否则返回0)的历史累和
    B6赋值:B2+B3
    DD1赋值:1
    比赋值:B2/B3
    D1赋值:YEARANDMONTHAND日
    BA1赋值:字符串相加
    BA2赋值:字符串相加
    BA3赋值:字符串相加
    BA4赋值:字符串相加
    AA赋值:字符串相加
    当满足条件D1时,在横轴0.905纵轴0位置书写文字,画深灰色
    WA1赋值:成交量(手)*收盘价/100
    WA2赋值:(如果((WA1/8>20)AND(收盘价>(1日前的收盘价))),返回WA1,否则返回0)的历史累和
    WA3赋值:(如果((WA1/8>20)AND(收盘价<(1日前的收盘价))),返回WA1,否则返回0)的历史累和
    WA4赋值:(如果((WA1/8<20)AND(收盘价>(1日前的收盘价))),返回WA1,否则返回0)的历史累和
    WA5赋值:(如果((WA1/8<20)AND(收盘价<(1日前的收盘价))),返回WA1,否则返回0)的历史累和
    WA6赋值:((A2+A3)+A4)+A5
    WA7赋值:如果(是否最后一个周期),返回((100*WA2)/WA6),否则返回0
    WA8赋值:如果(是否最后一个周期),返回((100*WA3)/WA6),否则返回0
    WA9赋值:如果(是否最后一个周期),返回((100*WA4)/WA6),否则返回0
    WA10赋值:如果(是否最后一个周期),返回((100*WA5)/WA6),否则返回0
    机构买盘赋值:(WA2)
    机构卖盘赋值:(WA3)
    散户买盘赋值:(WA4)
    散户卖盘赋值:(WA5)
    当满足条件1时,在横轴0.752纵轴1-0.088位置书写文字,画红色
    当满足条件1时,在横轴0.752纵轴1-0.001位置书写文字,画绿色
    当满足条件1时,在横轴0.883纵轴1-0.088位置书写文字,画洋红色
    当满足条件1时,在横轴0.883纵轴1-0.001位置书写文字,画青色
    输出涨停就发:1日前的收盘价/2日前的收盘价<
    =0.93AND收盘价/1日前的收盘价位于1.03和0.97之间AND收盘价/8日前的收盘价<
    =0.8AND2日前的收盘价/3日前的收盘价位于1.04和0.96之间AND3日前的收盘价/4日前的收盘价位于1.04和0.96之间,线宽为0,画黄色
    当满足条件涨停就发时,在0和2位置之间画柱状线,宽度为8,1不为0则画空心柱.,画红色
    当满足条件涨停就发时,在3位置书写文字,画红色
    输出选股:涨停就发,画白色



通达信涨停神器指标公式截图

最新发布

相关文章

神奇指标广告