指标资讯
神奇指标广告
通达信坐等涨停指标公式
来源:神奇指标 发布时间:2023-07-06

以下是通达信坐等涨停指标公式源码和注释翻译结果


使用说明:


   若涨停指标为正数,表示当日最高价高于当日开盘价,有一定的上涨潜力。

   若涨停指标为负数,表示当日最高价低于当日开盘价,预示可能下跌或震荡。

   指标数值的绝对值越大,涨停或跌停的可能性越高。

   根据涨停指标的数值制定投资策略:

   正数值较大:可能出现涨停,可考虑买入该股票。

   正数值较小:可能上涨,但涨停概率较低,可以谨慎考虑买入或观望。

   负数值:可能下跌或震荡,应慎重考虑买入或选择其他股票。


通达信坐等涨停指标公式源码:



X_1:=CLOSE/REF(CLOSE,1)>1.095 AND HIGH=OPEN AND LOW=HIGH;
X_2:=NOT(X_1) OR X_1=0;
X_3:=IF(NAMELIKE(3833) OR NAMELIKE(3834),0,1);
X_4:=DYNAINFO(4)>0;
X_5:=X_3 AND X_4 AND X_2;
X_6:=EMA(CLOSE,9);
X_7:=(CLOSE+OPEN)/2;
X_8:=MA(CLOSE,3);
X_9:=MA(CLOSE,2*3);
X_10:=MA(CLOSE,3*3);
X_11:=MA(CLOSE,4*3);
X_12:=MA((X_8+X_9+X_10+X_11)/4,5);
X_13:=EMA(X_6*1.14,5);
X_14:=(EMA(X_7,3)+EMA(X_7,6)+EMA(X_7,12)+EMA(X_7,24))/4;
X_15:=EMA(EMA(EMA(CLOSE,2),2),2);
X_16:=MA(X_15,13)*0.999;
X_17:=EMA(CLOSE,3);
主升浪5:CROSS(X_17,X_14)COLORYELLOW;
m:=80;
n:=3;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
VAR11:=ma(C,9),COLORRED;
上升通道:IF(VAR11>REF(VAR11,1),VAR11,DRAWNULL),LINETHICK5,COLORRED;
下降通道:IF(VAR11<REF(VAR11,1),VAR11,DRAWNULL),LINETHICK4,COLORGREEN;
A0:=(L+H+C*2)/4;
AA:=EMA(A0,14)COLORYELLOW,LINETHICK1;
BB:=EMA(A0,25)COLORYELLOW,LINETHICK2;
A1X:=(AA-REF(AA,1))/REF(AA,1)*100;
A2X:=(BB-REF(BB,1))/REF(BB,1)*100;
G:=BArslAst(crOSS(A1X,0));
CC:=IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLORBLUE;
DRAWKLINE(H,O,L,C);
ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);
ZSP:=IF(C>REF(C,1),C,DRAWNULL);
DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL);
DSP:=IF(C<=REF(C,1),C,DRAWNULL);
DRAWKLINE(H,DKP,L,DSP);
STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE;
STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700;
STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900;
STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00;
DRAWKLINE(H,ZKP,L,ZSP);
STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099;
STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;
STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF;
STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;
STICKLINE(V/REF(V,1)>2ANDCLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1);
B1:=FILTER(A1,10);
C1:=BacKSET(B1,10+1);
HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1);
B2:=FILTER(A2,10);
C2:=BACKSET(B2,10+1);
LD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT;
STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
VAR01:=(CLOSE>REF(CLOSE,1)ANDCLOSE>REF(CLOSE,2));
VAR02:=(REF(VAR01,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR03:=(REF(VAR02,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VAR04:=(REF(VAR03,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR05:=(REF(VAR04,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VAR06:=(REF(VAR05,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR07:=(REF(VAR06,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VAR08:=(REF(VAR07,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR09:=(REF(VAR08,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR09,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1)ANDCLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR010:=(REF(VARF,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VAR011:=(REF(VAR010,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR012:=(REF(VAR011,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VAR013:=(REF(VAR012,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR014:=(REF(VAR013,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VAR015:=(REF(VAR014,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR016:=(REF(VAR015,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VAR017:=(REF(VAR016,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2));
VAR018:=(REF(VAR017,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2));
VAR019:=((REF(VARDORVAREORVARFORVAR010ORVAR011ORVAR012ORVAR013ORVAR014ORVAR015ORVAR016ORVAR017ORVAR018,1))ANDVAR01);
VAR1A:=((REF(VAR01ORVAR02ORVAR03ORVAR04ORVAR05ORVAR06ORVAR07ORVAR08ORVAR09ORVARAORVARBORVARC,1))ANDVARD);
红色持股:=VAR01ORVAR02ORVAR03ORVAR04ORVAR05ORVAR06ORVAR07ORVAR08ORVAR09ORVARAORVARBORVARC,COLOR0000FF,NODRAW;
离场:=IF(红色持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
青色观望:=VARDORVAREORVARFORVAR010ORVAR011ORVAR012ORVAR013ORVAR014ORVAR015ORVAR016ORVAR017ORVAR018,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
今离场价:REF(离场,1),COLOR0000FF,NODRAW;
明进场价:进,COLOR33AACC,NODRAW;
今进场价:REF(明进场价,1),COLORGREEN,NODRAW;
必卖止损价位:REF(A0,G),COLORFFFFFF,LINETHICK4;
总额:=AMOUNT;
买:=IF(O=CAND(C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-Abs(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.10,0,'解禁日期:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,4))COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C)*100)),COLOR0080FF;
DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLOR0080FF;
DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLOR0080FF;
DRAWTEXT_FIX(1,0.31,0.15,0,'公积金(股):'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF;
DRAWTEXT_FIX(1,0.43,0.15,0,'收益:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF;
DRAWTEXT_FIX(1,0.00,0.19,0,'净流入(亿):'),COLORYELLOW;
DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW;
DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW;
DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW;
DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF;
DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF;
DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF;
DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF;
DRAWTEXT_FIX(1,0.00,0.23,0,'愚民导向:'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.06,0.23,0,EXTERNSTR(0,5)),COLOR00FFFF;
VAR111:=zig(3,13);
STICKLINE((REF(VAR111,2)<REF(VAR111,1))AND(VAR111<REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;
DRAWTEXT_FIX(STICKLINE((REF(VAR111,2)<REF(VAR111,1))AND(VAR111<REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1;
DRAwrECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超BOR大BOR中BOR小BOR超SOR大SOR中SOR小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
大宗进限制:=IF((超B+大B)=0,0,大宗进);
大宗出限制:=IF((超S+大S)=0,0,大宗出);
非大宗进限制:=IF(中B+小B=0,0,非大宗进);
非大宗出限制:=IF(中S+小S=0,0,非大宗出);
主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;
散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;
净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;
大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;
大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);
大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;
大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);
总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;
总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;
成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;
机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;
大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;
大单强度限制:=IF(大单强度=0,-100,大单强度);
大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;
超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;
超单强度限制:=IF(超单强度=0,-100,超单强度);
超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;
DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;
DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户',CON2STR(散户净流入,0)),'万')),COLORCYAN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;
主力买力度:=LARGEINTRDvol*1000/VOL;
主力卖力度:=LARGEOUTTRDVOL*1000/VOL;
AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;
DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));
DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;
{dde显示}
ddx:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);
DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);
DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);
DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE;
DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE;
DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE;
T1:=IF(DDX>0ANDREF(DDX,1)<0,1,0);
T2:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)<0,2,T1);
T3:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)<0,3,T2);
T4:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)<0,4,T3);
T5:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)<0,5,T4);
T6:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)<0,6,T5);
T7:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)>0ANDREF(DDX,7)<0,7,T6);
T8:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)>0ANDREF(DDX,7)>0ANDREF(DDX,8)<0,8,T7);
T9:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)>0ANDREF(DDX,7)>0ANDREF(DDX,8)>0ANDREF(DDX,9)<0,9,T8);
T:=IF(DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)>0ANDREF(DDX,7)>0ANDREF(DDX,8)>0ANDREF(DDX,9)>0,10,T9);
DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT('',CON2STR(T,0)),'[天]')),COLORYELLOW;
T11:=IF(DDY>0ANDREF(DDY,1)<0,1,0);
T21:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)<0,2,T11);
T31:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)<0,3,T21);
T41:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)<0,4,T31);
T51:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)<0,5,T41);
T61:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)<0,6,T51);
T71:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)>0ANDREF(DDY,7)<0,7,T61);
T81:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)>0ANDREF(DDY,7)>0ANDREF(DDY,8)<0,8,T71);
T91:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)>0ANDREF(DDY,7)>0ANDREF(DDY,8)>0ANDREF(DDY,9)<0,9,T81);
TY01:=IF(DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)>0ANDREF(DDY,7)>0ANDREF(DDY,8)>0ANDREF(DDY,9)>0,10,T91);
DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT('',CON2STR(TY01,0)),'[天]')),COLORYELLOW;
T1Z:=IF(DDZ>0ANDREF(DDZ,2)<0,1,0);
T2Z:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)<0,2,T1Z);
T3Z:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)<0,3,T2Z);
T4Z:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)<0,4,T3Z);
T5Z:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)<0,5,T4Z);
T6Z:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)<0,6,T5Z);
T7Z:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)>0ANDREF(DDZ,7)<0,7,T6Z);
T8Z:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)>0ANDREF(DDZ,7)>0ANDREF(DDZ,8)<0,8,T7Z);
T9Z:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)>0ANDREF(DDZ,7)>0ANDREF(DDZ,8)>0ANDREF(DDZ,9)<0,9,T8Z);
TZ:=IF(DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)>0ANDREF(DDZ,7)>0ANDREF(DDZ,8)>0ANDREF(DDZ,9)>0,10,T9Z);
DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT('',CON2STR(TZ,0)),'[天]')),COLORYELLOW;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
macd:=(DIF-DEA)*2;
VAR113:=HHV(HIGH,60);
VAR114:=LLV(LOW,30);
VAR115:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR116:=(VAR113+VAR114+VAR115)/3;
VAR117:=EMA(VAR116,5);
K01:=EMA(VAR117,5)*2,COLORFF00FF;
D01:=EMA(K01,5),COLORWHITE;
J01:=K01*3-D01*2,COLORYELLOW;
ENTERLONG:=CROSS(K01,D01);
EXITLONG:=CROSS(D01,K01);
B01:=(DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1))AND(REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),L*0.98,1))*D01*2/3;
B02:=IF(TROUGHBARS(3,15,1)=1ANDHIGH>LOW+0.01,20,0);
必买:=(B01ANDB02)AND净流入>0;
必卖:=IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN,LINETHICK1;
QQ:=必卖=80;
B03:=((ZIG(3,5)>REF(ZIG(3,5),1))AND(REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))AND(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)));
V1:=EMA(CLOSE,60)-EMA(CLOSE,300);
V2:=EMA(V1,300);
V3:=(CLOSE-(LOW,8))/((HIGH,8)-LLV(LOW,8))*100;
V4:=SMA(V3,2,1),NODRAW;
V5:=SMA(V4,2,1),NODRAW;
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,3);
大涨:=(V7ANDCOUNT(V7,3)=1);
DRAWICON(必买,L-0.16,11);
DRAWICON(大涨AND必买,L-0.16,9);
DRAWICON(大涨,L-0.18,1);
DRAWICON(QQ,H+0.1,6);





通达信坐等涨停指标公式源码注释翻译结果



    X_1赋值:收盘价/1日前的收盘价>
    1.095AND最高价=开盘价AND最低价=最高价
    X_2赋值:取反ORX_1=0
    X_3赋值:如果模糊匹配品种名称ORNAMELIKE(3834),返回0,否则返回1
    X_4赋值:开盘价>
    0
    X_5赋值:X_3ANDX_4ANDX_2
    X_6赋值:收盘价的9日指数移动平均
    X_7赋值:(收盘价+开盘价)/2
    X_8赋值:收盘价的3日简单移动平均
    X_9赋值:收盘价的2*3日简单移动平均
    X_10赋值:收盘价的3*3日简单移动平均
    X_11赋值:收盘价的4*3日简单移动平均
    X_12赋值:(X_8+X_9+X_10+X_11)/4的5日简单移动平均
    X_13赋值:X_6*1.14的5日指数移动平均
    X_14赋值:(X_7的3日指数移动平均+X_7的6日指数移动平均+X_7的12日指数移动平均+X_7的24日指数移动平均)/4
    X_15赋值:收盘价的2日指数移动平均的2日指数移动平均的2日指数移动平均
    X_16赋值:X_15的13日简单移动平均*0.999
    X_17赋值:收盘价的3日指数移动平均
    输出主升浪5:X_17上穿X_14画黄色
    M赋值:80
    N赋值:3
    K线
    VAR11赋值:收盘价的9日简单移动平均,画红色
    输出上升通道:如果VAR11>1日前的VAR11,返回VAR11,否则返回无效数,线宽为5,画红色
    输出下降通道:如果VAR11<1日前的VAR11,返回VAR11,否则返回无效数,线宽为4,画绿色
    A0赋值:(最低价+最高价+收盘价*2)/4
    AA赋值:A0的14日指数移动平均画黄色,线宽为1
    BB赋值:A0的25日指数移动平均画黄色,线宽为2
    A1X赋值:(AA-1日前的AA)/1日前的AA*100
    A2X赋值:(BB-1日前的BB)/1日前的BB*100
    G赋值:上次A1X上穿0距今天数
    CC赋值:如果到最后交易的周期<18,返回1日前的收盘价的最后一日取值设为常数,否则返回无效数,画蓝色
    K线
    ZKP赋值:如果收盘价>1日前的收盘价,返回1日前的收盘价,否则返回无效数
    ZSP赋值:如果收盘价>1日前的收盘价,返回收盘价,否则返回无效数
    DKP赋值:如果收盘价<=1日前的收盘价,返回1日前的收盘价,否则返回无效数
    DSP赋值:如果收盘价<=1日前的收盘价,返回收盘价,否则返回无效数
    K线
    当满足条件收盘价<=1日前的收盘价时,在DKP和DSP位置之间画柱状线,宽度为3.05,0不为0则画空心柱.,画蓝色
    当满足条件收盘价<=1日前的收盘价时,在DKP和DSP位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLORFF7700
    当满足条件收盘价<=1日前的收盘价时,在DKP和DSP位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF9900
    当满足条件收盘价<=1日前的收盘价时,在DKP和DSP位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFBB00
    K线
    当满足条件收盘价>1日前的收盘价时,在ZKP和ZSP位置之间画柱状线,宽度为3.05,0不为0则画空心柱.,COLOR000099
    当满足条件收盘价>1日前的收盘价时,在ZKP和ZSP位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR0000CC
    当满足条件收盘价>1日前的收盘价时,在ZKP和ZSP位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000FF
    当满足条件收盘价>1日前的收盘价时,在ZKP和ZSP位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORCC66FF
    当满足条件成交量(手)/1日前的成交量(手)>2ANDCLOSE>=开盘价时,在ZKP和ZSP位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
    TY赋值:收盘价
    A1赋值:10日前的TY=2*10+1日内TY的最高值
    B1赋值:A1的10日过滤
    C1赋值:若B1则将最近10+1周期置为1
    HD赋值:C1的10日过滤
    A2赋值:10日前的TY=2*10+1日内TY的最低值
    B2赋值:A2的10日过滤
    C2赋值:若B2则将最近10+1周期置为1
    LD赋值:C2的10日过滤
    输出前期高位:上次HD距今天数日前的收盘价,COLOR8000FF,POINTDOT
    当满足条件收盘价时,在前期高位和前期高位位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR8000FF
    JRH赋值:2日内收盘价的最高值
    JRL赋值:2日内收盘价的最低值
    VAR01赋值:(收盘价>1日前的收盘价ANDCLOSE>2日前的收盘价)
    VAR02赋值:(1日前的VAR01ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR03赋值:(1日前的VAR02ANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VAR04赋值:(1日前的VAR03ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR05赋值:(1日前的VAR04ANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VAR06赋值:(1日前的VAR05ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR07赋值:(1日前的VAR06ANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VAR08赋值:(1日前的VAR07ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR09赋值:(1日前的VAR08ANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VARA赋值:(1日前的VAR09ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VARB赋值:(1日前的VARAANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VARC赋值:(1日前的VARBANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VARD赋值:(收盘价<1日前的收盘价ANDCLOSE<2日前的收盘价)
    VARE赋值:(1日前的VARDANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VARF赋值:(1日前的VAREANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR010赋值:(1日前的VARFANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VAR011赋值:(1日前的VAR010ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR012赋值:(1日前的VAR011ANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VAR013赋值:(1日前的VAR012ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR014赋值:(1日前的VAR013ANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VAR015赋值:(1日前的VAR014ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR016赋值:(1日前的VAR015ANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VAR017赋值:(1日前的VAR016ANDCLOSE<=1日前的收盘价ANDCLOSE>=2日前的收盘价)
    VAR018赋值:(1日前的VAR017ANDCLOSE>=1日前的收盘价ANDCLOSE<=2日前的收盘价)
    VAR019赋值:((1日前的VARDORVAREORVARFORVAR010ORVAR011ORVAR012ORVAR013ORVAR014ORVAR015ORVAR016ORVAR017ORVAR018)ANDVAR01)
    VAR1A赋值:((1日前的VAR01ORVAR02ORVAR03ORVAR04ORVAR05ORVAR06ORVAR07ORVAR08ORVAR09ORVARAORVARBORVARC)ANDVARD)
    红色持股赋值:VAR01ORVAR02ORVAR03ORVAR04ORVAR05ORVAR06ORVAR07ORVAR08ORVAR09ORVARAORVARBORVARC,COLOR0000FF,NODRAW
    离场赋值:如果红色持股,返回JRL,否则返回无效数
    明离场价赋值:离场,COLORFF99FF,NODRAW
    青色观望赋值:VARDORVAREORVARFORVAR010ORVAR011ORVAR012ORVAR013ORVAR014ORVAR015ORVAR016ORVAR017ORVAR018,COLORFFFF00,NODRAW
    进赋值:如果青色观望,返回JRH,否则返回无效数
    输出今离场价:1日前的离场,COLOR0000FF,NODRAW
    输出明进场价:进,COLOR33AACC,NODRAW
    输出今进场价:1日前的明进场价,画绿色,NODRAW
    输出必卖止损价位:G日前的A0,COLORFFFFFF,线宽为4
    总额赋值:成交额(元)
    买赋值:如果开盘价=CAND(收盘价-1日前的收盘价)/1日前的收盘价*100>9.8,返回成交额(元),否则返回成交额(元)/((最高价-最低价)*2-开盘价-收盘价的绝对值)*(收盘价-最低价)
    买%赋值:买/成交额(元)*100
    流入赋值:成交额(元)*买%/10000000000
    流出赋值:成交额(元)/100000000-流入
    净流赋值:(流入-流出)
    总额3赋值:成交额(元)的3日累和
    流入3赋值:流入的3日累和
    流出3赋值:流出的3日累和
    净流3赋值:流入-流出的3日累和
    总额5赋值:成交额(元)的5日累和
    流入5赋值:流入的5日累和
    流出5赋值:流出的5日累和
    净流5赋值:流入-流出的5日累和
    总额10赋值:成交额(元)的10日累和
    流入10赋值:流入的10日累和
    流出10赋值:流出的10日累和
    净流10赋值:流入-流出的10日累和
    画赋值:总额10在0日前的190天内第1个最高价的最后一日取值设为常数
    当满足条件1时,在横轴0.00纵轴0位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.06纵轴0位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.14纵轴0位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.20纵轴0位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.30纵轴0.00位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.36纵轴0.00位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.00纵轴0.05位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.06纵轴0.05位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.00纵轴0.10位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.06纵轴0.10位置书写文字COLOR00FFFF
    当满足条件1时,在横轴0.00纵轴0.15位置书写文字,画黄色
    当满足条件1时,在横轴0.06纵轴0.15位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.12纵轴0.15位置书写文字,画黄色
    当满足条件1时,在横轴0.17纵轴0.15位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.22纵轴0.15位置书写文字,画黄色
    当满足条件1时,在横轴0.26纵轴0.15位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.31纵轴0.15位置书写文字,画黄色
    当满足条件1时,在横轴0.38纵轴0.15位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.43纵轴0.15位置书写文字,画黄色
    当满足条件1时,在横轴0.47纵轴0.15位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.00纵轴0.19位置书写文字,画黄色
    当满足条件1时,在横轴0.06纵轴0.19位置书写文字,画黄色
    当满足条件1时,在横轴0.12纵轴0.19位置书写文字,画黄色
    当满足条件1时,在横轴0.18纵轴0.19位置书写文字,画黄色
    当满足条件1时,在横轴0.24纵轴0.19位置书写文字,画黄色
    当满足条件1时,在横轴0.08纵轴0.19位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.14纵轴0.19位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.20纵轴0.19位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.265纵轴0.19位置书写数字,COLOR0080FF
    当满足条件1时,在横轴0.00纵轴0.23位置书写文字,COLOR00FFFF
    当满足条件1时,在横轴0.06纵轴0.23位置书写文字,COLOR00FFFF
    VAR111赋值:收盘价13%的之字转向
    当满足条件(2日前的VAR111<1日前的VAR111)AND(VAR111<1日前的VAR111)时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR66FF00
    当满足条件当满足条件(2日前的VAR111<1日前的VAR111)AND(VAR111<1日前的VAR111)时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.时,在横轴0.00纵轴0.11位置书写文字,COLOR00FF00,线宽为1
    相对位置上画矩形
    超B赋值:成交额分档/10000.0
    大B赋值:成交额分档/10000.0
    中B赋值:成交额分档/10000.0
    小B赋值:成交额分档/10000.0
    超S赋值:成交额分档/10000.0
    大S赋值:成交额分档/10000.0
    中S赋值:成交额分档/10000.0
    小S赋值:成交额分档/10000.0
    如果满足条件取反不等于0,公式返回
    大宗进赋值:(超B)+(大B),NODRAW
    大宗出赋值:(超S)+(大S),NODRAW
    非大宗进赋值:(中B)+(小B),NODRAW
    非大宗出赋值:(中S)+(小S),NODRAW
    大宗进限制赋值:如果(超B+大B)=0,返回0,否则返回大宗进
    大宗出限制赋值:如果(超S+大S)=0,返回0,否则返回大宗出
    非大宗进限制赋值:如果中B+小B=0,返回0,否则返回非大宗进
    非大宗出限制赋值:如果中S+小S=0,返回0,否则返回非大宗出
    主力净流入赋值:(超B+大B)-(超S+大S),画红色,NODRAW
    散户净流入赋值:(中B+小B)-(中S+小S),画红色,NODRAW
    净流入赋值:(超B+大B+中B+小B)-(超S+大S+中S+小S),画红色,NODRAW
    大单流入赋值:(超B+大B)/(超B+大B+超S+大S)*100,NODRAW
    大单流入限制赋值:如果(超B+大B+超S+大S)=0,返回0,否则返回大单流入
    大单流出比赋值:(超S+大S)/(超B+大B+超S+大S)*100,NODRAW
    大单流出限制赋值:如果(超B+大B+超S+大S)=0,返回0,否则返回大单流出比
    总流入比赋值:(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW
    总流出比赋值:(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW
    成交总量赋值:(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW
    机构参与度赋值:(超B+超S+大B+大S)/成交总量*100,画黄色,NODRAW
    大单强度赋值:(超B+大B-超S-大S)/成交总量*100,画黄色,NODRAW
    大单强度限制赋值:如果大单强度=0,返回-100,否则返回大单强度
    大单强度比赋值:如果大单强度>=0,返回(大单强度限制+100)/2,否则返回100-(大单强度限制-100)/2的绝对值,NODRAW
    超单强度赋值:(超B-超S)/(超B+超S)*100,画黄色,NODRAW
    超单强度限制赋值:如果超单强度=0,返回-100,否则返回超单强度
    超单强度比赋值:如果超单强度>0,返回(超单强度限制+100)/2,否则返回如果超单强度<0,返回100-(超单强度限制-100)/2的绝对值,否则返回0,NODRAW
    DAZHIV赋值:大宗进的绝对值和大宗出的绝对值和非大宗进的绝对值和非大宗出的绝对值的较大值的较大值的较大值的最后一日取值设为常数,NODRAW
    相对位置上画矩形
    相对位置上画矩形
    相对位置上画矩形
    相对位置上画矩形
    相对位置上画矩形
    当满足条件到最后交易的周期=1时,在横轴0.0001纵轴0.9位置书写文字,画黄色
    当满足条件到最后交易的周期=1时,在横轴0.036纵轴0.9位置书写文字,画黄色
    当满足条件到最后交易的周期=1时,在横轴0.074纵轴0.9位置书写文字,画黄色
    当满足条件到最后交易的周期=1时,在横轴0.111纵轴0.9位置书写文字,画黄色
    当满足条件到最后交易的周期=1时,在横轴0.150纵轴0.9位置书写文字,画黄色
    当满足条件1时,在横轴0.000纵轴0.99位置书写文字,画洋红色
    当满足条件1时,在横轴0.078纵轴0.99位置书写文字,画青色
    当满足条件到最后交易的周期=1时,在横轴0.145纵轴0.99位置书写文字,画黄色
    主力买力度赋值:逐笔买入大单成交量*1000/成交量(手)
    主力卖力度赋值:逐笔卖出大单成交量*1000/成交量(手)
    AAD赋值:主力买力度的绝对值和主力卖力度的绝对值的较大值的最后一日取值设为常数*4,NODRAW
    相对位置上画矩形
    相对位置上画矩形
    当满足条件1时,在横轴0纵轴0.524位置书写文字,画黄色
    当满足条件1时,在横轴0纵轴0.576位置书写文字,画黄色
    DDX赋值:(逐笔买入大单成交量-逐笔卖出大单成交量)*1000/流通股本(股)
    DDY赋值:如果总成交单数>0,返回(逐笔卖出成交单数-逐笔买入成交单数)*100/总成交单数,否则返回0
    DDZ赋值:如果总成交单数>0,返回(逐笔买入大单成交单数-逐笔卖出大单成交单数)/总成交单数*100,否则返回0
    相对位置上画矩形
    相对位置上画矩形
    相对位置上画矩形
    当满足条件1时,在横轴0.153纵轴0.500位置书写文字,画黄色,画白色
    当满足条件1时,在横轴0.153纵轴0.548位置书写文字,画黄色,画白色
    当满足条件1时,在横轴0.153纵轴0.596位置书写文字,画黄色,画白色
    T1赋值:如果DDX>0ANDREF(DDX,1)<0,返回1,否则返回0
    T2赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)<0,返回2,否则返回T1
    T3赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)<0,返回3,否则返回T2
    T4赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)<0,返回4,否则返回T3
    T5赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)<0,返回5,否则返回T4
    T6赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)<0,返回6,否则返回T5
    T7赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)>0ANDREF(DDX,7)<0,返回7,否则返回T6
    T8赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)>0ANDREF(DDX,7)>0ANDREF(DDX,8)<0,返回8,否则返回T7
    T9赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)>0ANDREF(DDX,7)>0ANDREF(DDX,8)>0ANDREF(DDX,9)<0,返回9,否则返回T8
    T赋值:如果DDX>0ANDREF(DDX,1)>0ANDREF(DDX,2)>0ANDREF(DDX,3)>0ANDREF(DDX,4)>0ANDREF(DDX,5)>0ANDREF(DDX,6)>0ANDREF(DDX,7)>0ANDREF(DDX,8)>0ANDREF(DDX,9)>0,返回10,否则返回T9
    当满足条件1时,在横轴0.190纵轴0.500位置书写文字,画黄色
    T11赋值:如果DDY>0ANDREF(DDY,1)<0,返回1,否则返回0
    T21赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)<0,返回2,否则返回T11
    T31赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)<0,返回3,否则返回T21
    T41赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)<0,返回4,否则返回T31
    T51赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)<0,返回5,否则返回T41
    T61赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)<0,返回6,否则返回T51
    T71赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)>0ANDREF(DDY,7)<0,返回7,否则返回T61
    T81赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)>0ANDREF(DDY,7)>0ANDREF(DDY,8)<0,返回8,否则返回T71
    T91赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)>0ANDREF(DDY,7)>0ANDREF(DDY,8)>0ANDREF(DDY,9)<0,返回9,否则返回T81
    TY01赋值:如果DDY>0ANDREF(DDY,1)>0ANDREF(DDY,2)>0ANDREF(DDY,3)>0ANDREF(DDY,4)>0ANDREF(DDY,5)>0ANDREF(DDY,6)>0ANDREF(DDY,7)>0ANDREF(DDY,8)>0ANDREF(DDY,9)>0,返回10,否则返回T91
    当满足条件1时,在横轴0.190纵轴0.548位置书写文字,画黄色
    T1Z赋值:如果DDZ>0ANDREF(DDZ,2)<0,返回1,否则返回0
    T2Z赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)<0,返回2,否则返回T1Z
    T3Z赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)<0,返回3,否则返回T2Z
    T4Z赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)<0,返回4,否则返回T3Z
    T5Z赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)<0,返回5,否则返回T4Z
    T6Z赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)<0,返回6,否则返回T5Z
    T7Z赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)>0ANDREF(DDZ,7)<0,返回7,否则返回T6Z
    T8Z赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)>0ANDREF(DDZ,7)>0ANDREF(DDZ,8)<0,返回8,否则返回T7Z
    T9Z赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)>0ANDREF(DDZ,7)>0ANDREF(DDZ,8)>0ANDREF(DDZ,9)<0,返回9,否则返回T8Z
    TZ赋值:如果DDZ>0ANDREF(DDZ,1)>0ANDREF(DDZ,2)>0ANDREF(DDZ,3)>0ANDREF(DDZ,4)>0ANDREF(DDZ,5)>0ANDREF(DDZ,6)>0ANDREF(DDZ,7)>0ANDREF(DDZ,8)>0ANDREF(DDZ,9)>0,返回10,否则返回T9Z
    当满足条件1时,在横轴0.190纵轴0.596位置书写文字,画黄色
    DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
    DEA赋值:DIF的9日指数移动平均
    MACD赋值:(DIF-DEA)*2
    VAR113赋值:60日内最高价的最高值
    VAR114赋值:30日内最低价的最低值
    VAR115赋值:(收盘价-收盘价的32日简单移动平均)/收盘价的32日简单移动平均*100
    VAR116赋值:(VAR113+VAR114+VAR115)/3
    VAR117赋值:VAR116的5日指数移动平均
    K01赋值:VAR117的5日指数移动平均*2,COLORFF00FF
    D01赋值:K01的5日指数移动平均,画白色
    J01赋值:K01*3-D01*2,画黄色
    ENTERLONG赋值:K01上穿D01
    EXITLONG赋值:D01上穿K01
    B01赋值:(当满足条件(收盘价5%的之字转向>1日前的收盘价5%的之字转向)AND(1日前的收盘价5%的之字转向<=2日前的收盘价5%的之字转向)AND(2日前的收盘价5%的之字转向<=3日前的收盘价5%的之字转向)时,在最低价*0.98位置画1号图标)*D01*2/3
    B02赋值:如果收盘价15%之字转向的前1个波谷位置=1ANDHIGH>最低价+0.01,返回20,否则返回0
    必买赋值:(B01ANDB02)AND净流入>0
    必卖赋值:如果收盘价15%之字转向的前1个波峰位置=1,返回80,否则返回100,画绿色,线宽为1
    QQ赋值:必卖=80
    B03赋值:((收盘价5%的之字转向>1日前的收盘价5%的之字转向)AND(1日前的收盘价5%的之字转向<=2日前的收盘价5%的之字转向)AND(2日前的收盘价5%的之字转向<=3日前的收盘价5%的之字转向))
    V1赋值:收盘价的60日指数移动平均-收盘价的300日指数移动平均
    V2赋值:V1的300日指数移动平均
    V3赋值:(收盘价-(最低价,8))/((最高价,8)-8日内最低价的最低值)*100
    V4赋值:V3的2日[1日权重]移动平均,NODRAW
    V5赋值:V4的2日[1日权重]移动平均,NODRAW
    V6赋值:收盘价/3日前的收盘价>=1.1
    V7赋值:若V6则将最近3周期置为1
    大涨赋值:(V7ANDCOUNT(V7,3)=1)
    当满足条件必买时,在最低价-0.16位置画11号图标
    当满足条件大涨AND必买时,在最低价-0.16位置画9号图标
    当满足条件大涨时,在最低价-0.18位置画1号图标
    当满足条件QQ时,在最高价+0.1位置画6号图标




通达信坐等涨停指标公式截图

最新发布

相关文章

神奇指标广告