指标资讯
神奇指标广告
通达信涨停画线指标公式
来源:神奇指标 发布时间:2023-06-15

  

以下是通达信涨停画线指标公式源码和注释翻译结果


使用说明:


   绘制涨停线:当最高价等于最低价时,通过涨停画线指标在股票的K线图上绘制一条水平线。这条线代表了股票的涨停价位,通常在股票价格上方绘制。

   涨停板分析:当股票价格触及或突破涨停线时,可以判断该股票出现了涨停板。涨停板通常是市场短期内热点股票的表现,因此可以关注该股票的交易活跃度和市场情绪变化。

   趋势判断:涨停画线指标还可以用于判断股票价格的趋势变化。当股票连续多次触及或突破涨停线时,可能意味着股票处于强势上涨的趋势,投资者可以关注该股票的进一步走势。


通达信涨停画线指标公式源码:


    N:=33;
    UR:=6;
    LR:=6;
    TC1:=IF(H=HHV(H,8*UR),H,DRAWNULL);
    TC2:=CONst(BArslAST(TC1=H))+1;
    UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
    BC1:=IF(L=LLV(L,8*LR),L,DRAWNULL);
    BC2:=CONST(BARSLAST(BC1=L))+1;
    LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
    LP:=CURRBARSCOUNT<=BC2ANDL=LOWER;{低点定位}
    HP:=CURRBARSCOUNT<=TC2ANDH=UPPER;{高点定位}
    STICKLINE(IF(BC2>TC2,HP,LP),LOWER,UPPER,0,0),COLOR628962;{右侧竖线}
    STICKLINE(IF(BC2>TC2,LP,HP),LOWER,UPPER,0,0),COLOR628962;{左侧竖线}
    NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2));{用时}
    LR1:=FORCAST(C,NOD+1);
    NP:IF(CURRBARSCOUNT<=maX(BC2,TC2),CONST(IF(MIN(TC2,BC2)=1,LR1,REF(LR1,MIN(TC2,BC2)-1))),DRAWNULL),POINTDOT,COLORFFFFFF;{近点}
    LR2:=SLOPE(C,NOD+1);
    LR3:=CONST(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)-1)));
    FP:NP-LR3*(NOD),POINTDOT,COLORFFFFFF;{远点}
    EQU:(NP+FP)/2,POINTDOT,COLORFFFFFF;{中点}
    AD:=Abs(NP-FP);{高差};
    DBL:=BARSLAST(BC1!=DRAWNULL)+1;
    DBH:=BARSLAST(TC1!=DRAWNULL)+1;
    BSP:=IF(BC2>TC2,DBL,DBH)-1;
    LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP);
    AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2)ANDH>LRL,H,LRL);
    AT2:=HHV(AT1-LRL,MAX(BC2,TC2));
    AT3:=CONST(BARSLAST(AT1-LRL=AT2));
    AT4:=CONST(IF(AT3=0,H,REF(H,AT3)));
    AT5:=CONST(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)));
    ATL:=LRL+AT5;
    UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2)ANDL<LRL,L,LRL);
    UT2:=HHV(LRL-UT1,MAX(BC2,TC2));
    UT3:=CONST(BARSLAST(LRL-UT1=UT2));
    UT4:=CONST(IF(UT3=0,H,REF(H,UT3)));
    UT5:=CONST(IF(UT3=0,LRL-UT1,REF(LRL-UT1,UT3)));
    UTL:=LRL-UT5;
    RH:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,ATL,CONST(REF(ATL,MIN(BC2,TC2)-11)));
    RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,CONST(REF(UTL,MIN(BC2,TC2)-11)));
    {IF(NP>FP,IF(LRL<=RH,LRL,DRAWNULL),IF(LRL>=RL,LRL,DRAWNULL)),COLORRED;}{中轨画线}
    IF(NP>FP,IF(ATL<=RH,ATL,DRAWNULL),IF(ATL>=RL,ATL,DRAWNULL)),COLORYELLOW;{上轨画线}
    IF(NP>FP,IF(UTL<=RH,UTL,DRAWNULL),IF(UTL>=RL,UTL,DRAWNULL)),COLORFFFFFF;{下轨画线};
    猎手:(EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100,COLORSTICK;
    主力:EXPMA((EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100,120)-0.0004,LINETHICK5,COLORMAGENTA;
    散户:EXPMA((EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100,200),LINETHICK5,COLORGREEN;
    DRAWICON(CROSS(EXPMA(猎手,120)-0.0004,EXPMA(猎手,200)),EXPMA(猎手,200)*1,34);
    DRAWICON(CROSS(EXPMA(猎手,200),EXPMA(猎手,120)-0.0004),EXPMA(猎手,200)*1,35);
    Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);
    Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));
    DRAWICON(CROSS((C/Q2),1.03),0.02,5);
    STICKLINE(CROSS((C/Q2),1.03),0.02,0,4,0)COLORYELLOW;






通达信涨停画线指标公式源码注释翻译结果



    N赋值:33
    UR赋值:6
    LR赋值:6
    TC1赋值:如果最高价=8*UR日内最高价的最高值,返回最高价,否则返回无效数
    TC2赋值:上次TC1=最高价距今天数的最后一日取值设为常数+1
    UPPER赋值:如果TC2=1,返回最高价,否则返回TC2-1日前的最高价的最后一日取值设为常数
    BC1赋值:如果最低价=8*LR日内最低价的最低值,返回最低价,否则返回无效数
    BC2赋值:上次BC1=最低价距今天数的最后一日取值设为常数+1
    LOWER赋值:如果BC2=1,返回最低价,否则返回BC2-1日前的最低价的最后一日取值设为常数
    LP赋值:到最后交易的周期<=BC2ANDL=LOWER
    HP赋值:到最后交易的周期<=TC2ANDH=UPPER
    当满足条件如果BC2>TC2,返回HP,否则返回LP时,在LOWER和UPPER位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR628962
    当满足条件如果BC2>TC2,返回LP,否则返回HP时,在LOWER和UPPER位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR628962
    NOD赋值:(如果TC2>BC2,返回TC2,否则返回BC2-如果TC2>BC2,返回BC2,否则返回TC2)
    LR1赋值:收盘价的NOD+1日线性回归预测值
    输出NP:如果到最后交易的周期<=BC2和TC2的较大值,返回如果TC2和BC2的较小值=1,返回LR1,否则返回TC2和BC2的较小值-1日前的LR1的最后一日取值设为常数,否则返回无效数,POINTDOT,COLORFFFFFF
    LR2赋值:收盘价的NOD+1日线性回归斜率
    LR3赋值:如果TC2和BC2的较小值=1,返回LR2,否则返回TC2和BC2的较小值-1日前的LR2的最后一日取值设为常数
    输出FP:NP-LR3*(NOD),POINTDOT,COLORFFFFFF
    输出EQU:(NP+FP)/2,POINTDOT,COLORFFFFFF
    AD赋值:NP-FP的绝对值
    DBL赋值:上次BC1不等于无效数距今天数+1
    DBH赋值:上次TC1不等于无效数距今天数+1
    BSP赋值:如果BC2>TC2,返回DBL,否则返回DBH-1
    LRL赋值:如果NP>FP,返回FP+AD/NOD*BSP,否则返回FP-AD/NOD*BSP
    AT1赋值:如果到最后交易的周期位于BC2和TC2之间ANDH>LRL,返回最高价,否则返回LRL
    AT2赋值:BC2和TC2的较大值日内AT1-LRL的最高值
    AT3赋值:上次AT1-LRL=AT2距今天数的最后一日取值设为常数
    AT4赋值:如果AT3=0,返回最高价,否则返回AT3日前的最高价的最后一日取值设为常数
    AT5赋值:如果AT3=0,返回AT1-LRL,否则返回AT3日前的AT1-LRL的最后一日取值设为常数
    ATL赋值:LRL+AT5
    UT1赋值:如果到最后交易的周期位于BC2和TC2之间ANDL<LRL,返回最低价,否则返回LRL
    UT2赋值:BC2和TC2的较大值日内LRL-UT1的最高值
    UT3赋值:上次LRL-UT1=UT2距今天数的最后一日取值设为常数
    UT4赋值:如果UT3=0,返回最高价,否则返回UT3日前的最高价的最后一日取值设为常数
    UT5赋值:如果UT3=0,返回LRL-UT1,否则返回UT3日前的LRL-UT1的最后一日取值设为常数
    UTL赋值:LRL-UT5
    RH赋值:如果到最后交易的周期>=BC2和TC2的较小值-10,返回ATL,否则返回BC2和TC2的较小值-11日前的ATL的最后一日取值设为常数
    RL赋值:如果到最后交易的周期>=BC2和TC2的较小值-10,返回UTL,否则返回BC2和TC2的较小值-11日前的UTL的最后一日取值设为常数
    如果NP>FP,返回如果ATL<=RH,返回ATL,否则返回无效数,否则返回如果ATL>=RL,返回ATL,否则返回无效数,画黄色
    如果NP>FP,返回如果UTL<=RH,返回UTL,否则返回无效数,否则返回如果UTL>=RL,返回UTL,否则返回无效数,COLORFFFFFF
    输出猎手:(收盘价的500日指数移动平均-1日前的收盘价的500日指数移动平均)/1日前的收盘价的500日指数移动平均*100,COLORSTICK
    输出主力:(收盘价的500日指数移动平均-1日前的收盘价的500日指数移动平均)/1日前的收盘价的500日指数移动平均*100的120日指数移动平均-0.0004,线宽为5,画洋红色
    输出散户:(收盘价的500日指数移动平均-1日前的收盘价的500日指数移动平均)/1日前的收盘价的500日指数移动平均*100的200日指数移动平均,线宽为5,画绿色
    当满足条件猎手的120日指数移动平均-0.0004上穿猎手的200日指数移动平均时,在猎手的200日指数移动平均*1位置画34号图标
    当满足条件猎手的200日指数移动平均上穿猎手的120日指数移动平均-0.0004时,在猎手的200日指数移动平均*1位置画35号图标
    Q赋值:收盘价/(成交额(元)的收盘价的有效数据周期数日累和/成交量(手)*100的收盘价的有效数据周期数日累和)位于1.05和0.95之间
    Q2赋值:如果Q=0,返回收盘价的收盘价的有效数据周期数日简单移动平均,否则返回(成交额(元)的收盘价的有效数据周期数日累和/成交量(手)*100的收盘价的有效数据周期数日累和)
    当满足条件(收盘价/Q2)上穿1.03时,在0.02位置画5号图标
    当满足条件(收盘价/Q2)上穿1.03时,在0.02和0位置之间画柱状线,宽度为4,0不为0则画空心柱.画黄色



通达信涨停画线指标公式截图

最新发布

相关文章

神奇指标广告