指标资讯
神奇指标广告
通达信神龙必胜指标公式
来源:神奇指标 发布时间:2023-06-15

  

以下是通达信神龙必胜指标公式源码和注释翻译结果


使用说明:

   买入信号:当短期移动平均线上穿长期移动平均线,并且RSI指标处于低位(通常低于30)时,产生买入信号。这意味着股票价格可能即将反转并向上走势。

   卖出信号:当短期移动平均线下穿长期移动平均线,并且RSI指标处于高位(通常高于70)时,产生卖出信号。这意味着股票价格可能即将反转并向下走势。

   停损点:当股票价格在买入后下跌一定幅度(通常为买入价格的一定比例)时,建议设置止损点,以保护投资。


通达信神龙必胜指标公式源码:



    {大阴线:大跌超2.3}C2:=REF(C,1);
    BG:=IF((C2-C)*100/C2>=2.3,1,0)ORIF((O-C)*100/O>=5,1,0){ORIF((H-L)*100/REF(C,1)>5,1,0)};
    {第二个条件开盘价过高掉下来}BG2:=IF((H-L)*100/C2>=3.58,1,0);
    BB1:=L<REF(L,1);
    {卖点信号}SELL1:=BGANDBB1;
    {大阳线:升幅超2.64}BR:=IF((C-C2)*100/C2>=2.59,1,0)ORIF((C-O)*100/O>=4.5,1,0)ORIF((C-L)*100/L>5,1,0);
    {第二个条件开盘价太低升上来}{stICKLINE(BR,O,C,3,0),COLORRED;
    }{以下条件记住最近一次卖出点}DAY1:=BArslAST(SELL1);
    JIA1:=REF(O,DAY1);
    JIA2:=REF(O,1);
    BB4:=C>JIA2;
    BB2:=H>JIA1;
    {买入信号}BUY1:=BRANDBB2ANDBB4;
    {记住最后一次买点}DAY2:=BARSLAST(BUY1);
    {买卖谁先}S1:=DAY1<DAY2;
    B1:=DAY2<DAY1;
    {其它补充1:买点}AA2:=AMOUNT/vol;
    BB3:=L1.2;
    DD2:=L<ma(C,6)*0.921;
    DD1:=L<MA(C,5)*0.921;
    EE2:=VOL<MA(V,5)*1.5;
    FF2:=BB3ANDCC2ANDDD2ANDEE2;
    老鼠仓:=BB3ANDCC2ANDDD1ANDEE2,LINETHICK0,COLOR0099FF;
    DRAWTEXT(老鼠仓,L*0.97,'老鼠仓'),COLOR0099FF;
    DRAWTEXT(FF2,L*0.99,'买点'),COLOR00FFFF;
    {STICKLINE(FF2,H,L,0.3,0),COLOR00FFFF;
    STICKLINE(FF2,O,C,3,1),LINETHICK2,COLOR00FFFF;
    }{检查买点是否成立}B4:=BARSLAST(FF2);
    {底点日期}E4:=B4<5;
    {5日内的线}F4:=E4ANDC>REF(C,1);
    {STICKLINE(F4,H,L,0.3,0),COLOR00FFFF;
    }{其它补充2:卖点}A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
    A3:=H>MA(C,5)*1.12;
    AA:=A2ANDA3;
    DRAWTEXT(AA,H*1.05,'卖点'),COLORFF0000;
    {STICKLINE(AA,H,L,0.3,0),COLORFF0000;
    STICKLINE(AA,H,L,3,0),COLORFF0000;
    };
    {补充阳光买点}VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
    VAR2:=8;
    CC:=crOSS(VAR1,VAR2);
    CCC:=CROSS(VAR1,VAR2)ANDH>REF(H,1)ANDC>REF(C,1);
    DRAWICON(CCC,L*0.99,1);
    {STICKLINE(CC,H,L,0.3,0),COLORRED;
    STICKLINE(CC,O,C,3,1),LINETHICK2,COLORRED;
    }{加强买点后续升势}CF1:=BARSLAST(CC);
    {买点日期}CF2:=CF1<3;
    {5日内的线}CF3:=CF2ANDC>REF(C,1);
    {STICKLINE(CF3,O,C,3,0),COLOR00FFFF;
    }CD:=CROSS(VAR2,VAR1);
    {STICKLINE(CD,H,L,0.3,0),COLORYELLOW;
    STICKLINE(CD,O,C,3,1),LINETHICK2,COLORYELLOW;
    }DRAWTEXT(CD,H*1.01,'准备'),COLORYELLOW;
    DRAWTEXT(CC,L*0.98,'买'),COLORFF00FF;
    {输出粉红色的买字};
    {牛窝}VAR1A:=LLV(LOW,21);
    VAR2A:=HHV(HIGH,21);
    AK1:=EMA((((CLOSE-VAR1A)/(VAR2A-VAR1A))*100),5);
    AK:=EMA((((CLOSE-VAR1A)/(VAR2A-VAR1A))*50),13);
    AB:=CROSS(AK1,AK);
    DRAWTEXT((AB=1),(LOW*0.95),'○牛窝'),COLORYELLOW;
    {大胆博、加仓、小心变盘、逃顶}VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
    VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05)AND((HIGH)/(CLOSE)<1.01)AND(VAR3AA>0),91,0);
    DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏'),COLOR00FFFF;
    DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;
    A1AA:=9;
    A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
    DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;
    VAR6:=REF(C,1);
    VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(Abs(C-VAR6),6,1)*100;
    DRAWTEXT(CROSS(82,VAR7),H*1.02,'逃顶'),COLORYELLOW;
    {主力进场}VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
    VAR10:=SMA(VAR9,3,1);
    VAR11:=SMA(VAR10,3,1);
    VAR12:=SMA(VAR11,3,1);
    主力出现:DRAWICON(CROSS(VAR11,VAR12)AND(VAR11<40),L*0.98,1);
    {黑马}A1A:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;
    A5A:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
    DRAWTEXT(CROSS(A1A,EMA(A1A,5))ANDEMA(A1A,5)81ANDVV3<80,HIGH,2);
    VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
    DRAWTEXT(IF(CLOSE<VF1ANDVOL/240>MA(VOL,5)/240ANDCLOSE>=REF(CLOSE,1)*1.08ANDCLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORRED;
    VVARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
    VVARB:=EMA(0.667*REF(VVARA,1)+0.333*VVARA,5);
    DRAWTEXT(IF(VOL>=1.3*MA(VOL,5)ANDCOUNT(VVARA>=VVARBANDVVARA<-17,3)ANDREF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');
    VVARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
    DRAWICON(CROSS(82,VVARR1),HIGH,2);
    DRAWTEXT(CROSS(82,VVARR1),HIGH,''),COLORYELLOW;
    VVAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
    VVAR2:=REF(VVAR1,1);
    VVAR3:=SMA(MAX(VVAR1-VVAR2,0),10,1)/SMA(ABS(VVAR1-VVAR2),10,1)*100;
    HY3:=IF(COUNT(VVAR3<20,5)>=1ANDCOUNT(VVAR1=LLV(VVAR1,10),10)>=1ANDCLOSE>=OPEN*1.038ANDVOL>MA(VOL,5)*1.2,1,0);
    DRAWTEXT(HY3,LOW,'注意买入'),COLORRED;
    DRAWGBK(CLOSE>0,RGB(0,0,0),RGB(20,58,120),0,61,0);
    X_1:=MA(CLOSE,13);
    X_2:=100-ABS((CLOSE-X_1)/X_1*100);
    X_3:=LLV(LOW,75);
    X_4:=HHV(HIGH,75);
    X_5:=(X_4-X_3)/100;
    X_6:=SMA((CLOSE-X_3)/X_5,20,1);
    X_7:=SMA((OPEN-X_3)/X_5,20,1);
    X_8:=3*X_6-2*SMA(X_6,15,1);
    X_9:=3*X_7-2*SMA(X_7,15,1);
    X_10:=100-X_9;
    X_11:=100-X_8;
    X_12:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
    X_13:=EMA(X_12,5);
    DRAWBAND(IF(X_13-X_11>=0,X_13-X_11,0),RGB(150,90,50),0,RGB(50,50,50));
    X_14:=(2*CLOSE+HIGH+LOW)/4;
    X_15:=LLV(LOW,34);
    X_16:=HHV(HIGH,34);
    X_17:=MAX((X_14-X_15)/(X_16-X_15)*100,8);
    X_18:=SMA(X_17,8,1);
    X_19:=SMA(X_18,5,1);
    DRAWBAND(X_18,RGB(250,248,0),X_19,RGB(0,118,0));
    J:3*X_18-2*X_19,COLORMAGENTA;
    IF(EMA(((2*CLOSE+HIGH+LOW+OPEN)/5-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,60))/(HHV((2*CLOSE+HIGH+LOW+OPEN)/5,60)-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,60)),2)*100>90OREMA(((2*CLOSE+HIGH+LOW+OPEN)/5-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,15))/(HHV((2*CLOSE+HIGH+LOW+OPEN)/5,15)-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,15)),2)*100>95ANDJ>80,J,DRAWNULL),COLORGREEN,LINETHICK2;
    IF(EMA(((2*CLOSE+HIGH+LOW+OPEN)/5-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,60))/(HHV((2*CLOSE+HIGH+LOW+OPEN)/5,60)-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,60)),2)*100<10OREMA(((2*CLOSE+HIGH+LOW+OPEN)/5-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,15))/(HHV((2*CLOSE+HIGH+LOW+OPEN)/5,15)-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,15)),2)*100<5ANDJ<5,J,DRAWNULL),COLORYELLOW,LINETHICK2;
    X_20:=SMA(CLOSE,2,1);
    X_21:=SMA(MAX(CLOSE-X_20,0),6,1)/SMA(ABS(CLOSE-X_20),6,1)*100;
    X_22:=SMA(HIGH,2,1);
    X_23:=SMA(MAX(HIGH-X_22,0),6,1)/SMA(ABS(HIGH-X_22),6,1)*100;
    X_24:=SMA(OPEN,2,1);
    X_25:=SMA(MAX(OPEN-X_24,0),6,1)/SMA(ABS(OPEN-X_24),6,1)*100;
    X_26:=SMA(LOW,2,1);
    X_27:=SMA(MAX(LOW-X_26,0),6,1)/SMA(ABS(LOW-X_26),6,1)*100;
    X_28:=SMA(10000*CLOSE/INDEXC,2,1);
    X_29:=SMA(MAX(10000*CLOSE/INDEXC-X_28,0),6,1)/SMA(ABS(10000*CLOSE/INDEXC-X_28),6,1)*100;
    X_30:=(X_21+X_25+X_23+X_27+X_29)/5;
    X_31:=EMA(EMA(X_30,6),5);
    底部【机会区】:IF(X_30<=15ANDX_31<=15,J,DRAWNULL),COLORRED,LINETHICK3;
    顶部【风险区】:IF(X_30>=85ANDX_31>=80,J,DRAWNULL),COLORWHITE,LINETHICK3;
    控仓(险):EMA(WINNER(CLOSE)*100,5)>85ANDX_18>85OR(EMA(WINNER(CLOSE)*100,5)>90ORX_18>90),NODRAW,COLORCYAN;
    STICKLINE(控仓(险),J,85,0,1),COLORCYAN,LINETHICK3;
    X_32:=REF(LOW,1)*0.9;
    X_33:=EMA(X_32,30);
    X_34:=CLOSE-REF(CLOSE,1);
    X_35:=MAX(X_34,0);
    X_36:=ABS(X_34);
    X_37:=SMA(X_35,7,1)/SMA(X_36,7,1)*100;
    X_38:=SMA(X_35,13,1)/SMA(X_36,13,1)*100;
    X_39:=BARSCOUNT(CLOSE);
    X_40:=SMA(MAX(X_34,0),6,1)/SMA(ABS(X_34),6,1)*100;
    X_41:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
    X_42:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
    X_43:=SMA((SMA(X_42,4,1)-50)*2,3,1);
    X_44:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
    X_45:=SMA(X_44,4,1);
    X_46:=SMA(X_45,3,1);
    X_47:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
    神龙大底:(X_40<=25ANDX_41<(-95)ANDX_47>20ANDX_43<(-30)ANDX_46<30ANDX_33-CLOSE>=(-0.25)ANDX_37<22ANDX_38<28ANDX_39>50)*50,COLORYELLOW;
    X_48:=VOL/REF(VOL,1)>=1.91ANDCLOSE>REF(CLOSE,1)ANDCLOSE>OPEN;
    X_49:=VOL>=HHV(VOL,21);
    X_50:=X_48ANDX_49;
    倍量反弹:(X_30<=15ANDX_31<=15ANDX_50)*70,COLORGREEN;
    X_51:=BARSLAST(MONTH!=REF(MONTH,1))+1;
    月±%:(CLOSE/REF(CLOSE,X_51)-1)*100,NODRAW,COLORRED;





通达信神龙必胜指标公式源码注释翻译结果



    C2赋值:1日前的收盘价
    BG赋值:如果(C2-收盘价)*100/C2>=2.3,返回1,否则返回0ORIF((开盘价-收盘价)*100/开盘价>=5,1,0)
    BG2赋值:如果(最高价-最低价)*100/C2>=3.58,返回1,否则返回0
    BB1赋值:最低价<1日前的最低价
    SELL1赋值:BGANDBB1
    BR赋值:如果(收盘价-C2)*100/C2>=2.59,返回1,否则返回0ORIF((收盘价-开盘价)*100/开盘价>=4.5,1,0)ORIF((收盘价-最低价)*100/最低价>5,1,0)
    DAY1赋值:上次SELL1距今天数
    JIA1赋值:DAY1日前的开盘价
    JIA2赋值:1日前的开盘价
    BB4赋值:收盘价>JIA2
    BB2赋值:最高价>JIA1
    BUY1赋值:BRANDBB2ANDBB4
    DAY2赋值:上次BUY1距今天数
    S1赋值:DAY1<DAY2
    B1赋值:DAY2<DAY1
    AA2赋值:成交额(元)/成交量(手)
    BB3赋值:L1.2
    DD2赋值:最低价<收盘价的6日简单移动平均*0.921
    DD1赋值:最低价<收盘价的5日简单移动平均*0.921
    EE2赋值:成交量(手)<成交量(手)的5日简单移动平均*1.5
    FF2赋值:BB3ANDCC2ANDDD2ANDEE2
    老鼠仓赋值:BB3ANDCC2ANDDD1ANDEE2,线宽为0,COLOR0099FF
    当满足条件老鼠仓时,在最低价*0.97位置书写文字,COLOR0099FF
    当满足条件FF2时,在最低价*0.99位置书写文字,COLOR00FFFF
    B4赋值:上次FF2距今天数
    E4赋值:B4<5
    F4赋值:E4ANDC>1日前的收盘价
    A2赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100<1.02
    A3赋值:最高价>收盘价的5日简单移动平均*1.12
    AA赋值:A2ANDA3
    当满足条件AA时,在最高价*1.05位置书写文字,COLORFF0000
    VAR1赋值:4*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均-3*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均的3.2日[1日权重]移动平均
    VAR2赋值:8
    CC赋值:VAR1上穿VAR2
    CCC赋值:VAR1上穿VAR2ANDH>1日前的最高价ANDC>1日前的收盘价
    当满足条件CCC时,在最低价*0.99位置画1号图标
    CF1赋值:上次CC距今天数
    CF2赋值:CF1<3
    CF3赋值:CF2ANDC>1日前的收盘价
    CD赋值:VAR2上穿VAR1
    当满足条件CD时,在最高价*1.01位置书写文字,画黄色
    当满足条件CC时,在最低价*0.98位置书写文字,COLORFF00FF
    VAR1A赋值:21日内最低价的最低值
    VAR2A赋值:21日内最高价的最高值
    AK1赋值:(((收盘价-VAR1A)/(VAR2A-VAR1A))*100)的5日指数移动平均
    AK赋值:(((收盘价-VAR1A)/(VAR2A-VAR1A))*50)的13日指数移动平均
    AB赋值:AK1上穿AK
    当满足条件(AB=1)时,在(最低价*0.95)位置书写文字,画黄色
    VAR3AA赋值:如果(收盘价>1日前的收盘价),返回88,否则返回0
    VAR4AA赋值:如果((收盘价)/(1日前的收盘价)>1.05)AND((最高价)/(收盘价)<1.01)AND(VAR3AA>0),返回91,否则返回0
    当满足条件(VAR4AA>90)的45日过滤时,在(最低价)*(0.93)位置书写文字,COLOR00FFFF
    当满足条件(VAR4AA>90)的35日过滤时,在(最低价)*(0.99000001)位置书写文字,COLOR00FFFF
    A1AA赋值:9
    A2AA赋值:(A1AA+1日前的收盘价<收盘价)
    当满足条件(A2AA>-0.5)的84日过滤时,在(最高价)*(1.05)位置书写文字,COLORFFFFFF
    VAR6赋值:1日前的收盘价
    VAR7赋值:收盘价-VAR6和0的较大值的6日[1日权重]移动平均/收盘价-VAR6的绝对值的6日[1日权重]移动平均*100
    当满足条件82上穿VAR7时,在最高价*1.02位置书写文字,画黄色
    VAR9赋值:((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*(100)
    VAR10赋值:VAR9的3日[1日权重]移动平均
    VAR11赋值:VAR10的3日[1日权重]移动平均
    VAR12赋值:VAR11的3日[1日权重]移动平均
    输出主力出现:当满足条件VAR11上穿VAR12AND(VAR11<40)时,在最低价*0.98位置画1号图标
    A1A赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*1的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*1的5日[1日权重]移动平均,COLOR330066
    A5A赋值:(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)*1
    当满足条件A1A上穿A1A的5日指数移动平均ANDEMA(A1A,5)81ANDVV3<80时,在最高价位置书写文字
    VF1赋值:收盘价的60日简单移动平均-收盘价的5日简单移动平均/3.2
    当满足条件如果收盘价<VF1ANDVOL/240>成交量(手)的5日简单移动平均/240ANDCLOSE>=1日前的收盘价*1.08ANDCLOSE<收盘价的13日简单移动平均*1.3,返回1,否则返回0时,在最低价位置书写文字,画红色
    VVARA赋值:(收盘价-29日前的开盘价)/29日前的开盘价*100
    VVARB赋值:0.667*1日前的VVARA+0.333*VVARA的5日指数移动平均
    当满足条件如果成交量(手)>=1.3*成交量(手)的5日简单移动平均ANDCOUNT(VVARA>=VVARBANDVVARA<-17,3)ANDREF(最低价,1)=120日内最低价的最低值,返回1,否则返回0时,在最低价位置书写文字
    VVARR1赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100
    当满足条件82上穿VVARR1时,在最高价位置画2号图标
    当满足条件82上穿VVARR1时,在最高价位置书写文字,画黄色
    VVAR1赋值:(最高价+最低价+开盘价+2*收盘价)/5
    VVAR2赋值:1日前的VVAR1
    VVAR3赋值:VVAR1-VVAR2和0的较大值的10日[1日权重]移动平均/VVAR1-VVAR2的绝对值的10日[1日权重]移动平均*100
    HY3赋值:如果统计5日中满足VVAR3<20的天数>=1ANDCOUNT(VVAR1=10日内VVAR1的最低值,10)>=1ANDCLOSE>=开盘价*1.038ANDVOL>成交量(手)的5日简单移动平均*1.2,返回1,否则返回0
    当满足条件HY3时,在最低价位置书写文字,画红色
    填充背景
    0,自定色,自定色,0,61,0)
    X_1赋值:收盘价的13日简单移动平均
    X_2赋值:100-(收盘价-X_1)/X_1*100的绝对值
    X_3赋值:75日内最低价的最低值
    X_4赋值:75日内最高价的最高值
    X_5赋值:(X_4-X_3)/100
    X_6赋值:(收盘价-X_3)/X_5的20日[1日权重]移动平均
    X_7赋值:(开盘价-X_3)/X_5的20日[1日权重]移动平均
    X_8赋值:3*X_6-2*X_6的15日[1日权重]移动平均
    X_9赋值:3*X_7-2*X_7的15日[1日权重]移动平均
    X_10赋值:100-X_9
    X_11赋值:100-X_8
    X_12赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
    X_13赋值:X_12的5日指数移动平均
    画带状线
    =0,X_13-X_11,0),自定色,0,自定色)
    X_14赋值:(2*收盘价+最高价+最低价)/4
    X_15赋值:34日内最低价的最低值
    X_16赋值:34日内最高价的最高值
    X_17赋值:(X_14-X_15)/(X_16-X_15)*100和8的较大值
    X_18赋值:X_17的8日[1日权重]移动平均
    X_19赋值:X_18的5日[1日权重]移动平均
    画带状线
    输出J:3*X_18-2*X_19,画洋红色
    如果((2*收盘价+最高价+最低价+开盘价)/5-60日内(2*收盘价+最高价+最低价+开盘价)/5的最低值)/(60日内(2*收盘价+最高价+最低价+开盘价)/5的最高值-60日内(2*收盘价+最高价+最低价+开盘价)/5的最低值)的2日指数移动平均*100>,返回?,否则返回?
    90OREMA(((2*收盘价+最高价+最低价+开盘价)/5-15日内(2*收盘价+最高价+最低价+开盘价)/5的最低值)/(15日内(2*收盘价+最高价+最低价+开盘价)/5的最高值-15日内(2*收盘价+最高价+最低价+开盘价)/5的最低值),2)*100>
    95ANDJ>
    80,J,无效数),画绿色,线宽为2
    如果((2*收盘价+最高价+最低价+开盘价)/5-60日内(2*收盘价+最高价+最低价+开盘价)/5的最低值)/(60日内(2*收盘价+最高价+最低价+开盘价)/5的最高值-60日内(2*收盘价+最高价+最低价+开盘价)/5的最低值)的2日指数移动平均*100<,返回?,否则返回?
    10OREMA(((2*收盘价+最高价+最低价+开盘价)/5-15日内(2*收盘价+最高价+最低价+开盘价)/5的最低值)/(15日内(2*收盘价+最高价+最低价+开盘价)/5的最高值-15日内(2*收盘价+最高价+最低价+开盘价)/5的最低值),2)*100<
    5ANDJ<
    5,J,无效数),画黄色,线宽为2
    X_20赋值:收盘价的2日[1日权重]移动平均
    X_21赋值:收盘价-X_20和0的较大值的6日[1日权重]移动平均/收盘价-X_20的绝对值的6日[1日权重]移动平均*100
    X_22赋值:最高价的2日[1日权重]移动平均
    X_23赋值:最高价-X_22和0的较大值的6日[1日权重]移动平均/最高价-X_22的绝对值的6日[1日权重]移动平均*100
    X_24赋值:开盘价的2日[1日权重]移动平均
    X_25赋值:开盘价-X_24和0的较大值的6日[1日权重]移动平均/开盘价-X_24的绝对值的6日[1日权重]移动平均*100
    X_26赋值:最低价的2日[1日权重]移动平均
    X_27赋值:最低价-X_26和0的较大值的6日[1日权重]移动平均/最低价-X_26的绝对值的6日[1日权重]移动平均*100
    X_28赋值:10000*收盘价/大盘的收盘价的2日[1日权重]移动平均
    X_29赋值:10000*收盘价/大盘的收盘价-X_28和0的较大值的6日[1日权重]移动平均/10000*收盘价/大盘的收盘价-X_28的绝对值的6日[1日权重]移动平均*100
    X_30赋值:(X_21+X_25+X_23+X_27+X_29)/5
    X_31赋值:X_30的6日指数移动平均的5日指数移动平均
    输出底部【机会区】:如果X_30<,返回?,否则返回?
    =15ANDX_31<
    =15,J,无效数),画红色,线宽为3
    输出顶部【风险区】:如果X_30>,返回?,否则返回?
    =85ANDX_31>
    =80,J,无效数),画白色,线宽为3
    输出控仓(险):以收盘价计算的获利盘比例*100的5日指数移动平均>
    85ANDX_18>
    85OR(以收盘价计算的获利盘比例*100的5日指数移动平均>
    90ORX_18>
    90),NODRAW,画青色
    当满足条件控仓(险)时,在J和85位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色,线宽为3
    X_32赋值:1日前的最低价*0.9
    X_33赋值:X_32的30日指数移动平均
    X_34赋值:收盘价-1日前的收盘价
    X_35赋值:X_34和0的较大值
    X_36赋值:X_34的绝对值
    X_37赋值:X_35的7日[1日权重]移动平均/X_36的7日[1日权重]移动平均*100
    X_38赋值:X_35的13日[1日权重]移动平均/X_36的13日[1日权重]移动平均*100
    X_39赋值:收盘价的有效数据周期数
    X_40赋值:X_34和0的较大值的6日[1日权重]移动平均/X_34的绝对值的6日[1日权重]移动平均*100
    X_41赋值:(-200)*(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)+100
    X_42赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100
    X_43赋值:(X_42的4日[1日权重]移动平均-50)*2的3日[1日权重]移动平均
    X_44赋值:(大盘的收盘价-14日内大盘的最低价的最低值)/(14日内大盘的最高价的最高值-14日内大盘的最低价的最低值)*100
    X_45赋值:X_44的4日[1日权重]移动平均
    X_46赋值:X_45的3日[1日权重]移动平均
    X_47赋值:(30日内最高价的最高值-收盘价)/收盘价*100
    输出神龙大底:(X_40<
    =25ANDX_41<
    (-95)ANDX_47>
    20ANDX_43<
    (-30)ANDX_46<
    30ANDX_33-收盘价>
    =(-0.25)ANDX_37<
    22ANDX_38<
    28ANDX_39>
    50)*50,画黄色
    X_48赋值:成交量(手)/1日前的成交量(手)>
    =1.91ANDCLOSE>
    1日前的收盘价ANDCLOSE>
    开盘价
    X_49赋值:成交量(手)>
    =21日内成交量(手)的最高值
    X_50赋值:X_48ANDX_49
    输出倍量反弹:(X_30<
    =15ANDX_31<
    =15ANDX_50)*70,画绿色
    X_51赋值:上次月份不等于1日前的月份距今天数+1
    输出月±%:(收盘价/X_51日前的收盘价-1)*100,NODRAW,画红色




通达信神龙必胜指标公式截图

最新发布

相关文章

神奇指标广告