指标资讯
神奇指标广告
通达信至尊抄底指标公式
来源:神奇指标 发布时间:2023-06-15

  

以下是通达信至尊抄底指标公式源码和注释翻译结果



通达信至尊抄底指标公式源码:


    RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
    RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
    短线:SMA(Sma(RSV1,3,1),3,1)+3*stD(CLOSE,21),COLOR00FF00;
    中线:SMA(RSV2,5,1)+2*STD(CLOSE,37),COLORRED;
    RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
    长线:SMA(RSV3,5,1),COLORYELLOW;
    看底:STICKLINE(中线<15,中线,15,6,0),COLORF00FF0;
    黄金坑:STICKLINE(短线<20AND中线<20AND长线<20,MAX(长线,MAX(短线,中线)),20,8,0),COLOR00CCFF;
    看顶:STICKLINE(中线>80,80,中线,6,0),COLORFFF000;
    DRAWICON(crOSS(长线,15),中线,1);
    DRAWTEXT(LONGCROSS(中线,20,15),20,'追涨');
    DRAWTEXT(CROSS(短线,长线)AND长线<18AND长线>REF(长线,1)ORCROSS(长线,5),20,'千载难逢');
    粘合星:DRAWTEXT(Abs(中线-长线)<2AND中线>REF(中线,1),中线,'*');
    中线2:=-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40));
    底:DRAWTEXT(CROSS(中线2,-90)AND(长线<中线AND长线>REF(长线,1)OR短线<20AND中线<20AND长线<20),长线,'底'),COLORFF00FF;
    IF(COUNT(CROSS(中线2,-90),12)=3,30,5);
    IF(COUNT(CROSS(-5,中线2),12)=3ORCOUNT(CROSS(-15,中线2),6)=3,70,100);
    LOCK:=1;
    VAR1:=MA(CLOSE,1);
    VAR2:=MA(CLOSE,3);
    VAR3:MA(VAR2,1)*LOCK;
    VAR4:MA(VAR2,3)*LOCK;
    STICKLINE(VAR3>VAR4,VAR3,VAR4*LOCK,4,0),COLORFF00FF;
    STICKLINE(VAR3<VAR4,VAR3,VAR4*LOCK,3,0),COLOR00FF00;






通达信至尊抄底指标公式源码注释翻译结果


    RSV1赋值:(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100
    RSV2赋值:(收盘价-37日内最低价的最低值)/(37日内最高价的最高值-37日内最低价的最低值)*100
    输出短线:RSV1的3日[1日权重]移动平均的3日[1日权重]移动平均+3*收盘价的21日估算标准差,COLOR00FF00
    输出中线:RSV2的5日[1日权重]移动平均+2*收盘价的37日估算标准差,画红色
    RSV3赋值:(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100
    输出长线:RSV3的5日[1日权重]移动平均,画黄色
    输出看底:当满足条件中线<15时,在中线和15位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORF00FF0
    输出黄金坑:当满足条件短线<20AND中线<20AND长线<20时,在长线和短线和中线的较大值的较大值和20位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR00CCFF
    输出看顶:当满足条件中线>80时,在80和中线位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFFF000
    当满足条件长线上穿15时,在中线位置画1号图标
    当满足条件中线小于20保持15个交易日后交叉上穿时,在20位置书写文字
    当满足条件短线上穿长线AND长线<18AND长线>1日前的长线ORCROSS(长线,5)时,在20位置书写文字
    输出粘合星:当满足条件中线-长线的绝对值<2AND中线>1日前的中线时,在中线位置书写文字
    中线2赋值:-100*(40日内最高价的最高值-收盘价)/(40日内最高价的最高值-40日内最低价的最低值)
    输出底:当满足条件中线2上穿-90AND(长线<中线AND长线>1日前的长线OR短线<20AND中线<20AND长线<20)时,在长线位置书写文字,COLORFF00FF
    如果统计12日中满足中线2上穿-90的天数=3,返回30,否则返回5
    如果统计12日中满足-5上穿中线2的天数=3ORCOUNT(-15上穿中线2,6)=3,返回70,否则返回100
    LOCK赋值:1
    VAR1赋值:收盘价的1日简单移动平均
    VAR2赋值:收盘价的3日简单移动平均
    输出VAR3:VAR2的1日简单移动平均*LOCK
    输出VAR4:VAR2的3日简单移动平均*LOCK
    当满足条件VAR3>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.
    VAR4,VAR3,VAR4*LOCK,4,0),COLORFF00FF
    当满足条件VAR3<时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.
    VAR4,VAR3,VAR4*LOCK,3,0),COLOR00FF00




通达信至尊抄底指标公式截图



最新发布

相关文章

神奇指标广告